Page 1 of 3

Help a newbie please! (PSP-3000)

Posted: Tue Feb 24, 2015 12:03 pm
by SopaXorzTaker
Hello! I'm completely new to PSP hacking, can I downgrade PSP with the following parameters:

TA-095v2 (09g)
Date Code (under battery): 1C
PSP-3008 Brite
FW 6.61 OFW.

Re: Help a newbie please! (PSP-3000)

Posted: Tue Feb 24, 2015 12:10 pm
by BlumCoLe

Re: Help a newbie please! (PSP-3000)

Posted: Tue Feb 24, 2015 12:13 pm
by SopaXorzTaker
Oh, sorry please!
My bad. Forgot about searching before posting.

Re: Help a newbie please! (PSP-3000)

Posted: Tue Feb 24, 2015 12:16 pm
by BlumCoLe
No prob ...using the search function is just faster. ;)

btw: Downgrade for what? 6.61 CFW exists. :P

https://www.youtube.com/watch?v=xFIywnUOEM4

Re: Help a newbie please! (PSP-3000)

Posted: Tue Feb 24, 2015 12:26 pm
by SopaXorzTaker
But I've heard that PSP's of TA-095v2 + Datecode 1C are unflashable to CFW?

Re: Help a newbie please! (PSP-3000)

Posted: Tue Feb 24, 2015 1:00 pm
by PSPcfwDUDE
It is downgrade-able, but doesn't have many options to downgrade to (because of the motherboard being the last motherboard made for the PSP3000).
I'd say, in your situation, just install 6.61 PRO-C2 or LME-2.3 and you're all set. No need to downgrade and put your system's life at risk.
I'd like to let you know that the CFW you're probably going to install is NOT permanent, and you will need to launch it again (after a full shutdown or crash) with the CFW's appropriate launcher.

Re: Help a newbie please! (PSP-3000)

Posted: Tue Feb 24, 2015 1:08 pm
by Casavult
Stay on 6.61 or downgrade to 6.60.

Install either the recently updated PRO-C2 by Qwikrazor or ME-2.3.

Personally I'd downgrade to 6.60.

Re: Help a newbie please! (PSP-3000)

Posted: Tue Feb 24, 2015 2:47 pm
by The Z
SopaXorzTaker wrote:But I've heard that PSP's of TA-095v2 + Datecode 1C are unflashable to CFW?
All PSPs are "flashable". Maybe not full (cIPL) or permanent (perma patch), but temporary CFW or HEN should always work.

Downgrading is possible to 6.30 and higher (PSP 3000 07g/09g), 6.50 and higher (PSP E1000), 5.70 and higher (PSPgo & 3000 04g), 4.20 and higher (3000 03g), 3.60 and higher (2000) or 1.00 and higher (1000).

Downgrade to 6.60 and install 6.60 L/ME or PRO-C2 (qwikrazors update), since 6.61 breaks some plugins.

Re: Help a newbie please! (PSP-3000)

Posted: Tue Feb 24, 2015 2:59 pm
by SopaXorzTaker
The reason was I didn't like the semi-permanent patch.

Re: Help a newbie please! (PSP-3000)

Posted: Thu Feb 26, 2015 3:54 pm
by SopaXorzTaker
Still didn't find anything. Please help me!
I need to know whether it's possible to flash my model.
The chart says no, but I saw something somewhere about TA095v2 perma CFW's.