Advertising (This ad goes away for registered users. You can Login or Register)

Updating my PSP?

Everything that is PSP-related but doesn't go in any other subforum
Thibault1171
Posts: 131
Joined: Sun Aug 04, 2013 10:26 am

Updating my PSP?

Post by Thibault1171 »

Hi guys. I want to take my old PSP out of my drawer.
I want to use my PSP 3000.
Here is my PSP list :
PSP-1004 5.50 GEN-D3 Datecode 5C
PSP-3004 1C Model 09g 6.60 PRO-C2
PSP-N1004 9C (GO) Model 05g 6.60 PRO-C2 (with Darkspeed Final installed)

My question is : is it better to stay like this, or to install 6.61 ME-2.3? I use a photofast as memory stick in my PSP 3000 (2 micro SD adapter).

Thanks for your help
Advertising
SORRY FOR MY BAD ENGLISH
PSP 1000/3000/GO
PSVita 1000 Datecode 2C running 3.60 HENKAKU
PS3 with up-to-date firmware
Butcher
Posts: 317
Joined: Mon Dec 12, 2016 11:58 pm

Re: Updating my PSP?

Post by Butcher »

Do like u wonna.

On all u can load modern version games. (To 5.50Gen-D3 u nned only instal prometheus patch to launch modern FW neded games)

But no problem update all PSP FW to 6.6X

I prefer 6.60 then 6.61 some on 6.61 plugins most not work perfect - need use fake plugin to show like 6.60 version but its 1% plugins.

To CFW a prefer PRO-C more options in Recovery - ME have small.

Install 1004 6.60 PRO-C permanent
3004 - Prefer LCFW 6.60 PRO-C (U can use perm patch but 3k psp and no unbrick method so its not worst have perm such u can brick)
On Go that same like on 3004 - 6.60 PRO-C LCFW

To Memory Stick Pro Duo Adapter or normal Sony card will work.
Advertising
Thibault1171
Posts: 131
Joined: Sun Aug 04, 2013 10:26 am

Re: Updating my PSP?

Post by Thibault1171 »

Hi, thanks for the quick reply. So I think I'll stay like this.
Can I install Darkspeed on my PSP 3000 (in order to replace Digital Comics with a PRO shortcut)? If I install Darkspeed, can I delete PRO homebrews from my memory stick (the installer, the quick recovery), or does Darkspeed shortcut need them?

Thanks
SORRY FOR MY BAD ENGLISH
PSP 1000/3000/GO
PSVita 1000 Datecode 2C running 3.60 HENKAKU
PS3 with up-to-date firmware
fate6
Big Beholder
Posts: 7599
Joined: Fri Mar 09, 2012 1:18 am
Location: [fate6@Canterlot ~]$

Re: Updating my PSP?

Post by fate6 »

iirc darkspeed installs its own fast recovery elsewhere in the memorystick so it should be safe to remove them.
Image
anon wrote:If you can't trust a 600 year old vampire in a prepubescent girl's body, who can you trust?
Thibault1171
Posts: 131
Joined: Sun Aug 04, 2013 10:26 am

Re: Updating my PSP?

Post by Thibault1171 »

fate6 wrote:iirc darkspeed installs its own fast recovery elsewhere in the memorystick so it should be safe to remove them.
Thanks

So, it's better to install Darkspeed and stay on 6.60 PRO-C2 (instead of installing 6.61 ME)?
SORRY FOR MY BAD ENGLISH
PSP 1000/3000/GO
PSVita 1000 Datecode 2C running 3.60 HENKAKU
PS3 with up-to-date firmware
Cyber
Posts: 235
Joined: Sat Aug 30, 2014 8:39 am

Re: Updating my PSP?

Post by Cyber »

Thibault1171 wrote:So, it's better to install Darkspeed and stay on 6.60 PRO-C2 (instead of installing 6.61 ME)?
You can't install ME firmwares on 3000 series PSPs since they will brick. You can install their LME counterparts though.
The only substantial difference between 6.61 and 6.60 is PSN access. If you don't need to download your PSN games directly to your PSP, there's no need for the update as even the latest PSP games still require firmware 6.60 to run.
I think 6.61 is also required to transfer PSN games from PS3 to PSP, but I'm not 100% sure on this.
Thibault1171
Posts: 131
Joined: Sun Aug 04, 2013 10:26 am

Re: Updating my PSP?

Post by Thibault1171 »

Thanks for the information. For now, I have nothing to transfer from my PS3 to my PSP. So I'll stay on 6.60PRO-C2.

And for my PSP1000, what is best? Stay on 5.50GEN-D3, update to 6.61ME, or last 5.00M33-6 ?
SORRY FOR MY BAD ENGLISH
PSP 1000/3000/GO
PSVita 1000 Datecode 2C running 3.60 HENKAKU
PS3 with up-to-date firmware
Butcher
Posts: 317
Joined: Mon Dec 12, 2016 11:58 pm

Re: Updating my PSP?

Post by Butcher »

Update all PSP to 6.60 PRO C or 6.61 PRO-C in PSP 1000 permanent in 3000 LCFW and GO LCFW - no need to have old FW versions - i prefer 6.60 - 5.XX god but u need prometheus patch tu run 6.XX games . Not work to do faster use 6.6X FW
fate6
Big Beholder
Posts: 7599
Joined: Fri Mar 09, 2012 1:18 am
Location: [fate6@Canterlot ~]$

Re: Updating my PSP?

Post by fate6 »

If you have had no issues with the 3k then just leave it be, Sure you can update it to 6.61 but there is no real reason to do so.
The 1k tho get rid of GEN and move it over the 6.61 ME tho you will need to edit the version text file since GEN put a 9.99 version number that the 6.61 updater will see.

iirc you can bypass that by running the ME installer with the 6.61 pbp either in root or in the installer folder but if that fails you need to go into flash0 and in vsh there should be a version.txt, in it it will say 9.99 and you change to be anything lower then 6.61.
Image
anon wrote:If you can't trust a 600 year old vampire in a prepubescent girl's body, who can you trust?
Butcher
Posts: 317
Joined: Mon Dec 12, 2016 11:58 pm

Re: Updating my PSP?

Post by Butcher »

No i trayed on Gen D3 the lates ME and Pro - needed to edit version.txt from 9.90 to for my was then install 6.60 so changed to 5.50 like its normla FW version the updated normal .
Post Reply

Return to “General”