Advertising (This ad goes away for registered users. You can Login or Register)

[RELEASE] vitaHexenII - Hexen II port for PSVITA

HENkaku is a native Homebrew Enabler for the PS Vita and PS TV. It lets you run homebrews on the PS Vita
User avatar
Rinnegatamante
VIP
Posts: 881
Joined: Sat Mar 26, 2011 10:02 am
Contact:

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by Rinnegatamante » Fri Jan 18, 2019 8:51 pm

You have to go to Old Mission to start the game. New Game is meant to be for the DLC (Portal of Praveus).
Advertising
If you want, visit my website: http://rinnegatamante.it :D

ivory_soul
Posts: 14
Joined: Wed Feb 05, 2014 10:33 am

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by ivory_soul » Sat Jan 19, 2019 9:10 am

Rinnegatamante wrote:
Fri Jan 18, 2019 8:51 pm
You have to go to Old Mission to start the game. New Game is meant to be for the DLC (Portal of Praveus).
Now there's the issue with effects on screen strobing. When you get hit and the screen turns red it stays red and just strobes at a million flashes a second (seizure inducing) until another effect appears and it's unplayable. Any suggestions?
Advertising

User avatar
Rinnegatamante
VIP
Posts: 881
Joined: Sat Mar 26, 2011 10:02 am
Contact:

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by Rinnegatamante » Sat Jan 19, 2019 10:40 am

ivory_soul wrote:
Sat Jan 19, 2019 9:10 am
Rinnegatamante wrote:
Fri Jan 18, 2019 8:51 pm
You have to go to Old Mission to start the game. New Game is meant to be for the DLC (Portal of Praveus).
Now there's the issue with effects on screen strobing. When you get hit and the screen turns red it stays red and just strobes at a million flashes a second (seizure inducing) until another effect appears and it's unplayable. Any suggestions?
I don't get anything of this on my installation, can you take a small video of the issue?
If you want, visit my website: http://rinnegatamante.it :D

ivory_soul
Posts: 14
Joined: Wed Feb 05, 2014 10:33 am

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by ivory_soul » Sat Jan 19, 2019 8:34 pm

Rinnegatamante wrote:
Sat Jan 19, 2019 10:40 am
ivory_soul wrote:
Sat Jan 19, 2019 9:10 am
Rinnegatamante wrote:
Fri Jan 18, 2019 8:51 pm
You have to go to Old Mission to start the game. New Game is meant to be for the DLC (Portal of Praveus).
Now there's the issue with effects on screen strobing. When you get hit and the screen turns red it stays red and just strobes at a million flashes a second (seizure inducing) until another effect appears and it's unplayable. Any suggestions?
I don't get anything of this on my installation, can you take a small video of the issue?
Here the link to the 20 second video I made. You can see the constant strobing.

Here's a list of files inside my data1 folder if it helps:

Config.cfg
Hexen.rc
pak0.pak
pak1.pak

User avatar
Rinnegatamante
VIP
Posts: 881
Joined: Sat Mar 26, 2011 10:02 am
Contact:

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by Rinnegatamante » Sun Jan 20, 2019 12:39 am

Try replacing ux0:app/HXEN00001/eboot.bin with this: https://rinnegatamante.it/eboot.zip
If you want, visit my website: http://rinnegatamante.it :D

ivory_soul
Posts: 14
Joined: Wed Feb 05, 2014 10:33 am

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by ivory_soul » Sun Jan 20, 2019 2:03 am

Rinnegatamante wrote:
Sun Jan 20, 2019 12:39 am
Try replacing ux0:app/HXEN00001/eboot.bin with this: https://rinnegatamante.it/eboot.zip
Sadly, that didn't do anything it's still the same. I don't understand why I'm having these unique issues.

User avatar
Rinnegatamante
VIP
Posts: 881
Joined: Sat Mar 26, 2011 10:02 am
Contact:

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by Rinnegatamante » Sun Jan 20, 2019 10:56 am

That's my data1 folder by the way.
data1.png
data1.png (24.96 KiB) Viewed 7657 times
If you want, visit my website: http://rinnegatamante.it :D

ivory_soul
Posts: 14
Joined: Wed Feb 05, 2014 10:33 am

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by ivory_soul » Sun Jan 20, 2019 8:41 pm

Rinnegatamante wrote:
Sun Jan 20, 2019 10:56 am
That's my data1 folder by the way.

data1.png
So, after a week of fighting this thing I finally fixed it and found the issue. The Steam version of Hexen II is a Source port so the files in data1 (outside of the .pak files) are changed for the Source engine. I had to download the Hammer of Thyrion "patch" and use the .pak files from the Steam version to make a working copy. The music tracks also do not work in the Steam version as a third party patch it needed to implement them (the game is simply not coded to find the music files). Bottom line: The Steam version is NOT compatible with vitaHexenII!

Maybe you can mention that, Rinnegatamante, in your next update that the Steam version will not work outside of the .pak files and it won't read the music (without the patch). Maybe that info right up front could save a lot of people some headaches as the Steam version is the only version you can buy digitally right now.

User avatar
Rinnegatamante
VIP
Posts: 881
Joined: Sat Mar 26, 2011 10:02 am
Contact:

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by Rinnegatamante » Sun Jan 27, 2019 1:27 pm

ivory_soul wrote:
Sun Jan 20, 2019 8:41 pm
Rinnegatamante wrote:
Sun Jan 20, 2019 10:56 am
That's my data1 folder by the way.

data1.png
So, after a week of fighting this thing I finally fixed it and found the issue. The Steam version of Hexen II is a Source port so the files in data1 (outside of the .pak files) are changed for the Source engine. I had to download the Hammer of Thyrion "patch" and use the .pak files from the Steam version to make a working copy. The music tracks also do not work in the Steam version as a third party patch it needed to implement them (the game is simply not coded to find the music files). Bottom line: The Steam version is NOT compatible with vitaHexenII!

Maybe you can mention that, Rinnegatamante, in your next update that the Steam version will not work outside of the .pak files and it won't read the music (without the patch). Maybe that info right up front could save a lot of people some headaches as the Steam version is the only version you can buy digitally right now.
Thanks for the info, i'll add a link to your post in the first post of the thread
If you want, visit my website: http://rinnegatamante.it :D

Al Capwn
Posts: 15
Joined: Wed Apr 18, 2018 10:43 am

Re: [RELEASE] vitaHexenII - Hexen II port for PSVITA

Post by Al Capwn » Sat Feb 09, 2019 11:08 am

Thanks for the new version, loving the hardware acceleration. However, there is one issue I've run into and it's a little odd; whenever I finish an area, I always make 3 separate saves in-case of corruption. Sometimes mid-area I will overwrite just one save, and this time after doing so I happened to die. Upon loading the most recent save it stays in the console with the error "Prespawn not valid -- already spawned".
wall of text

The other weird thing is while loading the save file, after it says 'loading ux0:/data/hexen II/portals/si/info.dat' and version 1.12 server (3164 CRC) it says 'The Forgotten Chapel' and then tries to make a save to "ux0:/data/Hexen II/Portals/Villages.gip..." and the line below it tries to load Villages.gip, says version 1.12 server (3164 CRC), Inner Courtyard, Couldn't load sound/archer/growly.wav, then the Prespawn error.

After loading the 2nd save and continued back into the palace to my death once more, I tried to then load the same save but now it gives me the previous game's error. Loading the 1st slot save does the same.

Edit: Even stranger; upon trying to load the game, when it gets to the "Presawpn not valid -- already spawned" message, hit start to go back to menu, I for some reason decided to try to use the save game function and it actually let me save to a slot. I was able to then load that file normally, although it put me back at the doorway before you enter the palace (I had zoned into the palace and then made the save originally). Once entering the palace the 'objectives' window is also stuck open, along with strange white line artifacting. The artifacting slowly gets worse with red and even yellow lines which turn out to be coming from the fountain. The first time I reached it I crashed but can sometimes make it through.
Edit 2: I tried to start a brand new game but I everytime I reached blackmarsh my progress would be from my original game somehow, where the puzzles are already solved and items collected etc so I fully removed the game from /data/ and /app/ and I'm going to fully start over. I saw in the /portals/ folder there were multiple villages.gip files that are not there with the fresh re-install so I'm hoping they don't get re-created. I did backup my old saves in-case they're wanted for testing purposes. The only issues I notice is that the soundtrack won't work unless it's in .mid format (the files are actually .mp3), in certain areas the shadows change to jagged blocks on surfaces and the strange line artifacting, such as at the start of the new mission when killing the first spiders or when reaching the palace again.

Update: The same save issue started happening again where it for some reason saves and loads to a villages.gip file (saves to villages1.gip and tries to load from villages4.gip) when trying to load a save game. Hitting start and going back to the menu, selecting save and saving the game after this failed load seems to be a temporary fix, but it is odd.

As a separate question, does anyone know the purpose of collecting your main weapon multiple times? Such as all the vorpal swords you get, does it slightly increase your damage? This is something I've wondered since the first time playing back in '98.

Post Reply

Return to “HENkaku”