Page 1 of 1

Recompiling for Unity support?

Posted: Mon Aug 10, 2015 2:29 am
by daxtsu
What exactly have you guys been doing when specifically recompiling homebrew for Unity support, just a make clean and make? I have the latest (as of August 1st) psp2sdk libraries and devkitARM, and yet the Unity assistant keeps crashing with that generic C2-12828-1 error on just about every homebrew I've compiled.

Re: Recompiling for Unity support?

Posted: Thu Aug 13, 2015 12:59 am
by DPyro
Did you update psp2sdk, including psp2.specs?

Re: Recompiling for Unity support?

Posted: Thu Aug 13, 2015 4:03 am
by cheeyee09
There has been updates to psp2sdk github in the last 4 days, but the builds from wololo.net //wololo.net/psp2sdk/?C=M;O=D aren't updated? Last build was on Aug 1st.

Are those updates to psp2sdk github in the last 4 days that is needed for unity?

Same for me, I've update my psp2sdk with the last files from wololo.net and rebuilt almost everything from scratch again and I'm getting the error too.

Re: Recompiling for Unity support?

Posted: Thu Aug 13, 2015 4:55 am
by cheeyee09
Did the entire process again and now my first homebrew NES4Vita I built myself runs.

I deleted everything and started scratch again. That is re-download the lastest psp-libs, psp-multi, psp-tools, lib-gcc from wololo again and reinstalled. Deleted then git cloned vita2dlib, vita_portlibs, psplib4vita and rebuilt everything from scratch. Then rebuilt NES4Vita.

Update: I was too early to be happy. Rebuilt FTPVita, but it failed with the error.
Update2: All other rebuilt homebrews end up with error.

Update3: I had asked Ezio on Twitter who had created working builds for PSM Unity and the problem was in the latest psp2sdk. He mentions to use an older version. Link to Ezio https://twitter.com/Ezio_PS/status/630786796750807044