Official Wagic 0.20.1.x 03-14-2017

Additional Ressources for WTH : new cards, card images & more
Post Reply
kevlahnota
Posts: 618
Joined: Tue Feb 08, 2011 3:00 pm
Location: Philippines
Contact:

Re: Official Wagic 0.20.1.x 02-10-2017

Post by kevlahnota »

added instruction in the first page for PSP users only. Remove your graphics folder in WTH\Res, download the graphics.zip, extract it and replace it in WTH\Res. It seems some graphics file are loaded even it's not supposed to load in PSP version... It's a temporary fix but it will be useable for PSP only. For the blurriness or Slow loading of images, the PSP version cannot accomodate large cache (if you try large images it will most likely crash).
User avatar
Bas
Posts: 413
Joined: Sat Dec 26, 2015 10:55 pm
Location: Germany

Re: Official Wagic 0.20.1.x 02-10-2017

Post by Bas »

Wow, sounds great!

Did you test out with the new deck editor?

Deck editor seems to be 30% slower than in my version, but I guess that's a cut I am willing to make.
For the blurriness or Slow loading of images, the PSP version cannot accomodate large cache (if you try large images it will most likely crash).
You are talking about the images loading which shouldn't causing this issue?

You didn't test out with card images yet?
Are these going to load in the deck editor?
kevlahnota
Posts: 618
Joined: Tue Feb 08, 2011 3:00 pm
Location: Philippines
Contact:

Re: Official Wagic 0.20.1.x 02-10-2017

Post by kevlahnota »

Bas wrote:Wow, sounds great!

Did you test out with the new deck editor?

Deck editor seems to be 30% slower than in my version, but I guess that's a cut I am willing to make.
For the blurriness or Slow loading of images, the PSP version cannot accomodate large cache (if you try large images it will most likely crash).
You are talking about the images loading which shouldn't causing this issue?

You didn't test out with card images yet?
Are these going to load in the deck editor?
I didn't have time to record but it works with images. Just don't forget you need to delete the graphics folder then extract the new graphics.zip for PSP. I removed some items and resized some files so its exclusive for PSP versions only.
User avatar
Bas
Posts: 413
Joined: Sat Dec 26, 2015 10:55 pm
Location: Germany

Re: Official Wagic 0.20.1.x 02-10-2017

Post by Bas »

Cool stuff!

Looking forward to abandon my "PSP setup" which was quite wonky.

Also nice to actually being able to code with new keywords. Was kind of a mess and frustrating to code with keywords which were not implemented yet - Or at least not with full functionality, and this was kind of a mess to even figure this out. Or in general my coding "mistakes".
User avatar
Bas
Posts: 413
Joined: Sat Dec 26, 2015 10:55 pm
Location: Germany

Re: Official Wagic 0.20.1.x 02-10-2017

Post by Bas »

Hiho!

Some points;
- Can you add a shortcut from the taskboard/shop for future releases? PSP sometimes goes very, very slow there, and having a hotkey which you can hold would make returning to the main menu way more comfortable.
- Couldn't it be wise to code a way for adding counters to players in general? Partly for custom-built cards, other part for in case new cards are being released and no one being there who can update the WTH program itself. This way cards could still be added with this effect.
- Link to Github in 1st posting?
- What would Python need to do? I might know 1 or 2 ppl who know things in that language.
sandman423
Posts: 739
Joined: Thu Sep 10, 2009 8:59 pm

Re: Official Wagic 0.20.1.x 02-10-2017

Post by sandman423 »

I really like the PC Release of this...I can actually play some decks I never had the chance to test out and it runs a lot smoother.

- Aetherflux Reservoir still isn't working for me on the first post version of the PC Wagic. It doesn't gain me life when I cast spells but aside from that all cards seem to be working so far.

- I noticed a bug with See the Unwritten where I have Ferocious active with a 5/5 on the field and I was able to grab Ulamog, Ceasless Hunger & Avenger of Zendikar but for some reason when Avenger of Zendikar hit the field it gave me the plant tokens but the Avenger goes straight to GY.


Thank you for all your work everyone. I am hoping there will be a time I can get Omnath, Locus of Mana in game and Extraplanar lens.
User avatar
Bas
Posts: 413
Joined: Sat Dec 26, 2015 10:55 pm
Location: Germany

Re: Official Wagic 0.20.1.x 02-10-2017

Post by Bas »

Question: Before you replaced the graphic folder, which issue(s) were you experiencing? And what was fixed?

My test on PSP;
- A bit slower ingame/in match. Might be related to another issue.
- Deck editor: Blurred up images, being far from being readable. Only seems to happen there and MAYBE the store, but I couldn't find any card images there with one set unlocked only (in the "Ask for card..." section)
- Got a BSOD on purchasing a booster. I think I didn't test w/o images, though.


Your emu:
Did you use the PSP sized images for testing?
Did you limit the emu's RAM and VRAM size to match that one from the PSP?
kevlahnota
Posts: 618
Joined: Tue Feb 08, 2011 3:00 pm
Location: Philippines
Contact:

Re: Official Wagic 0.20.1.x 02-10-2017

Post by kevlahnota »

sandman423 wrote:I really like the PC Release of this...I can actually play some decks I never had the chance to test out and it runs a lot smoother.

- Aetherflux Reservoir still isn't working for me on the first post version of the PC Wagic. It doesn't gain me life when I cast spells but aside from that all cards seem to be working so far.

- I noticed a bug with See the Unwritten where I have Ferocious active with a 5/5 on the field and I was able to grab Ulamog, Ceasless Hunger & Avenger of Zendikar but for some reason when Avenger of Zendikar hit the field it gave me the plant tokens but the Avenger goes straight to GY.


Thank you for all your work everyone. I am hoping there will be a time I can get Omnath, Locus of Mana in game and Extraplanar lens.
Try this:

Code: Select all

[card]
name=Extraplanar Lens
auto=may moveto(exile) target(land|mybattlefield) and!( transforms((,newability[lord(*[share!name!]) producecolor:land],newability[lord(*[share!name!]) producecolor:green],newability[lord(*[share!name!]) producecolor:blue],newability[lord(*[share!name!]) producecolor:red],newability[lord(*[share!name!]) producecolor:black],newability[lord(*[share!name!]) producecolor:white])) forever )!
text=Imprint — When Extraplanar Lens enters the battlefield, you may exile target land you control. -- Whenever a land with the same name as the exiled card is tapped for mana, its controller adds one mana to his or her mana pool of any type that land produced.
mana={3}
type=Artifact
[/card]
kevlahnota
Posts: 618
Joined: Tue Feb 08, 2011 3:00 pm
Location: Philippines
Contact:

Re: Official Wagic 0.20.1.x 02-10-2017

Post by kevlahnota »

Bas wrote:Question: Before you replaced the graphic folder, which issue(s) were you experiencing? And what was fixed?

My test on PSP;
- A bit slower ingame/in match. Might be related to another issue.
- Deck editor: Blurred up images, being far from being readable. Only seems to happen there and MAYBE the store, but I couldn't find any card images there with one set unlocked only (in the "Ask for card..." section)
- Got a BSOD on purchasing a booster. I think I didn't test w/o images, though.


Your emu:
Did you use the PSP sized images for testing?
Did you limit the emu's RAM and VRAM size to match that one from the PSP?
I just tried removing those large images since I suspect they are loaded and when I test it using the emu, it solves the issue in deck editor being slow. I use PPSSPP 1.3 emulator, I use default values, just extract the emu and put the wth folder in the game directory to test. The fix was to reduce some graphics file and removed the ones that are not needed on PSP versions (Memory/Cache issues on PSP). Other than that I didnt test anymore. The last time I used a PSP with Wagic around 2010 or 2011 and the issues that I'm having is the more sets I add, the slower I get in PSP.
i-am-not-one
Posts: 304
Joined: Fri Dec 07, 2012 4:36 am

Re: Official Wagic 0.20.1.x 02-10-2017

Post by i-am-not-one »

Very excited I just downloaded release 0.20.1.1765 (02-23-2017) with the PSP graphics patch. Playing on PSP 3000 fresh install.

After I choose Play->Play Game-> There is a blank choice (If I scroll down I can choose classic or story)->Single Game etc.

If i don't scroll down to classic mode and just press circle ( and it does not crash) When I get into the game it doesn't deal out the cards to myself or the opposition.

Just wondering if this was happening to everyone or just me?

The other main menu choices seem to work, did not test much.
Played through a full game and it was the smoothest it has been on PSP in a long time.
I like how it greys out cards you cannot use during the attack phase.

I am tempted to test some more (Play some more games that is)
Post Reply