Bug reports 0.20.1.xxxx

Do not post feature requests here, please.
Before posting bugs report check the Image Bug reporting help & guidelines
Forum rules
Do not post Features/Improvments request here (i.e : AI being stupid is not a bug, not being able to do a mulligan is not a bug, etc..etc..)
Before posting, please read the Bugs reporting guideline
Zethfox
Posts: 3029
Joined: Thu Jun 10, 2010 11:28 pm

Re: Bug reports 0.20.1.xxxx

Post by Zethfox »

The deck editor will always show blurry images on psp systems earlier than vita. Were sorry, its a limitation, no further time will be used by kev and i to brainstorm ways to force this to work on nonvitas. Ram limations are something only usera can control by upgrading thier platform either to a vita or smart device.
Again sorry.

And heres the tech info,
Ive already covered psp ram limits, so i wont talk about that.

Grid editor loads 30-40 normal res images per section.
To find out what that means, look at the size of any image card, its anywhere from 20k to 130k. Now times that by 30, you have some 35mbsish to use which is shared with storing primitives which i think is close to 7mbs now, and running the actual app.

There is no way other reverting 4 years of devolopment, to make it run any better than it is.

I understand not everyone can get a vita, but wagic run android 4.0 and up at top preformance. That means those 20 dollar phones/tablets you see at walmart.

Every software has requirements, just like any game. You cant run wow on a system with windows 98 for example.

Wagic is psp vita. The fact that it still even runs on the older systems just is shocking to me, and i say that anytime anyone asks me.

And while we intend to keep it running on legacy devices as long as possible, there will come a day when it just wont be able to.

Btw neat little note, there was a minmax system being worked on for ai. However if this is ever implemented, legacy psp would most likely have to be removed.
The psp would blow up if it had to run 20 games in the background while you played so ai can build a decision tree.
User avatar
Bas
Posts: 414
Joined: Sat Dec 26, 2015 10:55 pm
Location: Germany

Re: Bug reports 0.20.1.xxxx

Post by Bas »

leeeeeeeeeeeeel. SryMeARiver. Made my day.
Zethfox
Posts: 3029
Joined: Thu Jun 10, 2010 11:28 pm

Re: Bug reports 0.20.1.xxxx

Post by Zethfox »

Im sure you can score 20 bucks to buy a cheap android phone. You got a job right?
If you do, get a vita, their 90$ now, thats almost free to me, shouldnt be any problem for you.

Enjoy, glad i can make your day.
sandman423
Posts: 739
Joined: Thu Sep 10, 2009 8:59 pm

Re: Bug reports 0.20.1.xxxx

Post by sandman423 »

I looked into vita's and they still are over 120 bucks. So I want to play on PSP...I don't see the reason to buy a Vita and buying a Vita to play Wagic seems like a waste of money. All games on Vita seem kind of crappy.

I downloaded latest PSP from GitHub and I get blue screen of death when I go to Single Player.

Bus Error (Data)
LoadTexture Error
EPC - 0881AB38 / JGEApp_title.text + 00016B38
Cause 1000001C
Zethfox
Posts: 3029
Joined: Thu Jun 10, 2010 11:28 pm

Re: Bug reports 0.20.1.xxxx

Post by Zethfox »

Im just perplexed at how many of you guys dont own a smart phone.

Ive seen homeless people in my local city walking around with smart phones in thier hand.

Anyways sandman, make sure you are using the most current release, i think kev just added the font file for it that seems to be missing from your install
sandman423
Posts: 739
Joined: Thu Sep 10, 2009 8:59 pm

Re: Bug reports 0.20.1.xxxx

Post by sandman423 »

I do have a Smartphone HTC One but I don't want games on it because it is for my business. PSP for me convenient because I can play it on the go.

I installed the latest Wagic for Windows and it is so cool to see these new cards to me.

I will try it again when the d/l gets updated
User avatar
ph34rbot
Posts: 260
Joined: Thu Jan 07, 2010 6:33 am

Re: Bug reports 0.20.1.xxxx

Post by ph34rbot »

Loving the latest version of wagic, thanks for the hard work.

I have been using the latest windows version from github with images and when the AI cast a spell that looks and discrads from my hand the app crashes, happened with cards Duress and Castigate
sandman423
Posts: 739
Joined: Thu Sep 10, 2009 8:59 pm

Re: Bug reports 0.20.1.xxxx

Post by sandman423 »

Where did you get 0.20.1??

I went here
https://github.com/WagicProject/wagic/releases

and got the latest windows version did a clean install and tried to use SOI cards like Bygon Bishop/Tireless Tracker/& Thraben inspector and I don't get a clue. When I click on them I get a token popup that says ID NOT FOUND.

Anyone else having issues with this? I also noticed against the Black Vise/Rack deck Black vise doesn't do damage to me on my upkeep or at all.

I will test it out on my Windows version 0.19.2

Here is My Primitives & _Cards.dat as for the latest Wagic Windows 0.19.2 (I am using)
http://s000.tinyupload.com/?file_id=715 ... 5247248683 (SOI _cards.dat)
http://s000.tinyupload.com/?file_id=965 ... 6801885014 (Primitives) (Fresh from install)
kevlahnota
Posts: 618
Joined: Tue Feb 08, 2011 3:00 pm
Location: Philippines
Contact:

Re: Bug reports 0.20.1.xxxx

Post by kevlahnota »

here is the latest master 0.20.1.xxxx https://github.com/WagicProject/wagic/r ... est-master

the clue token I can fix but black vise is working for me.

Image

Image
kevlahnota
Posts: 618
Joined: Tue Feb 08, 2011 3:00 pm
Location: Philippines
Contact:

Re: Bug reports 0.20.1.xxxx

Post by kevlahnota »

ph34rbot wrote:Loving the latest version of wagic, thanks for the hard work.

I have been using the latest windows version from github with images and when the AI cast a spell that looks and discrads from my hand the app crashes, happened with cards Duress and Castigate
I think maybe because I changed its code to use reveal, since the card says reveal... I think we need to use something like:
auto=if AI then old code here
auto=ifnot AI then reveal code here
Post Reply