PlayStation 4 Release: flatz releases scripts to backport PS4 games allowing FW 5.50-6.72 titles to run on FW 5.05 – RDR2 & Spider-Man confirmed to work!

Aurora

I'm a girl that's liked technology from day 1. Mostly interested in the PSVita/PSP scene but I've always modded my stuff when it's possible, that is :)Contact me via DM at @KawaiiAuroraA on Twitter if you have any questions/concerns about my articles or if you have any article requests.

6 Responses

  1. César says:

    Excelente! Buenas noticias… =D

  2. skitt says:

    why wouldnt you update from 5.05 to 6.72?

    • evilpaul says:

      Because the Jailbreak barely works? Because if you do anything with your jailbroken PS4, besides pirate games, then all that stuff needs to be ported to 6.72 before it will work?

  3. I bet a lot of people are waiting for FF7R. Still, nice to have more options for people on slightly higher firmwares.

  4. Mr Nice Guy says:

    First thing im gonna do when im finally able to play my patched ff7r is create a walk though walls cheat so i can fully explore the entire surroundings and see what other goodies are hiding in the possible debug options.

    Like the good old days of ffvii

  5. Anonymous says:

    GGGreat news!! I didn’t wanna upgrade to the newer lamer version.

Leave a Reply

Your email address will not be published. Required fields are marked *

Most comments are automatically approved, but in some cases, it might take up to 24h for your comments to show up on the site, if they need manual moderation. Thanks for your understanding