Advertising (This ad goes away for registered users. You can Login or Register)

Help Me.. My Vita Bricked...

You have questions and can't find another subforum to ask? Go here
Post Reply
tunahanshn
Posts: 1
Joined: Sun Nov 24, 2019 10:24 pm

Help Me.. My Vita Bricked...

Post by tunahanshn » Sun Nov 24, 2019 10:26 pm

Hello guys. I'm updated my Vita 3.73 today. But i heard Adrenaline is not working, and i'm decided to downgrade my firmware. I'm downloaded 3.68 firmware and used modoru fordowngrade. SCE Updater is runned but stucks at %11 and i'm faced C1-6548-3 error. Tried to reboot but not working. Now i'm stucked at recovery mode. I'm tried QCMA for unbrick but my PS Vita says "Latest firmware is aleady installed"

Please help me for this :/
Advertising

User avatar
NNNRT
Moderator
Posts: 1620
Joined: Fri Jul 27, 2012 1:32 pm
Location: Byblos
Contact:

Re: Help Me.. My Vita Bricked...

Post by NNNRT » Mon Dec 02, 2019 10:00 pm

You'll probably have to wait until a new update is out so you can update from recovery mode. I don't really know about any other solution.
Advertising

Post Reply

Return to “Support”