Advertising (This ad goes away for registered users. You can Login or Register)

[RELEASE] PicoDrive 1.92 - with SVP dynarec

Running old school games on your PSP? It's definitely possible
User avatar
Oldvic
Posts: 20
Joined: Tue Apr 18, 2017 2:20 am

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by Oldvic » Fri Nov 24, 2017 6:20 am

robson.santana wrote:A similar problem occurs in the Brazilian Mega Drive Tec Toy (2017). This is related to line renderer (accurate renderer, raster effect), probably the same problem as your previous post.

https://github.com/robson-alcantara/picodrive/issues/37
Thanks for the info, I didn't know TecToy re-released the Mega Drive. I just watched a couple of videos on You Tube.
robson.santana wrote:This is the problem of the core of the picodrive and not of the port.

Retroarch (picodrive 1.91 core)
Image

Kega Fusion
Image
Yes, the 'Sonic 3D Blast' problem is a core issue, but I think the partially visible black band rendering issue in 'Fantastic Dizzy' and 'Test Drive II' are a separate issue from the graphics issue in 'Sonic 3D Blast'. I'll explain why. The black band problem is unique to your PSP compiles of v1.91 and v1.92. The Arm versions and other Mips versions don't have this bug. Also, if you test the Retroarch core of PicoDrive v1.91 on the PSP you will see this issue is not present. See pic below of 'Fantastic Dizzy' running in PSP Retroarch PicoDrive v1.91 with no black band issue:
Image
Image

The 'Sonic 3D Blast' problem is something else, and has been present since the changes Notaz made for the v1.50 release (like the missing car sprites in 'Test Drive II'). It is present in all versions of PicoDrive (Arm and Mips (although I haven't tested the new v1.92 release on my Pandora yet)). If you test this game in v1.40b, you will see it works fine as long as you enable 'Accurate Sprites' (see pics below). It seems the 'Accurate Sprites' mode of v1.40b is missing in v1.50 and beyond. So yes, you are correct in that it is a core problem in PicoDrive, and has been present a long time. But that black band rendering issue in 'Fantastic Dizzy', 'Test Drive II' and possibly Sub-Terrania is surely something else, as I have shown above 'Fantastic Dizzy' running fine on PSP in Retroarch PicoDrive v1.91 core.

'Sonic 3D Blast' in PSP PicoDrive v1.40b with 'Accurate Sprites' enabled.
Image
Image

Thanks.
Advertising

robson.santana
Posts: 82
Joined: Mon Sep 26, 2016 11:45 pm

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by robson.santana » Fri Nov 24, 2017 12:00 pm

Oldvic wrote:
robson.santana wrote:A similar problem occurs in the Brazilian Mega Drive Tec Toy (2017). This is related to line renderer (accurate renderer, raster effect), probably the same problem as your previous post.

https://github.com/robson-alcantara/picodrive/issues/37
Thanks for the info, I didn't know TecToy re-released the Mega Drive. I just watched a couple of videos on You Tube.
robson.santana wrote:This is the problem of the core of the picodrive and not of the port.

Retroarch (picodrive 1.91 core)
Image

Kega Fusion
Image
Yes, the 'Sonic 3D Blast' problem is a core issue, but I think the partially visible black band rendering issue in 'Fantastic Dizzy' and 'Test Drive II' are a separate issue from the graphics issue in 'Sonic 3D Blast'. I'll explain why. The black band problem is unique to your PSP compiles of v1.91 and v1.92. The Arm versions and other Mips versions don't have this bug. Also, if you test the Retroarch core of PicoDrive v1.91 on the PSP you will see this issue is not present. See pic below of 'Fantastic Dizzy' running in PSP Retroarch PicoDrive v1.91 with no black band issue:
Image
Image

The 'Sonic 3D Blast' problem is something else, and has been present since the changes Notaz made for the v1.50 release (like the missing car sprites in 'Test Drive II'). It is present in all versions of PicoDrive (Arm and Mips (although I haven't tested the new v1.92 release on my Pandora yet)). If you test this game in v1.40b, you will see it works fine as long as you enable 'Accurate Sprites' (see pics below). It seems the 'Accurate Sprites' mode of v1.40b is missing in v1.50 and beyond. So yes, you are correct in that it is a core problem in PicoDrive, and has been present a long time. But that black band rendering issue in 'Fantastic Dizzy', 'Test Drive II' and possibly Sub-Terrania is surely something else, as I have shown above 'Fantastic Dizzy' running fine on PSP in Retroarch PicoDrive v1.91 core.

'Sonic 3D Blast' in PSP PicoDrive v1.40b with 'Accurate Sprites' enabled.
Image
Image

Thanks.
Humm, it's true, are different problems. I will continue to investigate with another game.

The accurate sprites exist in versions after 1.4 (as PDRAW_SPR_LO_ON_HI) , but the option no longer exists - but use true value.
Advertising

THiaGOBlaCkAiT
Posts: 2
Joined: Fri Nov 24, 2017 4:02 pm

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by THiaGOBlaCkAiT » Fri Nov 24, 2017 4:05 pm

robson esta versao nova funciona com qual extensao pras roms? porque eu tentei aqui usar o .bin como no 1.51 e nao funcionou

robson.santana
Posts: 82
Joined: Mon Sep 26, 2016 11:45 pm

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by robson.santana » Fri Nov 24, 2017 5:03 pm

THiaGOBlaCkAiT wrote:robson esta versao nova funciona com qual extensao pras roms? porque eu tentei aqui usar o .bin como no 1.51 e nao funcionou
No meu funciona com zip, bin e smd. Tem como você disponibilizar uma rom para testes?

THiaGOBlaCkAiT
Posts: 2
Joined: Fri Nov 24, 2017 4:02 pm

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by THiaGOBlaCkAiT » Fri Nov 24, 2017 7:32 pm

robson.santana wrote:
THiaGOBlaCkAiT wrote:robson esta versao nova funciona com qual extensao pras roms? porque eu tentei aqui usar o .bin como no 1.51 e nao funcionou
No meu funciona com zip, bin e smd. Tem como você disponibilizar uma rom para testes?
nao da pra postar roms aqui... mas creio que ta parecendo que nao funciona porque talvez nao é compativel com o VHBL do vita. esqueci de falar que to usando no vita

no menu de seleçao de roms apos clicar no O nao carrega as roms

Image

robson.santana
Posts: 82
Joined: Mon Sep 26, 2016 11:45 pm

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by robson.santana » Fri Nov 24, 2017 8:01 pm

THiaGOBlaCkAiT wrote:
robson.santana wrote:
THiaGOBlaCkAiT wrote:robson esta versao nova funciona com qual extensao pras roms? porque eu tentei aqui usar o .bin como no 1.51 e nao funcionou
No meu funciona com zip, bin e smd. Tem como você disponibilizar uma rom para testes?
nao da pra postar roms aqui... mas creio que ta parecendo que nao funciona porque talvez nao é compativel com o VHBL do vita. esqueci de falar que to usando no vita

no menu de seleçao de roms apos clicar no O nao carrega as roms

Image
Creio que seja isso, outros usuários relataram problemas com o Vita e até postaram neste post versões adaptadas compatíveis.

Não tenho um Vita para corrigir o erro.

Quando a rom aparece da cor rosa é porque o emulador detectou que é uma rom, caso contrário a cor seria branca.
Last edited by robson.santana on Sat Nov 25, 2017 12:59 am, edited 1 time in total.

Butcher
Posts: 265
Joined: Mon Dec 12, 2016 11:58 pm

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by Butcher » Fri Nov 24, 2017 8:36 pm

In EN please write is EN forum

robson.santana
Posts: 82
Joined: Mon Sep 26, 2016 11:45 pm

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by robson.santana » Sat Nov 25, 2017 1:14 am

robson.santana wrote:
Oldvic wrote:
robson.santana wrote:A similar problem occurs in the Brazilian Mega Drive Tec Toy (2017). This is related to line renderer (accurate renderer, raster effect), probably the same problem as your previous post.

https://github.com/robson-alcantara/picodrive/issues/37
Thanks for the info, I didn't know TecToy re-released the Mega Drive. I just watched a couple of videos on You Tube.
robson.santana wrote:This is the problem of the core of the picodrive and not of the port.

Retroarch (picodrive 1.91 core)
Image

Kega Fusion
Image
Yes, the 'Sonic 3D Blast' problem is a core issue, but I think the partially visible black band rendering issue in 'Fantastic Dizzy' and 'Test Drive II' are a separate issue from the graphics issue in 'Sonic 3D Blast'. I'll explain why. The black band problem is unique to your PSP compiles of v1.91 and v1.92. The Arm versions and other Mips versions don't have this bug. Also, if you test the Retroarch core of PicoDrive v1.91 on the PSP you will see this issue is not present. See pic below of 'Fantastic Dizzy' running in PSP Retroarch PicoDrive v1.91 with no black band issue:
Image
Image

The 'Sonic 3D Blast' problem is something else, and has been present since the changes Notaz made for the v1.50 release (like the missing car sprites in 'Test Drive II'). It is present in all versions of PicoDrive (Arm and Mips (although I haven't tested the new v1.92 release on my Pandora yet)). If you test this game in v1.40b, you will see it works fine as long as you enable 'Accurate Sprites' (see pics below). It seems the 'Accurate Sprites' mode of v1.40b is missing in v1.50 and beyond. So yes, you are correct in that it is a core problem in PicoDrive, and has been present a long time. But that black band rendering issue in 'Fantastic Dizzy', 'Test Drive II' and possibly Sub-Terrania is surely something else, as I have shown above 'Fantastic Dizzy' running fine on PSP in Retroarch PicoDrive v1.91 core.

'Sonic 3D Blast' in PSP PicoDrive v1.40b with 'Accurate Sprites' enabled.
Image
Image

Thanks.
Humm, it's true, are different problems. I will continue to investigate with another game.

The accurate sprites exist in versions after 1.4 (as PDRAW_SPR_LO_ON_HI) , but the option no longer exists - but use true value.
fixed

robson.santana
Posts: 82
Joined: Mon Sep 26, 2016 11:45 pm

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by robson.santana » Sat Nov 25, 2017 1:53 am

THiaGOBlaCkAiT wrote:
robson.santana wrote:
THiaGOBlaCkAiT wrote:robson esta versao nova funciona com qual extensao pras roms? porque eu tentei aqui usar o .bin como no 1.51 e nao funcionou
No meu funciona com zip, bin e smd. Tem como você disponibilizar uma rom para testes?
nao da pra postar roms aqui... mas creio que ta parecendo que nao funciona porque talvez nao é compativel com o VHBL do vita. esqueci de falar que to usando no vita

no menu de seleçao de roms apos clicar no O nao carrega as roms

Image
see this: https://www.reddit.com/r/vitahacks/comm ... 1_on_vhbl/

and create a 'log.txt' file in emulator folder and try again. Maybe help.

User avatar
Oldvic
Posts: 20
Joined: Tue Apr 18, 2017 2:20 am

Re: [RELEASE] PicoDrive 1.92 - with SVP dynarec

Post by Oldvic » Sat Nov 25, 2017 3:40 am

robson.santana wrote:
robson.santana wrote:
Oldvic wrote:Yes, the 'Sonic 3D Blast' problem is a core issue, but I think the partially visible black band rendering issue in 'Fantastic Dizzy' and 'Test Drive II' are a separate issue from the graphics issue in 'Sonic 3D Blast'. I'll explain why. The black band problem is unique to your PSP compiles of v1.91 and v1.92. The Arm versions and other Mips versions don't have this bug. Also, if you test the Retroarch core of PicoDrive v1.91 on the PSP you will see this issue is not present. See pic below of 'Fantastic Dizzy' running in PSP Retroarch PicoDrive v1.91 with no black band issue:
Image
Image

The 'Sonic 3D Blast' problem is something else, and has been present since the changes Notaz made for the v1.50 release (like the missing car sprites in 'Test Drive II'). It is present in all versions of PicoDrive (Arm and Mips (although I haven't tested the new v1.92 release on my Pandora yet)). If you test this game in v1.40b, you will see it works fine as long as you enable 'Accurate Sprites' (see pics below). It seems the 'Accurate Sprites' mode of v1.40b is missing in v1.50 and beyond. So yes, you are correct in that it is a core problem in PicoDrive, and has been present a long time. But that black band rendering issue in 'Fantastic Dizzy', 'Test Drive II' and possibly Sub-Terrania is surely something else, as I have shown above 'Fantastic Dizzy' running fine on PSP in Retroarch PicoDrive v1.91 core.

'Sonic 3D Blast' in PSP PicoDrive v1.40b with 'Accurate Sprites' enabled.
Image
Image

Thanks.
Humm, it's true, are different problems. I will continue to investigate with another game.

The accurate sprites exist in versions after 1.4 (as PDRAW_SPR_LO_ON_HI) , but the option no longer exists - but use true value.
fixed
Brilliant, thanks Robson.

Post Reply

Return to “Emulators”