Running old school games on your PSP? It's definitely possible
#420816 by bloodfalco
Sun Nov 19, 2017 2:38 am
Bro, I have just does test on it. Everything is perfect, but just minor problems

1. SEGA CD problem: When I goes to sleep mode, the tracks in Sega-CD stopped running and it freezes when it is loading.
ex: when I play Snatcher. After playing a while, I put my PSP on standby for 5 minutes and I turn it back on again, the sound is off and when it goes to next scene, it freezes. It happened on all Sega-CD games.
2. MEGA DRIVE problem: This one had no problem with sleep mode, but only if I left the PSP on sleep mode for less than 30 minutes. If I took more than 30 minutes, when I turn back on, the emulator freezes and I am unable to do anything except press HOME and exit the emulator.

Thank you again for the emulator and for always modifying it. Sorry for being too noisy
Advertising
#420817 by Oldvic
Sun Nov 19, 2017 7:08 am
Thanks a lot for the v1.92 update Robson .It's great to see the Super Monaco GP graphics are now fixed. That graphics bug had always been in Picodrive. Previously, only the Mega CD/Sega CD version worked perfect. Cheers.

I've done a bit of testing and found some issues:

1. If you choose any 'Sound Quality' below '44100', the sound will randomly distort quite a few times a minute. This is a problem because I often choose '22050hz' for Virtua Racing and Sega CD/Mega CD games to gain some extra FPS. But now it is impossible because of the distortion. By the way, this distortion only appears with NTSC games (all of them). PAL games work fine with any 'Sound Quality' setting. This problem only appeared in v1.92, v1.91 works fine.

2. If 'Wait for vsync' is set to 'Sometimes', PAL games always run at '60hz', when they should runnning at '50hz'. If the setting is set to 'Never' or 'Always', PAL games run at correct speed of '50hz'. This issue is also present in v1.91.

3. Fantastic Dizzy has a graphical issue. There are invisible horizontal black bands that seem to appear when Dizzy passes through them. I have posted a pic below to highlight the issue. You can see the 'Star' sprites on-screen are also affected by it, but only when Dizzy is stood in a band. It can be fixed by entering and exiting the menu, but if you leave Dizzy's house and then re-enter, the issue re-appears. It's probably in other parts of the game too, but i've only played the beginning. This issue is also present in v1.91, but not in 1.51b:
Image
Image

4. Sub-Terrania (thanks for fixing this by the way) also has a graphical issue. Both PAL and NTSC versions are affected. At the bottom of the screen where the score and number of POW's rescued is located, there is a constant horizontal flickering all the way across the screen. If you look at the pics below you can see how it should look in the bottom pic, and the resulting effect it the top pic. Again, this can be fixed by entering and exiting the menu, but when you lose a life, the effect comes back. I tested the game in Dgen and some Arm versions of Picodrive and it doesn't do this:
Image
Image
Thanks a lot.
#420819 by robson.santana
Sun Nov 19, 2017 11:53 am
bloodfalco wrote:Bro, I have just does test on it. Everything is perfect, but just minor problems

1. SEGA CD problem: When I goes to sleep mode, the tracks in Sega-CD stopped running and it freezes when it is loading.
ex: when I play Snatcher. After playing a while, I put my PSP on standby for 5 minutes and I turn it back on again, the sound is off and when it goes to next scene, it freezes. It happened on all Sega-CD games.
2. MEGA DRIVE problem: This one had no problem with sleep mode, but only if I left the PSP on sleep mode for less than 30 minutes. If I took more than 30 minutes, when I turn back on, the emulator freezes and I am unable to do anything except press HOME and exit the emulator.

Thank you again for the emulator and for always modifying it. Sorry for being too noisy


Thanks for informations. I will add to the ticket and this information was very important to solve the problems.

https://github.com/robson-alcantara/picodrive/issues/24
#420820 by robson.santana
Sun Nov 19, 2017 11:56 am
bloodfalco wrote:However Brother Robson

CD Loading is already very fast, same as 1.51b

You just need a bit of tweaking here and there, to achieve the stable status of 1.51b

Go for it, bro


It's true, sleeping problems, some embellishments on the menus and the speed of games on the sega cd I believe are what is missing
#420821 by robson.santana
Sun Nov 19, 2017 12:18 pm
Oldvic wrote:Thanks a lot for the v1.92 update Robson .It's great to see the Super Monaco GP graphics are now fixed. That graphics bug had always been in Picodrive. Previously, only the Mega CD/Sega CD version worked perfect. Cheers.

I've done a bit of testing and found some issues:

1. If you choose any 'Sound Quality' below '44100', the sound will randomly distort quite a few times a minute. This is a problem because I often choose '22050hz' for Virtua Racing and Sega CD/Mega CD games to gain some extra FPS. But now it is impossible because of the distortion. By the way, this distortion only appears with NTSC games (all of them). PAL games work fine with any 'Sound Quality' setting. This problem only appeared in v1.92, v1.91 works fine.

2. If 'Wait for vsync' is set to 'Sometimes', PAL games always run at '60hz', when they should runnning at '50hz'. If the setting is set to 'Never' or 'Always', PAL games run at correct speed of '50hz'. This issue is also present in v1.91.

3. Fantastic Dizzy has a graphical issue. There are invisible horizontal black bands that seem to appear when Dizzy passes through them. I have posted a pic below to highlight the issue. You can see the 'Star' sprites on-screen are also affected by it, but only when Dizzy is stood in a band. It can be fixed by entering and exiting the menu, but if you leave Dizzy's house and then re-enter, the issue re-appears. It's probably in other parts of the game too, but i've only played the beginning. This issue is also present in v1.91, but not in 1.51b:
Image
Image

4. Sub-Terrania (thanks for fixing this by the way) also has a graphical issue. Both PAL and NTSC versions are affected. At the bottom of the screen where the score and number of POW's rescued is located, there is a constant horizontal flickering all the way across the screen. If you look at the pics below you can see how it should look in the bottom pic, and the resulting effect it the top pic. Again, this can be fixed by entering and exiting the menu, but when you lose a life, the effect comes back. I tested the game in Dgen and some Arm versions of Picodrive and it doesn't do this:
Image
Image
Thanks a lot.


I thought super monaco was OK in version 1.51b!

1. I had already noticed some flaw in version 1.91. Ticket: https://github.com/robson-alcantara/picodrive/issues/35

2. Ticket: https://github.com/robson-alcantara/picodrive/issues/36

3 and 4. I had already seen this problem in Sonic 3d Blast and Knuckles Chaotix. I think it's because of the fact that I re-took the PSP rendering of version 1.51b and some function needs updating. For now I recommend changing the renderer. Ticket: https://github.com/robson-alcantara/picodrive/issues/37

Many thanks to you and bloodfalco for the feedback
#420825 by Oldvic
Mon Nov 20, 2017 4:41 am
robson.santana wrote:Many thanks to you and bloodfalco for the feedback

No problem. Thank you for your dedication.
robson.santana wrote:I thought super monaco was OK in version 1.51b!

I just double-checked, and the graphics problem exists in v1.51b. You can see it on the 'Course Select' screen. Thankfully it now runs fine in v1.92.

Another game that has seen some improvement in v1.92, is 'Test Drive II'. The car sprites have been missing in this game for a long time. In fact, the last PSP version that this game worked properly in is v1.40b (1.40c in Arm). Notaz made a lot of changes for the v1.50 release and something amongst them completely broke this game, and it was never fixed. It's nice to see the car sprites have returned in v1.92. It just has that rendering issue, as seen in a few other games (see pic below), and switching to the 'Fast' renderer isn't an option for this game, as some sprites go missing. If you could fix that we'd have a very good version Picodrive for the PSP.
Thanks
Image
#420827 by robson.santana
Mon Nov 20, 2017 10:49 am
Oldvic wrote:
robson.santana wrote:Many thanks to you and bloodfalco for the feedback

No problem. Thank you for your dedication.


Version 1.51b was small for PSP greatness. We needed something better.

Oldvic wrote:
robson.santana wrote:I thought super monaco was OK in version 1.51b!

I just double-checked, and the graphics problem exists in v1.51b. You can see it on the 'Course Select' screen. Thankfully it now runs fine in v1.92.

Another game that has seen some improvement in v1.92, is 'Test Drive II'. The car sprites have been missing in this game for a long time. In fact, the last PSP version that this game worked properly in is v1.40b (1.40c in Arm). Notaz made a lot of changes for the v1.50 release and something amongst them completely broke this game, and it was never fixed. It's nice to see the car sprites have returned in v1.92. It just has that rendering issue, as seen in a few other games (see pic below), and switching to the 'Fast' renderer isn't an option for this game, as some sprites go missing. If you could fix that we'd have a very good version Picodrive for the PSP.
Thanks
Image


A similar problem occurs in the Brazilian Mega Drive Tec Toy (2017). This is related to line renderer (accurate renderer, raster effect), probably the same problem as your previous post.

https://github.com/robson-alcantara/picodrive/issues/37
#420852 by robson.santana
Thu Nov 23, 2017 1:42 am
robson.santana wrote:
Oldvic wrote:
robson.santana wrote:Many thanks to you and bloodfalco for the feedback

No problem. Thank you for your dedication.


Version 1.51b was small for PSP greatness. We needed something better.

Oldvic wrote:
robson.santana wrote:I thought super monaco was OK in version 1.51b!

I just double-checked, and the graphics problem exists in v1.51b. You can see it on the 'Course Select' screen. Thankfully it now runs fine in v1.92.

Another game that has seen some improvement in v1.92, is 'Test Drive II'. The car sprites have been missing in this game for a long time. In fact, the last PSP version that this game worked properly in is v1.40b (1.40c in Arm). Notaz made a lot of changes for the v1.50 release and something amongst them completely broke this game, and it was never fixed. It's nice to see the car sprites have returned in v1.92. It just has that rendering issue, as seen in a few other games (see pic below), and switching to the 'Fast' renderer isn't an option for this game, as some sprites go missing. If you could fix that we'd have a very good version Picodrive for the PSP.
Thanks
Image


A similar problem occurs in the Brazilian Mega Drive Tec Toy (2017). This is related to line renderer (accurate renderer, raster effect), probably the same problem as your previous post.

https://github.com/robson-alcantara/picodrive/issues/37


This is the problem of the core of the picodrive and not of the port.

Retroarch (picodrive 1.91 core)
Image

Kega Fusion
Image

Who is online

Users browsing this forum: No registered users and 3 guests