#420299 by Fife Dawg
Sun Oct 08, 2017 9:31 am
Hi all, can anyone confirm if the nonpdrm plugin works with vpk games? I previously used Vitamin 2.0 to create vpk's of all my cartridge based games and have installed the vpk's through Vitashell and they run fine. I have the nonpdrm plugin installed and it has already created fake licences for a couple of legitimate games i purchased through the PSN store but when i launch any of the vpk games, no licences appear in the nonpdrm folder in Vitashell.

Any ideas?

FD
Advertising
#420301 by pez2k
Sun Oct 08, 2017 12:05 pm
Dumping with Vitamin / Mai decrypts everything and strips out any licenses, which is why they're not really recommended now. You can't get that data back without re-dumping your card using a better tool. I'd recommend psvgamesd to create a .psv file for archival, and NoNPDRM to copy all of the game files either from the original gamecard or the mounted .psv image.
Advertising
#420302 by Fife Dawg
Sun Oct 08, 2017 12:13 pm
Great thanks for that. Any idea how i temporarily go back to making my official memory card the main source of memory? I am using an SD2Vita adapter with a microsd card and when i take the adapter out to put a cartridge game in the vita, i lose all my apps, Henkaku, etc. as they are now running from the microsd card. I still have the ux0 folder with all apps on the official memory card as i simply copied this over to the micrsd card.

Also, is it possible to use the microsd card/SD2 adapter and official vita memory card together or can you only use one at a time?

Any help on this would be appreciated.

FD
#420306 by pez2k
Mon Oct 09, 2017 6:13 pm
It depends on which version of the plugin you're using - it sounds like you're using one that just mounts the SD card as ux0, but there are variants that will mount the memory card as uma0 at the same time, or vice-versa.

Have you tried holding L on boot to disable all plugins? This will stop it from trying to unmount the memory card and mount the SD card, so the memory card should remain as ux0. If this works, then you can simply comment out the plugin in your config file (put a # in front of the line) so that it's no longer loaded. Once you're done, uncomment it and it'll go back to mounting the SD card as ux0 again.

I believe there's an upcoming version of the plugin that will allow you to configure which mount points it uses for both cards to simplify a lot of this fiddling, but I can't say when it'll be finished.

Who is online

Users browsing this forum: No registered users and 1 guest