HENkaku is a native Homebrew Enabler for the PS Vita and PS TV. It lets you run homebrews on the PS Vita
#406697 by ShrineFox
Sat Jul 30, 2016 11:12 pm
Although the failmail trick was patched in 3.55, with Henkaku you don't need it to download/rewrite the app.db to do mr. gas's dumping trick.

So I did all the same steps to open a PSVita game's manual in Near, and then I tried to dump using CMA. Turns out, I get C2-17775-7 trying to transfer the PSP game used for the dump to my PC. A quick google search shows some other people running into the issue trying to dump games on 3.55.

I then tried to backup the game like normal to my PC, and got a similar error code (C2-17119-9). Turns out, both these errors go away when I close the Near app.
This leads me to believe in 3.55, Sony patched not only failmail, but access to the game's ux0:/app/ folder when it's already being accessed by Near..

Instead of using the CMA at all, I then tried moving the folder to my computer using molecularShell's FTP (I also tried with vitaFTP, same results). That's when I confirmed my hypothesis.
With the game manual open in Near alongside the FTP, Filezilla gives me this error accessing the game's folder. However, any other game's folder is perfectly accessible.
Status: Retrieving directory listing of "/ux0:/app/PCSE00491"...
Command: CWD /ux0:/app
Response: 250 Requested file action okay, completed.
Command: CWD PCSE00491
Response: 550 Invalid directory.
Error: Failed to retrieve directory listing

When I close Near, and return to FTP, it works as expected, although the contents are immediately encrypted:
Status: Retrieving directory listing of "/ux0:/app"...
Status: Directory listing of "/ux0:/app" successful
Status: Retrieving directory listing of "/ux0:/app/PCSE00795"...
Status: Directory listing of "/ux0:/app/PCSE00795" successful

It doesn't matter if I use vitaFTP or moleculeFTP. I've only tried this with filezilla so far.

tl;dr permissions to even access these files are revoked if Near is accessing them, and there's no other way to decrypt the PFS (that I know of). Dumping confirmed dead on 3.60?

EDIT: bibibi claimed he could dump using the email app instead of near on 3.60. I tried this method, launching the manual in the email app and connecting to PC with FTP, but I get the same errors as above regarding "550 Invalid directory."
atreyu187 says he is working on a way to "decrypt games" on 3.60 here, but no further information was provided.
#406713 by fake me
Sun Jul 31, 2016 1:16 am
I think if we were to have something like ciangel but for the psvita, all this could be probably work its self out.
#406714 by fake me
Sun Jul 31, 2016 1:22 am
http://www.psx-place.com/threads/molecu ... ies.10080/

Note to anyone you can enable full read and write access by simply editing the files.c in the source code of MolecularShell (VitaShell fork) and then compile to have full access. And carts can be dumped for cart sharing by simply opening PC FTP client then downloading gro0:/ directory but you will have to manually input the location into FTP client as it is not enabled in this build but again can be added by simply editing the files.c then compiling it. Or by using this URL in FTP client to access without modifying the code.


Works for tm0:/ for registry edits, quick swap of PSN accounts or even merging content from multiple accounts. Active and banned work provided you still have the act.dat and needed rif/rap files as well as registry files.

sa0, pd0 well basically all directories can be called upon manually for the file system, game carts and memory internal and external.

Who is online

Users browsing this forum: No registered users and 2 guests