Open discussions on programming specifically for the PS Vita.
Forum rules: Forum rule Nº 15 is strictly enforced in this subforum.
#232269 by Sunny-Tech-UK
Sat Jan 26, 2013 10:14 am
Hi guys.

I am trying to connect to psn with my vita on 2.02.

I have used these two guides:

http://wololo.net/2013/01/25/psn-and-on ... les-proxy/

and

http://wololo.net/2013/01/26/psn-and-on ... fiddler-2/


I have tried doing the steps for each guide many times, and each time I do, I get the same error message on my vita, which is "C3-14978-9"

I am using the UK .xml file provided in both guides and my vita is on 2.02.

I am using wireless internet on my laptop.

When I do the internet connection test with the proxy settings, everything is connected apart from Playstation network.

I have used ipconfig and used my ipv4 address.

Thanks for your help,

Sunny.
Advertising
#232342 by JonathanH
Sat Jan 26, 2013 2:49 pm
If you can't reach the PSN network you are doing it wrong.

To find your LAN Address:
Spoiler
Open CMD
Type ipconfig
Look for the address that is called IPv4 Address usually 192.168.1.X



PSVita Settings: Assign a Proxy to your Wi-fi connection on the Vita, set it to the LAN address of the computer running Fiddler.
Spoiler
192.168.1.X

with port number
Spoiler
8888


Fiddler Settings:
Tools -> Fiddler Options -> Make sure it is set to port 8888 and tick the box called Allow Remote computers to connect.
paste this in the box for
Bypass Fiddler for links that start with:
Spoiler
<-loopback>;gs-sec.ww.np.dl.playstation.net




Get your PSVita's, psp2-updatelist for your region.
since you have a UK Account here is the link:
Spoiler
http://www.mediafire.com/?bb87uh39do97t4s


Make sure you do these things:

Start the network logging program (Charles or Fiddler).

Do an internet test on the Vita.

You should get a website address that looks like fXX01.psp.update.playstation.net/XXXXXXXXXXXXXXXX'
click the drop down menu and click from file...
change it's source to the psp2-updatelist file you downloaded earlier.

Click save.

Inspectors Tab -> Then add a Query String named var with the value 02050000

It should work after that.
#232359 by Sunny-Tech-UK
Sat Jan 26, 2013 3:33 pm
Hello thank you for your reply JonathanH.

I have tried to do your steps and I tried both fiddler2 and charles, but still I am having no luck.

The website which comes up in fiddler2 and charles is: http://ftw01.psp2.update.playstation.net

Does the region of the console make a difference?

I only ask as my vita is from Taiwan (tw) and the .xml file is UK, and my psn account is UK.

Would the UK .xml file need to be modified to TW instead of UK?

I am sitting here in frustration, not being able to connect. :(

I keep getting the same error message "C3-14978-9"

I am not sure what to do now. :(

Thank you for your help.
#232360 by topjohnwu
Sat Jan 26, 2013 3:37 pm
Sunny-Tech-UK wrote:Hello thank you for your reply JonathanH.

I have tried to do your steps and I tried both fiddler2 and charles, but still I am having no luck.

The website which comes up in fiddler2 and charles is: http://ftw01.psp2.update.playstation.net

Does the region of the console make a difference?

I only ask as my vita is from Taiwan (tw) and the .xml file is UK, and my psn account is UK.

Would the UK .xml file need to be modified to TW instead of UK?

I am sitting here in frustration, not being able to connect. :(

I keep getting the same error message "C3-14978-9"

I am not sure what to do now. :(

Thank you for your help.

I'm from Taiwan too hi XD. You have to modify the .xml file, change region to tw.
#232377 by Sunny-Tech-UK
Sat Jan 26, 2013 4:26 pm
Hello topjohnwu.

I have tried to change the .xml file from region id "uk" to "tw", but I still cannot connect to psn.

Here is the contents of the .xml file:

<?xml version="1.0" encoding="UTF-8" ?>
- <update_data_list>
- <region id="tw">
<np level0_system_version="01.000.000" level1_system_version="01.000.000" level2_system_version="01.000.000" map="01.800.000" />
- <version system_version="01.000.000" label="2.05">
- <update_data update_type="full">
<image size="115214336">http://duk01.psp2.update.playstation.net/update/psp2/image/2013_0123/rel_db28ae7d77dba9d2c31431aa08e991ae/PSP2UPDAT.PUP?dest=uk</image>
</update_data>
</version>
- <recovery spkg_type="systemdata">
<image spkg_version="01.000.010" size="56269824">http://duk01.psp2.update.playstation.net/update/psp2/image/2013_0123/sd_a6893e64b91f2ad45267a1cdba7f1c71/PSP2UPDAT.PUP?dest=uk</image>
</recovery>
- <recovery spkg_type="preinst">
<image spkg_version="01.000.000" size="128289792">http://duk01.psp2.update.playstation.net/update/psp2/image/2013_0123/pre_3a31f1df1b88f6f727e8ffa509acdf10/PSP2UPDAT.PUP?dest=uk</image>
</recovery>
</region>
</update_data_list>


Also the address which comes up on charles is:http://ftw01.psp2.update.playstation.net, I have also tried to edit the .xml to include this, for example:

<?xml version="1.0" encoding="UTF-8" ?>
- <update_data_list>
- <region id="tw">
<np level0_system_version="01.000.000" level1_system_version="01.000.000" level2_system_version="01.000.000" map="01.800.000" />
- <version system_version="01.000.000" label="2.05">
- <update_data update_type="full">
<image size="115214336">http://ftw01.psp2.update.playstation.net/update/psp2/image/2013_0123/rel_db28ae7d77dba9d2c31431aa08e991ae/PSP2UPDAT.PUP?dest=tw</image>
</update_data>
</version>
- <recovery spkg_type="systemdata">
<image spkg_version="01.000.010" size="56269824">http://ftw01.psp2.update.playstation.net/update/psp2/image/2013_0123/sd_a6893e64b91f2ad45267a1cdba7f1c71/PSP2UPDAT.PUP?dest=tw</image>
</recovery>
- <recovery spkg_type="preinst">
<image spkg_version="01.000.000" size="128289792">http://ftw01.psp2.update.playstation.net/update/psp2/image/2013_0123/pre_3a31f1df1b88f6f727e8ffa509acdf10/PSP2UPDAT.PUP?dest=tw</image>
</recovery>
</region>
</update_data_list>

I have tried editing the .xml files and tried both ways multiple times, but I still cannot connect, I have followed the guides very closely and now I am about ready to give up, to be honest.

Anyone else can help me with this please?

Thank you for your help.
#232403 by zevo4th
Sat Jan 26, 2013 6:34 pm
I have same problem, the error message C3-14978-9 keep pop up when I try connect to PSN thingy, but the internet work perfectly (ie. browser, fb, livetwit).
I use reg1 US for my PSN ID
anyone can help us? :(

Who is online

Users browsing this forum: No registered users and 2 guests