Advertising (This ad goes away for registered users. You can Login or Register)

Issue about Media Engine in POPS

Open discussions on programming specifically for the PS Vita.
Forum rules
Forum rule Nº 15 is strictly enforced in this subforum.
Post Reply
User avatar
Rinnegatamante
VIP
Posts: 737
Joined: Sat Mar 26, 2011 10:02 am
Contact:

Issue about Media Engine in POPS

Post by Rinnegatamante » Thu Jan 03, 2013 8:16 pm

Hi guys,
i'm trying to solve Media Engine problem for TN's popcorn but i have a simple question:
Why Media Engine isn't emulated by POPS?
I tried to load an .mp3 file from a simple Lua Player using Media Engine functions just to try if it work and it works very fine.

I saw, also, PRO'S popcorn sources and i noticed that PRO'S popcorn make a patch to sceMeAudio_67CD7972.
I tried to do this patch in TN'S popcorn but nothing is changed.

So what's the problem?
Advertising
If you want, visit my website: http://rinnegatamante.it :D

User avatar
rafael707
Posts: 1272
Joined: Thu Sep 30, 2010 6:10 pm
Location: VITA/PS4 section

Re: Issue about Media Engine in POPS

Post by rafael707 » Thu Jan 03, 2013 8:31 pm

Rinnegatamante wrote:Hi guys,
i'm trying to solve Media Engine problem for TN's popcorn but i have a simple question:
Why Media Engine isn't emulated by POPS?
I tried to load an .mp3 file from a simple Lua Player using Media Engine functions just to try if it work and it works very fine.

I saw, also, PRO'S popcorn sources and i noticed that PRO'S popcorn make a patch to sceMeAudio_67CD7972.
I tried to do this patch in TN'S popcorn but nothing is changed.

So what's the problem?
ME is emulated within the vita side, not the psp emulator..
Advertising
Add me, I got a ps4 ;)

IRC
#pspcommunity
#vitadev

PS4/PS VITA IGN: raff_da_don

User avatar
Z80
Posts: 123
Joined: Tue Apr 17, 2012 8:19 am
Location: [CPU]

Re: Issue about Media Engine in POPS

Post by Z80 » Thu Jan 03, 2013 8:35 pm

ME is emulated through kermit_me_wrapper.prx and kermit_me_wrapper_2.prx imho ;)
did you try extract pops_01g.prx from vita psp emu fw > 1.81 and use with CEF ? it might work ...

User avatar
rafael707
Posts: 1272
Joined: Thu Sep 30, 2010 6:10 pm
Location: VITA/PS4 section

Re: Issue about Media Engine in POPS

Post by rafael707 » Thu Jan 03, 2013 8:47 pm

Z80 wrote:ME is emulated through kermit_me_wrapper.prx and kermit_me_wrapper_2.prx imho ;)
iono...
Add me, I got a ps4 ;)

IRC
#pspcommunity
#vitadev

PS4/PS VITA IGN: raff_da_don

romain337
Posts: 219
Joined: Wed Feb 29, 2012 10:42 am
Location: France
Contact:

Re: Issue about Media Engine in POPS

Post by romain337 » Fri Jan 04, 2013 9:55 am

Hi!

On the vita dev wiki I can see the tree of the flash0 file structure. There is also a piece of code to make a dump of it (not tried yet). What happen if I make a dump of the flash0 from my PSVITA 2.02, and if I found pops_01g.prx and the both kermit module? Can I put them in the save exploit directory and try to run a psx game with the popcorn plugin for TN-C? Or, more generally, can we use the kermit wrapper to have a greater homebrews compatibility (via media engine support)?

Maybe this sound like a dumb question, maybe not. I like to read all the stuff about hacking/programming. I just wanna learn, see if i'm wrong or not. I'm a programmer but I mostly do demos/intros for fun on platform I own. I have not so much knowledge in hacking.

EDIT: When i ask if we could use the both kermit module to improve homebrew compatibility, i mean, do we can make some kind of wrapper/hook to make it working? Is that Coldbird was trying to achieve?

foxsevent
Posts: 54
Joined: Wed Oct 03, 2012 1:07 pm

Re: Issue about Media Engine in POPS

Post by foxsevent » Mon Jan 07, 2013 9:32 am

I don't think you can do anything with kermit modules unless you know how to decrypt them and even then you would need to have a kernel exploit on the VITA in order to overwrite it or change it path.

Don't get confused kermit is a VITA module so nothing can be done with it unless we have kernel privileges unlike on PSP when we know how to get those.

romain337
Posts: 219
Joined: Wed Feb 29, 2012 10:42 am
Location: France
Contact:

Re: Issue about Media Engine in POPS

Post by romain337 » Mon Jan 07, 2013 5:18 pm

I have tried but something goes wrong. I have taken the TN sources and some piece of code for compile a "dumper" (from vitadevwiki and others threads here), but it crash, and the emulator stop when i run it (with error C-something). I'm pretty sure i have done some **** inside the code. In fact i dunno exactly what is going wrong, because i've tried last friday with some help coming from irc but i don't know so much about the PSP. I used it to play some homebrew instead of coding them for now. Anyway, i don't own any kernel exploit. I use UNO for now, but as somebody tell to me friday, to have a valid flash dump you have to run the "dumper" before TN, because it corrupt original the flash0.

So... there is nothing more to do ^^ Or ask for the source to the author.. but as i said i have not so much knowledge in psp hw/programming, so i prefer just wait instead of ask again and again how things work on psp. As a dev i'm pretty busy with some projects and i have not the time and the motivation to learn more..I can learn with google, but others projects and the life take almost everything.

People was cool on irc btw. thx to Z80, Xerpi, and some others who helped me to do my testing. I will wait... maybe we will have the media engine sound one day, or better, native homebrew. It's just question of time.

I prefer make some demos/intros using the graphics API (OpenGL mainly), instead of trying to dump the flash0 for now :) I make demos/intros since some years now, and that's fun for me, but i do not like to spend so much time into hacking.

If you guys know how to program, maybe you like games, or management apps, or desktop apps... you should try to hack something, to see if you like.. It's like the sudoku against the cross words..

Post Reply

Return to “Programming and Security”