Discuss official PS Vita games here
#202163 by Nelson93
Tue Nov 20, 2012 10:30 pm
Since I stupidly updated to v2.0 my save won't load at all! It loads for a second in the screen that allows you to run about then instantly starts the game again. Am I the only one having this problem? Any help would be greatly appreciated!!
Advertising
#202165 by Darton Staker
Tue Nov 20, 2012 10:38 pm
Got this on 1.81 so I think it's a general bug along with the rest of them, disappointed that this title was released in the state it is, appalling and disgusting.
Advertising
#202166 by Nelson93
Tue Nov 20, 2012 10:44 pm
Wow really! Did you have to start a new save? I really don't think I could bring myself to, with the sub par story and the terrible frame rate issues it'd just be a massive chore!! It's so sad though because the game looks great!
#202177 by Nelson93
Tue Nov 20, 2012 11:30 pm
Anyway I just raged posting this on ubisofts "ask a question" area:

"Why is it that I recently updated my psvita system to the hotly anticipated version 2.0 and Assassins creed somehow manages to corrupt my save data to the point where I tried to load my save data but it instantly just reset and started the title screen again? Not only that do you believe it was ok to show trailers that clearly show the gameplay being a lot smother than the actual game. Sometimes the game is so laggy that it's near unplayable. Surely treating a customer who was looking forward to this game in such a way that already made them predisposed to dislike the game due to the poor playability that then losing the save that ultimately was the product of my persistence. Is that ok for you as a company because I think it's despicable!"

I can guarantee that it won't lead to anything but for venting my rage it was great!

Who is online

Users browsing this forum: No registered users and 0 guests