#199864 by kirbix50
Thu Nov 15, 2012 1:51 pm
I'm pretty new with psp vita, I've been rooting phones since android came up and flashing and using adb, so I have some sort of sense.

What I would like to do is play psp games on this system.

How do I start?

info:
Eu/finland
1.81
Games which I(own) think should work/exploits: Monster hunter fu

Regards, Tom.
Advertising
#199865 by wololo
Thu Nov 15, 2012 2:03 pm
The Monster Hunter exploit requires Firmware 1.80 or below.
On 1.81, you need either Urbanix, Mad blocker Alpha, or Gravity Crash.
Advertising
#199885 by 30Wditch
Thu Nov 15, 2012 4:07 pm
I thought those games have been removed from the store?
#199886 by rafael707
Thu Nov 15, 2012 4:15 pm
30Wditch wrote:I thought those games have been removed from the store?


Correct, its to late to get those games from psn :(
#199946 by wololo
Thu Nov 15, 2012 10:43 pm
Correct, and I didn't say he could get them. I was just describing "you're scr..ed" with specific facts.
#199955 by BlueMew151
Fri Nov 16, 2012 12:14 am
kirbix50 wrote:And I suppose there is no way to debrand back to 1.8?


There is no known way to downgrade at the moment.

Who is online

Users browsing this forum: No registered users and 2 guests