Unleash the full power of your PSP with a Custom Firmware.
Download and installation tutorial at http://wololo.net/wagic/cfw4dummies
#125988 by jamon
Fri Feb 10, 2012 10:14 pm
Hello Wololo,

Thanks for all the PSP updates and getting me into homebrew. My PSP is at 6.39 LME 9.7 and all is well. However I have recently seen that there is a new PRO B10 firmware along with a PSP 6.60 update.

So here is my question:

Will I get any real benefits if I upgrade to 6.60 PSP firmware from 6.39 AND if so what is the difference between PRO and ME?

Thank you ever so much.
Advertising
#126126 by Casavult
Sun Feb 12, 2012 7:48 am
Both firmwares on 6.39 and 6.60 don't have much differences besides 6.60 can play 6.60 required games, but if you use the 6.60 version.txt like I do on 6.39, you will basically have 6.60 ME and/or 6.60 PRO.
Advertising
#126156 by The Z
Sun Feb 12, 2012 1:46 pm
There is just one real different between 6.39 ME/PRO and 6.60 ME/PRO, the native PSN support with the 6.60 version, thats all.

Well and maybe the plugin compatibility...
#136688 by stoneskull
Tue Apr 10, 2012 12:40 pm
what about the differences between ME and PRO?

and the differences of plug-in compatibility are interesting..

i saw there is a wiki page on PSP emulation recently made over at a nintendo site..
http://wiki.gbatemp.net/wiki/Emulation_on_PSP
this is very cool, with all the info on emulation in an easy to see way, all on one page.

it would cool to see more pages like this on all aspects of PSP use.. models, firmware, plug-in compatibility, etc.

now that the PSP is "retired" it would be a good time to make a comprehensive PSP wiki, i reckon.

edit:
look at this page: http://en.wikipedia.org/wiki/List_of_Pl ... tibilities

only up to 6.37.. but still informative..

it'd be good to know which games require 6.60
i'm finding it difficult to find this out
#138623 by Disturbed0ne
Wed Apr 18, 2012 5:36 am
fouadtjuhmaster wrote:I both never had those firmwares, cuz i prefer permanent patches


Why are you posting in a thread about 6.39/6.60 ME/PRO firmwares if you've never used either of them? :?

Again, STOP posting useless replies in numerous threads just to boost your post count...
#144598 by Genesis
Sat May 12, 2012 10:49 am
My psp(gon1004) runs 6.20 pro b 10 - Maybe cause of some plugins i forgot about havin installed, maybe i without thinking of it went for Patch versions, yet on pro b 10 i haven´t stumbled across iso files it couldn´t run. Not even games like Gran Turismo set to run (I think it was) update 6.35+ They all works like a charm :D Any know how??
#144603 by nisarg_kolhe
Sat May 12, 2012 11:28 am
According to me, If you want the best compatibility with game backups, PRO it is. It has Inferno ISO mode which supports almost every PSP game exists. And when PRO-C comes out, you'll be able to play every PSP game which supports Ad-hoc mode or Infrastructure online on PRO servers!
But if you want better homebrew compatibility, go for ME. It supports leda.prx plugin which enables you native 1.50 kernel homebrews which you can launch directly from XMB without any use of homebrew. ;)
And about 6.39 and 6.60, its like just the difference of digits, as you can use 6.60 version.txt on 6.60 and still use PSN, play latest games etc.
#144613 by Genesis
Sat May 12, 2012 12:21 pm
nisarg_kolhe wrote:According to me, If you want the best compatibility with game backups, PRO it is. It has Inferno ISO mode which supports almost every PSP game exists. And when PRO-C comes out, you'll be able to play every PSP game which supports Ad-hoc mode or Infrastructure online on PRO servers!
But if you want better homebrew compatibility, go for ME. It supports leda.prx plugin which enables you native 1.50 kernel homebrews which you can launch directly from XMB without any use of homebrew. ;)
And about 6.39 and 6.60, its like just the difference of digits, as you can use 6.60 version.txt on 6.60 and still use PSN, play latest games etc.

Sweet info THX for that ;)

Who is online

Users browsing this forum: No registered users and 7 guests