Page 1 of 1

Assassin's Creed Unity

Posted: Tue Nov 11, 2014 8:13 am
by eliptics14
Hi Guys,

Does anyone knows what PS 4 firmware needed for AC:unity, I'm still using 1.76 version with my PS4.


TIA

Re: Assassin's Creed Unity

Posted: Wed Nov 12, 2014 11:37 am
by Masterhack
i want know too is unity working on 1.76 fw?

thanks for reply

Re: Assassin's Creed Unity

Posted: Thu Nov 13, 2014 6:24 pm
by RyanAD
how do i check that ?

i have pre-ordered the game from Amazon ... i should be receiving it next week (free shipping order)

ps. i have already updated to the latest fw. (2.0x)

Re: Assassin's Creed Unity

Posted: Fri Nov 14, 2014 12:43 pm
by Masterhack
i risk and bought this game and play and still have 1.76 update is not necesary

Re: Assassin's Creed Unity

Posted: Mon Nov 24, 2014 7:56 am
by eliptics14
Does it ask you to update when downloading the patches?

Re: Assassin's Creed Unity

Posted: Tue Nov 25, 2014 7:51 pm
by YoshiInAVoid
Anyone know about GTA V and Little Big Planet 3? I'm interested in playing these games but it's not worth it to lose an exploit.

Re: Assassin's Creed Unity

Posted: Thu Nov 27, 2014 11:51 pm
by Masterhack
No, you donĀ“t downloading patches when you want update you must newest fw

Re: Assassin's Creed Unity

Posted: Wed Dec 03, 2014 6:31 pm
by YoshiInAVoid
I don't care about patches or online. I just want to play Far Cry 4, GTA V, or Little Big Planet 3 on PS4 firmware 1.76. Which of these games require you to update, and which just work?

Re: Assassin's Creed Unity

Posted: Sun Dec 14, 2014 6:47 am
by Casavult
YoshiInAVoid wrote:I don't care about patches or online. I just want to play Far Cry 4, GTA V, or Little Big Planet 3 on PS4 firmware 1.76. Which of these games require you to update, and which just work?
All of these will require you to update afaik.

Re: Assassin's Creed Unity

Posted: Tue Apr 28, 2015 4:52 am
by sosad
I'm interested in playing these games but it's not worth it to lose an exploit.