Open discussions on programming specifically for the PS Vita.
Forum rules: Forum rule Nº 15 is strictly enforced in this subforum.
#419924 by ivo2376
Sun Sep 10, 2017 2:49 pm
so install ubuntu 12.04 to start running
vdpm psptoolchain ps3toolchain ps4toolchain and qcma and a nodejs henkaku or firekaku-ps4 ?

comes to little problems now and often
after adding qcma PPA to apt
it refuses to update after version heck
says:

verhoeve@EEM2:~$ sudo apt-get install qcma
[sudo] password for verhoeve:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
qcma : Depends: libavcodec-ffmpeg56 (>= 7:2.4) but it is not installable or
libavcodec-ffmpeg-extra56 (>= 7:2.4) but it is not installable
Depends: libavformat-ffmpeg56 (>= 7:2.4) but it is not installable
Depends: libavutil-ffmpeg54 (>= 7:2.4) but it is not installable
Depends: libqt5core5a (>= 5.5.0) but it is not installable
Depends: libqt5gui5 (>= 5.0.2) but it is not installable or
libqt5gui5-gles (>= 5.0.2) but it is not installable
Depends: libqt5network5 (>= 5.0.2) but it is not installable
Depends: libqt5sql5 (>= 5.0.2) but it is not installable
Depends: libqt5widgets5 (>= 5.0.2) but it is not installable
Depends: libstdc++6 (>= 5.2) but 4.6.3-1ubuntu5 is to be installed
Depends: libswscale-ffmpeg3 (>= 7:2.4) but it is not installable
E: Unable to correct problems, you have held broken packages.
verhoeve@EEM2:~$

theres a solution compiling the packages manually
heres the script

sudo apt-get update
sudo apt-get -y install autoconf automake build-essential libass-dev libfreetype6-dev \
libsdl2-dev libtheora-dev libtool libva-dev libvdpau-dev libvorbis-dev libxcb1-dev libxcb-shm0-dev \
libxcb-xfixes0-dev pkg-config texinfo wget zlib1g-dev



mkdir ~/ffmpeg_sources


cd ~/ffmpeg_sources
wget http://www.tortall.net/projects/yasm/re ... 3.0.tar.gz
tar xzvf yasm-1.3.0.tar.gz
cd yasm-1.3.0
./configure --prefix="$HOME/ffmpeg_build" --bindir="$HOME/bin"
make
make install


cd ~/ffmpeg_sources
wget http://www.nasm.us/pub/nasm/releasebuil ... 01.tar.bz2
tar xjvf nasm-2.13.01.tar.bz2
cd nasm-2.13.01
./autogen.sh
PATH="$HOME/bin:$PATH" ./configure --prefix="$HOME/ffmpeg_build" --bindir="$HOME/bin"
PATH="$HOME/bin:$PATH" make
make install


cd ~/ffmpeg_sources
wget http://download.videolan.org/pub/x264/s ... 64.tar.bz2
tar xjvf last_x264.tar.bz2
cd x264-snapshot*
PATH="$HOME/bin:$PATH" ./configure --prefix="$HOME/ffmpeg_build" --bindir="$HOME/bin" --enable-pic --enable-static --disable-opencl
PATH="$HOME/bin:$PATH" make
make install

#cd ~/ffmpeg_sources
#wget http://download.videolan.org/pub/x264/s ... 64.tar.bz2
#tar xjvf last_x264.tar.bz2
#cd x264-snapshot*
#PATH="$HOME/bin:$PATH" ./configure --prefix="$HOME/ffmpeg_build" --bindir="$HOME/bin" --enable-static --disable-opencl
#PATH="$HOME/bin:$PATH" make
#make install


sudo apt-get install cmake mercurial
cd ~/ffmpeg_sources
hg clone https://bitbucket.org/multicoreware/x265
cd ~/ffmpeg_sources/x265/build/linux
PATH="$HOME/bin:$PATH" cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX="$HOME/ffmpeg_build" -DENABLE_SHARED:bool=off ../../source
make
make install


cd ~/ffmpeg_sources
wget -O fdk-aac.tar.gz https://github.com/mstorsjo/fdk-aac/tarball/master
tar xzvf fdk-aac.tar.gz
cd mstorsjo-fdk-aac*
autoreconf -fiv
./configure --prefix="$HOME/ffmpeg_build" --disable-shared
make
make install


cd ~/ffmpeg_sources
wget http://downloads.sourceforge.net/projec ... 9.5.tar.gz
tar xzvf lame-3.99.5.tar.gz
cd lame-3.99.5
./configure --prefix="$HOME/ffmpeg_build" --enable-nasm --disable-shared
make
make install


cd ~/ffmpeg_sources
wget https://archive.mozilla.org/pub/opus/opus-1.1.5.tar.gz
tar xzvf opus-1.1.5.tar.gz
cd opus-1.1.5
./configure --prefix="$HOME/ffmpeg_build" --disable-shared
make
make install


sudo apt-get install git
cd ~/ffmpeg_sources
git clone --depth 1 https://chromium.googlesource.com/webm/libvpx.git
cd libvpx
PATH="$HOME/bin:$PATH" ./configure --prefix="$HOME/ffmpeg_build" --disable-examples --disable-unit-tests --enable-vp9-highbitdepth --enable-pic
PATH="$HOME/bin:$PATH" make
make install

cd ~/ffmpeg_sources
wget http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
tar xjvf ffmpeg-snapshot.tar.bz2
cd ffmpeg
PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure \
--prefix="$HOME/ffmpeg_build" \
--pkg-config-flags="--static" \
--extra-cflags="-I$HOME/ffmpeg_build/include" \
--extra-ldflags="-L$HOME/ffmpeg_build/lib" \
--bindir="$HOME/bin" \
--enable-gpl \
--enable-libass \
--enable-libfdk-aac \
--enable-libfreetype \
--enable-libmp3lame \
--enable-libopus \
--enable-libtheora \
--enable-libvorbis \
--enable-libvpx \
--enable-libx264 \
--enable-libx265 \
--enable-nonfree
PATH="$HOME/bin:$PATH" make
make install
hash -r


after a cmake and qt upgrade i eventually would want started to make building qcma latest myself
but im so lauzy and i need to go back becuz my weekend is over so its back a week at the institute

do u know a fix for installing those to /usr/local and have runlib them so it finds them ?
Advertising
#420007 by ivo2376
Fri Sep 15, 2017 10:12 pm
make[1]: Entering directory `/home/verhoeve/pc-code/qcma/common'
g++ -c -pipe -Wno-write-strings -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -Wall -Wextra -Wdisabled-optimization -Wformat=2 -Winit-self -Wmissing-include-dirs -Woverloaded-virtual -Wundef -Wno-unused -Wno-missing-field-initializers -Wno-format-nonliteral -O2 -fPIC -Wall -W -D_REENTRANT -DQT_WEBKIT -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DQCMA_VER=\"v0.4.1\" -DFFMPEG_ENABLED -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr/local/include -I/usr/include/libusb-1.0 -I/usr/include/libxml2 -I. -o cmaevent.o cmaevent.cpp
cmaevent.cpp: In member function ‘void CmaEvent::vitaEventSendHttpObjectFromURL(vita_event_t*, int)’:
cmaevent.cpp:637:43: error: ‘Sha256’ is not a member of ‘QCryptographicHash’
make[1]: *** [cmaevent.o] Error 1
make[1]: Leaving directory `/home/verhoeve/pc-code/qcma/common'
make: *** [sub-common-make_default] Error 2


the main question for me is howto get passed this compile error
thanks
Advertising

Who is online

Users browsing this forum: No registered users and 2 guests