Open discussions on programming specifically for the PS Vita.
Forum rules: Forum rule Nº 15 is strictly enforced in this subforum.
#292050 by SMOKE
Sun Sep 01, 2013 5:07 pm
Code: Select allsmoke@smoke:~$ pkg-config --libs --cflags libvitamtp
Package 'libvitamtp' has no Description: field
smoke@smoke:~$ ls -l /usr/lib/libvitamtp.*
lrwxrwxrwx 1 root  root      19 May 17 03:35 /usr/lib/libvitamtp.so.2 -> libvitamtp.so.2.0.0
-rwxrwxr-x 1 smoke smoke 537940 Jul 25 20:39 /usr/lib/libvitamtp.so.2.0.0
smoke@smoke:~$ ls -l /usr/include/vitamtp.h
-rw-rw-r-- 1 smoke smoke 23289 May 27 19:06 /usr/include/vitamtp.h
smoke@smoke:~$ echo $PKG_CONFIG_PATH

smoke@smoke:~$
Advertising
#292052 by codestation
Sun Sep 01, 2013 5:12 pm
Code: Select allsmoke@smoke:~$ pkg-config --libs --cflags libvitamtp
Package 'libvitamtp' has no Description: field

You are still using the old libvitamtp.pc. The original file is invalid (doesn't have a description field). Copy the libvitamtp.pc contents that i posted to your pkgconfig directory. In archlinux the directory is located in /usr/lib/pkgconfig, i don't know where is located in Ubuntu (*sigh* @ distro fragmentation).
Advertising
#292063 by codestation
Sun Sep 01, 2013 6:11 pm
SMOKE wrote:Project MESSAGE: Warning: unknown QT: widgets

Widgets is only valid in Qt5 but qmake-qt4 on my system doesn't generate that warning. In your case the warning shouldn't be a problem so try to continue with the make command.

I am downloading Ubuntu to run it in a VM to see whats the problem with this since i cannot reproduce that warning on Archlinux.
#292064 by SMOKE
Sun Sep 01, 2013 6:35 pm
codestation wrote:In your case the warning shouldn't be a problem so try to continue with the make command.

I just tried it, and heres the error im getting:
Code: Select allIn file included from /usr/local/include/libavformat/avio.h:31:0,
                 from /usr/local/include/libavformat/avformat.h:207,
                 from avdecoder.h:28,
                 from cmaobject.cpp:22:
/usr/local/include/libavutil/common.h: In function ‘int32_t av_clipl_int32_c(int64_t)’:
/usr/local/include/libavutil/common.h:150:47: error: ‘UINT64_C’ was not declared in this scope
make: *** [cmaobject.o] Error 1
smoke@smoke:~/Desktop/qcma$

codestation wrote:I am downloading Ubuntu to run it in a VM to see whats the problem with this since i cannot reproduce that warning on Archlinux.

Ok thanks
#292068 by codestation
Sun Sep 01, 2013 7:12 pm
SMOKE wrote:
codestation wrote:In your case the warning shouldn't be a problem so try to continue with the make command.

I just tried it, and heres the error im getting:


EDIT: update your qcma sources. I modified the avdecoder to compile in older versions of ffmpeg.
#292214 by SMOKE
Mon Sep 02, 2013 9:22 pm
Thank you codestation its working now :)
I like how I dont have to open the terminal every time I want to test homebrews.
In fact, I usually copy 15-20 homebrews at a time and test them one by one :lol:
If I run into any errors, Ill let you know
#295778 by codestation
Mon Sep 23, 2013 3:51 am
Bump. Added a windows version to the first post. Only had the chance to test basic functionality: backup/restore of a game, streaming of photos, music and videos via wireless/usb.

Who is online

Users browsing this forum: No registered users and 2 guests