Open discussions on programming specifically for the PS Vita.
Forum rules: Forum rule Nº 15 is strictly enforced in this subforum.
#406188 by devildwarf
Thu Jul 21, 2016 8:50 pm
suzy_k wrote:Hi guys. Dusted off my PS Vita and booted it up after the longest time today. Connected it to my laptop and QCMA, only to be greeted with the dreaded "update your firmware" message. This is what I get for not keeping my Vita in Airplane mode. :?

I know the situation may be somewhat salvable if I use Charles to spoof a firmware update. But the update files for 3.01 are down on zload, and I can't find them anywhere else! Does anyone have them? Please help me out by uploading them if you can. Thanks. :)

I have one from OpenCMA r5: psp2-updatelist.xml, but I don't think that'll work. I'm following the instructions in this video: https://www.youtube.com/watch?v=B__jx3RaNYs

Either that, or I wait for a new exploit. Are exploits still coming out for the Vita? I hope so. Thanks for your hard work, everyone.

If its just the update your vita message just put it in airplane mode then restart the vita (turn it off by holding the power button) then when you reboot use QMCA with the correct protocol and the offline mode button selected (in settings in QMCA) and it should connect and you shouldn't see the update vita message.
Advertising
#406190 by suzy_k
Thu Jul 21, 2016 10:12 pm
devildwarf wrote:If its just the update your vita message just put it in airplane mode then restart the vita (turn it off by holding the power button) then when you reboot use QMCA with the correct protocol and the offline mode button selected (in settings in QMCA) and it should connect and you shouldn't see the update vita message.


Hi, thanks for responding so quickly! I think I'm outta luck at this point. Sony is super-aggressive about PSV updates. I should've gone into Airplane Mode and then should've rebuilt the database immediately after, but alas. I was impatient.

I tried that, and unfortunately, it didn't work. I even tried rebuilding the database. Also, I've had QCMA run in Offline mode since I installed it years ago.

I also set QCMA to Custom, and underneath that, FW 3.10 - 1800010, and underneath that, it says 1800010. I don't know if that refers to 3.01 or not, but I got the same update message on every other FW I tried. I even managed to get my hands on the psp2-updatelist-261.xml, but using it with Charles didn't solve the issue. I just keep getting errors with that .xml.

I tried Vita Update Blocker as well, but I'm pretty sure it's not working because the latest FW update (3.60) wasn't released a week ago. It works--it manages to spoof the firmware so whenever I check System Update (it tells me I have the latest firmware installed), but when I go into CMA, I get the update message. Even when I click on the "update your system" link from CMA--it gives me the "latest update installed" message, but CMA won't let me proceed.

So CMA and PSN are stuck in the update loop; I'm guessing it's some Sony firmware signing issue at this point. Guess I'll try again when Sony releases a new update. But Sony might've gotten smart and patched the exploit by now. Oh well.

I don't know if using a PS3 to connect will solve anything. The PS3 in my house is on the latest firmware (sadly it doesn't belong to me).

I could also wait for the next exploit... if it ever comes out. I've got $27 in my PSN account that I can't take out. :( Sony refuses to refund you directly for games...

Anyway, check this out:

http://i.imgur.com/o7HYz5V.png

I managed to access my PSV's internals via FTP... from the PSP emulator (TN-V) itself! I used the native FTP Connection built into CFW 6.60. But the PSV doesn't recognize any files unless they're in folders. I managed to transfer a few .mp3s this way. Now, the PSV recognized the music files, but the PSP emulator didn't. :( I wonder if I'll be able to transfer games this way. It might, but IDK where everything should go; it's been so long since I used this thing. Plus I only have a 4GB memory card.

EDIT: Oh my god, it takes forever to transfer games this way. 50 minutes for 1.36GB! Also, it looks like you can't directly play the ISO itself--you have to extract the data files and so on. You have to follow the same format as the other games. CMA does this for you automatically when you transfer games over (obviously), and I'll have to do it for myself manually every time... yikes.
Advertising
#406478 by suzy_k
Fri Jul 29, 2016 9:07 pm
I'm happy to report that my PS Vita (on 3.01) is no longer asking me to update to the latest firmware.

Basically, after trying a bunch of times to salvage my Vita a few weeks back, I decided to give up, switch on Airplane Mode, and put it back in my drawer, out of sheer frustration. And it paid off!

Just today, I switched my OS to Ubuntu 16.04, and I thought I'd install QCMA for kicks. I thought my PS Vita would be stuck on the update screen in CMA forever... but nope! QCMA Linux seems to have some something to make the Vita think it's on the latest firmware. Maybe because it was off for so long? Who knows.

Everything is working perfectly now. Just backed up my Vita to my computer. I'm so glad I didn't do something rash and foolish like choosing to update to the latest firmware out of anger. Also, Airplane Mode. I learned to always use Airplane Mode. Don't know why I neglected switching it on in the past.

I knew QCMA would come through! Thank you, codestation!

To be honest, QCMA doesn't do much for me... only because I only have a tiny 4GB card in my Vita! That's like 1-2 full games. :| And PSV memory cards are still ridiculously expensive! I wish someone would hack the Vita to make it take normal SD cards, lol.
#406843 by monoestate
Sun Jul 31, 2016 6:05 pm
I just started QCMA for use with my VitaTV on 3.60 and whenever I try to use it to move pictures it promptly says it's disconnected from my PC.
It can back up saves and applications like normal but whenever it comes to pictures it always fails.
I'm running QCMA 0.3.12 on Win10
#412247 by Marien
Wed Sep 07, 2016 6:17 am
Why is it that every time I try to put something on my Vita by USB with QCMA I get 'cannot connect' errors and have to use Zadig to get it working? I'm on legit OFW and I can copy stuff by Wifi (which is too slow) but USB always gives me problems. And for some reason I can't copy any pictures by wifi but I can copy applications and save data.
#415276 by codestation
Wed Nov 23, 2016 5:15 pm
The systray plugins were removed from 0.3.12 onwards because they were too unstable. For proper system tray support your distro needs to provide Qt 5.4 at minimum. I did a quick search and it seems that Linux Mint is based on Ubuntu 14.04 who provices Qt 5.2.1 (too old).
#415731 by skie
Sun Dec 18, 2016 4:08 pm
Hello. I'm facing some issue with file transfer on latest qcma. Steps to reproduce:

1) Update database, transfer some files to vita
2) Put vita into sleep
3) Add some files to library folders, update database
4) Wake up vita, try to transfer files from PC. Then either the connection takes a long time and fails with "there are no %contenttype%" or even a PC completely disappears from the pairing list.

Restarting qcma (w/o restart vita) helps to get it works again.

Who is online

Users browsing this forum: No registered users and 3 guests