Advertising (This ad goes away for registered users. You can Login or Register)

PSV Required Firmware List - Need Volunteers

Discuss official PS Vita games here
User avatar
darkenvy
Posts: 191
Joined: Sat Mar 10, 2012 4:37 am

Re: PSV Game list?

Post by darkenvy » Sat Sep 15, 2012 2:06 pm

cradle wrote:
xTeZx wrote:
fate6 wrote:there are in fact forced updates on physical and digital games
its just the required FW is so low that we all are above it :3
actually im pretty sure Gravity Rush wanted me to update to 1.61? not too sure about which firmware it was, but i do recall Gravity Rush asking me to update. as i didnt have VHBL at the time, i went ahead and updated :)
Gravity Rush requires OFW 1.67. But I think it would be a great idea to make a list with all PSV games and their required FW. I think this could be really interesting in the near future.
Can you vouch or confirm for the gravity rush 1.67? I'll give it the green light if you can check.
Advertising
PSVita 1 : Unboxed → 1.61 → Everybody's Tennis Exploit → 1.81 → Urbanix Exploit
PSVita 2 : 1.813.51 → Rejuvinate & TN-V
PSTV 1 : 3.35 → Whitelist Hack & Rejuvinate
PSTV 2 : Latest FW Always

User avatar
cradle
Posts: 45
Joined: Mon Aug 20, 2012 3:33 pm

Re: PSV Game list?

Post by cradle » Sat Sep 15, 2012 3:24 pm

darkenvy wrote: Can you vouch or confirm for the gravity rush 1.67? I'll give it the green light if you can check.
Yep. I bought the Gravity Rush catridge in germany and it forces me to upgrade to OFW 1.67. 100% sure about this.
Advertising

User avatar
cradle
Posts: 45
Joined: Mon Aug 20, 2012 3:33 pm

Re: PSV Required Firmware List

Post by cradle » Sat Sep 15, 2012 3:56 pm

Eventually you could add games which are definitely run on all Firmwares (starting with the roll-out FW 1.05/1.06).
This way, users who read your list will know that you didn't forget these games and they are safe to buy.
2 game which I can confirm to run with OFW 1.06 are:

- ModNation Racers: Roadtrip
- Rayman Origins

mlc
Posts: 389
Joined: Tue Apr 17, 2012 9:28 pm
Location: america =(

Re: PSV Required Firmware List

Post by mlc » Sat Sep 15, 2012 6:03 pm

Sound Shapes requires 1.69. --after posting, I realized that Sound Shapes is PSN only, so it presently requires 1.80 unless you have a working proxy, and will continue to require whatever firmware is required by PSN (unless you already downloaded it, in which case you must be on 1.69, which I found out cuz I downloaded it while I still had the SC3 VHBL on 1.67)

User avatar
darkenvy
Posts: 191
Joined: Sat Mar 10, 2012 4:37 am

Re: PSV Required Firmware List

Post by darkenvy » Tue Sep 18, 2012 5:23 pm

The list has been updated. Anyone else have any games to add to the list? :)
PSVita 1 : Unboxed → 1.61 → Everybody's Tennis Exploit → 1.81 → Urbanix Exploit
PSVita 2 : 1.813.51 → Rejuvinate & TN-V
PSTV 1 : 3.35 → Whitelist Hack & Rejuvinate
PSTV 2 : Latest FW Always

Jd8531
Posts: 1753
Joined: Wed Apr 04, 2012 5:23 pm

Re: PSV Required Firmware List

Post by Jd8531 » Wed Sep 19, 2012 3:19 am

Ive gotten reports from people saying LBP force updates to play online or use community features

User avatar
fate6
Big Beholder
Posts: 7599
Joined: Fri Mar 09, 2012 1:18 am
Location: [fate6@Canterlot ~]$

Re: PSV Required Firmware List

Post by fate6 » Thu Sep 20, 2012 7:10 am

that would be PSN wanting the update not LBP ;)
Image
anon wrote:If you can't trust a 600 year old vampire in a prepubescent girl's body, who can you trust?

User avatar
darkenvy
Posts: 191
Joined: Sat Mar 10, 2012 4:37 am

Re: PSV Required Firmware List

Post by darkenvy » Sun Sep 30, 2012 2:29 am

fate6 wrote:that would be PSN wanting the update not LBP ;)
I'm going to have to agree. I can make a comment symbol (*) next to titles that require online play updates. I would expect that to be all. Do we know what firmware you need for LBP?
PSVita 1 : Unboxed → 1.61 → Everybody's Tennis Exploit → 1.81 → Urbanix Exploit
PSVita 2 : 1.813.51 → Rejuvinate & TN-V
PSTV 1 : 3.35 → Whitelist Hack & Rejuvinate
PSTV 2 : Latest FW Always

belux
Posts: 12
Joined: Sun Jun 10, 2012 3:25 pm

Re: PSV Required Firmware List

Post by belux » Tue Oct 02, 2012 10:57 am

sorry guys, a couple of questons:

a) where or how do you see the firmware required by a specified game? (both for digital and cartridge versions)

b) do you know the firmware required by FIFA13)

thanks

User avatar
darkenvy
Posts: 191
Joined: Sat Mar 10, 2012 4:37 am

Re: PSV Required Firmware List

Post by darkenvy » Tue Oct 02, 2012 12:17 pm

It requires someone with a low firmware to attempt to play a game (with no internet connection). The game should require you to update to "x.xx" firmware before playing. This is my best guess to figuring that out.

As for the FIFA, I'm afraid I don't know. I would really like to see lots of contribution towards this list as firmware is a common question. What version are you on currently belux? Any way of trying to play the game before buying? Snag a cart from a friend?
PSVita 1 : Unboxed → 1.61 → Everybody's Tennis Exploit → 1.81 → Urbanix Exploit
PSVita 2 : 1.813.51 → Rejuvinate & TN-V
PSTV 1 : 3.35 → Whitelist Hack & Rejuvinate
PSTV 2 : Latest FW Always

Post Reply

Return to “Games”