Discuss official PS Vita games here
#404596 by cvskid
Thu Apr 07, 2016 4:18 am
sentralizer wrote:
WolfFhang wrote:Anyone know the required firmware for Superbeat Xonic?

Superbeat Xonic requires 3.55 update. I stupidly bought it without thinking now I'm still on 3.01 and can't play it this is what happens when you spend most of your time playing older games you forget these issues lol.

I am on a psvita 3.52 firmware and this game asked me to update. I just clicked "no", and i never saw the message saying to update ever again and the game works for me. Don't know if that works for every game though.
Advertising
#404717 by sloppycrap
Tue Apr 12, 2016 3:31 pm
EDIT: on the US store
Does anyone know what TxK requires? If it's over 3.18 I'm not getting it but I'd really like to. Same thing for the Hotline Miami games.

EDIT2: And The Unfinished Swan. And how do I determine what the minimum firmware is other than buying a game and having it complain about what's on my Vita?
Advertising
#404769 by dyson
Sat Apr 16, 2016 6:11 am
cvskid wrote:
sentralizer wrote:
WolfFhang wrote:Anyone know the required firmware for Superbeat Xonic?

Superbeat Xonic requires 3.55 update. I stupidly bought it without thinking now I'm still on 3.01 and can't play it this is what happens when you spend most of your time playing older games you forget these issues lol.

I am on a psvita 3.52 firmware and this game asked me to update. I just clicked "no", and i never saw the message saying to update ever again and the game works for me. Don't know if that works for every game though.

Might be you're close enough to not require a technical reason to update (like freed RAM)
#404775 by Cyber
Sat Apr 16, 2016 6:35 pm
sloppycrap wrote:EDIT: on the US store
Does anyone know what TxK requires? If it's over 3.18 I'm not getting it but I'd really like to. Same thing for the Hotline Miami games.

EDIT2: And The Unfinished Swan. And how do I determine what the minimum firmware is other than buying a game and having it complain about what's on my Vita?

Hotline Miami runs on 3.18, while its sequel, having been released in March 2015, very likely requires something in 3.3x range.

The easiest way to check the minimum firmware requirement is to use Vita Game Update Checker with the Title ID as shown on a game's page in PS Store.
If the game has no update available, you can check .pkg file of the game in question directly, provided that you can get the link to that file on Sony's ares/zeus server or elsewhere.
#405149 by mindglitch
Sun May 08, 2016 3:15 pm
Any one have Axiom Verge on 3.51 or lower? Thanks.

EDIT-works on 3.57+
:(

Who is online

Users browsing this forum: No registered users and 1 guest