Forum rules: Forum rule Nº 15 is strictly enforced in this subforum.
#419787 by ivo2376
Sat Sep 02, 2017 8:46 pm
Msys2 after fresh install
step 1
pacman -Syuu
close terminal
step 2
pacman -Syuu
pacman -S base-devel msys2-devel mingw-w64-i686-toolchain mingw-w64-x86_64-toolchain
Advertising
#419795 by ivo2376
Sun Sep 03, 2017 1:56 am
hmm so the zlib-devel is refreshed with pacman -S zlib-devel
but what are the other development lib devel packages i should need for pacman ?
Advertising
#419796 by ivo2376
Sun Sep 03, 2017 2:10 am
nasty problem x86_64 vs w32
$ make
gcc -g -O2 -lz -Wall -o PrxEncrypter.exe crypto.o kirk_engine.o main.o
main.o: In function `gzip_compress':
/home/nick/psp/pspsdk/tools/PrxEncrypter/main.c:265: undefined reference to `deflateInit2_'
/home/nick/psp/pspsdk/tools/PrxEncrypter/main.c:265:(.text+0x230): relocation truncated to fit: R_X86_64_PC32 against undefined symbol `deflateInit2_'
/home/nick/psp/pspsdk/tools/PrxEncrypter/main.c:279: undefined reference to `deflate'
/home/nick/psp/pspsdk/tools/PrxEncrypter/main.c:279:(.text+0x25a): relocation truncated to fit: R_X86_64_PC32 against undefined symbol `deflate'
/home/nick/psp/pspsdk/tools/PrxEncrypter/main.c:290: undefined reference to `deflateEnd'
/home/nick/psp/pspsdk/tools/PrxEncrypter/main.c:290:(.text+0x277): relocation truncated to fit: R_X86_64_PC32 against undefined symbol `deflateEnd'
/home/nick/psp/pspsdk/tools/PrxEncrypter/main.c:282: undefined reference to `deflateEnd'
/home/nick/psp/pspsdk/tools/PrxEncrypter/main.c:282:(.text+0x2d9): relocation truncated to fit: R_X86_64_PC32 against undefined symbol `deflateEnd'
collect2: fout: ld gaf exit-status 1 terug
make: *** [Makefile:381: PrxEncrypter.exe] Fout 1
#419810 by ivo2376
Sun Sep 03, 2017 1:21 pm
for msys2 i cant get past previous reallocating error
but for wsl or uow windows on linux or ubuntu on windows
i see to manage with

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install g++ build-essential autoconf automake automake cmake doxygen bison flex libncurses5-dev libsdl1.2-dev libreadline-dev libusb-dev texinfo libgmp3-dev libmpfr-dev libelf-dev libmpc-dev libfreetype6-dev zlib1g-dev libtool libtool-bin subversion git tcl unzip

so remove the automake1.9 and replace with automake
then do automake1.9 manually

wget https://ftp.gnu.org/gnu/automake/automake-1.9.tar.gz
tar xzf automake-1.9.tar.gz
cd automake
aclocal
autoconf
automake
./configure
make
sudo make install

and continue building toolchain in progrezz
#419811 by ivo2376
Sun Sep 03, 2017 1:33 pm
the real solution is wsl or uow ubuntu on windows
but just install it as usual

but then adapt /etc/apt/sources.list
to reflect trusty instead of xenial

then u are good to install the packages like u did on trusty before with apt-get cmd from psptoolchain readme
so just

nano /etc/apt/sources.list
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install g++ build-essential autoconf automake automake1.9 cmake doxygen bison flex libncurses5-dev libsdl1.2-dev libreadline-dev libusb-dev texinfo libgmp3-dev libmpfr-dev libelf-dev libmpc-dev libfreetype6-dev zlib1g-dev libtool libtool-bin subversion git tcl unzip
./psptoolchain/sudo-toolchain.sh
and hope for luck like u did
#419812 by ivo2376
Sun Sep 03, 2017 1:53 pm
the other solution not as good but good as it is
is to install minpspw deb package

the real problem is we still need a
psptpm psptoolchain package manager for compiling eboots for psp and a
psputpm unfiedpsptoolchain package manager for compiling linux brew for psp

since mips linux is a reality on ti-** named uboot and psp app
this is ported to danzeff boot and vmlinux.bin gunzip

the real problem is its never been ported to 660 or 661 or vita or adrenaline

Who is online

Users browsing this forum: No registered users and 7 guests