Running old school games on your PSP? It's definitely possible
#414453 by Digitsie
Fri Oct 21, 2016 12:18 am
Has Picodrive ever managed to get the translated Phantasy Star II Text Adventures to work? I can only get them to work on Fusion so far, but not Pico.
Advertising
#414481 by Digitsie
Sat Oct 22, 2016 4:44 am
Just to answer my own question - yes, they work.

Now trying to figure out how to get 32X working - three bios, root directory of PicoDrive, yes?... I'm not -exactly- sure whether the problem is with me (most likely), the bios configuration set up, or not. Which 32X congigurations and games have you been able to get working with this?
#414504 by panther123
Sun Oct 23, 2016 3:51 am
just thought to let you know that Lunar 2:Eternal Blue is not working either,but it was working fine in picodrive 1.51 :|
I just a black screen,but no psp freeze when loading it up...
#414516 by Digitsie
Sun Oct 23, 2016 2:49 pm
I just looked at Lunar Eternal Blue and it works for me, as a .bin / .cue (not stored in a zip or anything.)
#414532 by Digitsie
Sun Oct 23, 2016 11:27 pm
Haven't figured out which 32X games work, haven't gotten any succesfully on a PSP1000 yet.

On the bright side, haven't run into a genesis game with a problem and the Sega CDs I've run have worked pretty well for me, yet.

The ones I used to have a problem with don't seem to be problematic anymore.
#414534 by panther123
Mon Oct 24, 2016 2:37 am
Digitsie wrote:I just looked at Lunar Eternal Blue and it works for me, as a .bin / .cue (not stored in a zip or anything.)

that is quite weird,it doesn't boot at all for me(psp slim-2000);do i absolutely need a .cue fileZ?i never needed it before....
#414535 by Digitsie
Mon Oct 24, 2016 4:04 am
Dunno, I remember having trouble with .bins sometimes so I just ran the .cue's.

My directory structure was like:

ROM ----
|
SEGA CD
|
[NAME}
|
.bin / .cue files

Then whenever I ran a CD, I ran the .cue for it. Isn't that how it's supposed to go?

Who is online

Users browsing this forum: No registered users and 8 guests