Running old school games on your PSP? It's definitely possible
#405950 by rsn8887
Mon Jul 04, 2016 5:11 pm
I can confirm the same bug is happening on my psp slim 3001 running CFW 6.60 Pro-C:

- if I start gpsp using the default recovery menu setting of "force high memory layout" set to disabled, I get 16 MB rom buffer only contrary to build 92 where I had 32mb always.

- if I enable "force high memory layout" in recovery, I get 32 MB as before. But I think the force high memory setting is incompatible with some other software that tries to enable it by itself.

EDIT: I am getting occasional crashes when loading zipped roms. The "unzipping" message shows up but the progress bar stays empty. The only way to reset when this happens is to restart the system by taking out the battery and putting it back in. Even holding the on/off button for a long time does not power off the system when this crash happens. This never happened with release 92. It happens about every 3rd time I try to load a zipped rom. After a restart, the unzipping usually works. I just tried aria of sorrow. It loaded fine on first try. I played for a bit, then went into the menu and loaded the same rom, aria of sorrow, again and it crashed on "unzipping" with a completely empty bar again (I think it crashes before it even starts unzipping just after the empty progress bar is drawn). I had to remove battery and put it back in to reset. On next try the same rom unzipped fine again.
Advertising
#405958 by ErikPshat
Tue Jul 05, 2016 12:22 am
In my Build 225 use memory 16 MB - this is not a bug. It was compiled specially, because when you use 32 MB of memory, strange things happen. If you want to see the inscription of 32 MB, all it can do itself...

  1. Open the file "Makefile.set" in the folder src "gpSP-kai-test".
  2. Change in the line "PSP LARGE MEMORY = 0" to 1
  3. Install "Minimalist PSPSDK"
  4. And make new Build.
How to make new build?...

  1. Hold down the SHIFT key, and right-click in an empty location folder "gpSP-kai-test"
  2. In the Explorer context menu, select "Open command window here"
  3. Enter the following command - "make" (without quotes).
  4. Wait for the end of the operation.
  5. The finished assembly can be found in the "obj" folder.
To clear the compilation results, enter the following command: "make clean" (without quotes).
Advertising
#405959 by rsn8887
Tue Jul 05, 2016 1:57 am
I see. Interesting. That explains the 16 MB memory then. Thank you for the great instructions!

However I think the hangs I get when unzipping sometimes must be a bug. Have you also experienced such lock-ups when unzipping a rom, where the progress bar stays empty and the psp becomes unresponsive until you take out the battery? The old versions definitely didn't show this problem.

EDIT: I can now reproduce the lock-up when unzipping everytime. It might have something to do with loading the cfg or sav file after it has been created after the first time loading a rom. If I delete the cfg and sav file, it loads fine once without lock-up. But then it locks up again when reloading the same rom a few times.

Here's how I could reproduce it both on 6.60 OFW and 6.60 PRO-C fix 3

1 - Install GPSP into game folder
2 - Put gba_bios.rom in GPSP folder
3 - Put zipped rom "GBA - D&D - Eye of the Beholder.zip" (from emuxtras packages) into GBA/ROM subfolder. The bug happens with other roms too but this one shows it most often for me. I saw it with Aria of Sorrow also.
4 - Start emulator
5 - Load above rom.
6 - While the game is running, on the copyright screen or later, press the ps button
7 - Repeat steps 5 and 6 a few time (two times was enough for me to see the lock-up)
8 - The emulator will lock up while the unzipping progress bar is completely empty. Only removing the battery will get you out of this state.

The above lock-up does not happen when I use CFW to enable "High Memory Layout" in the recovery menu to get the 32 MB rom buffer memory instead of 16 MB.

Following ErikPshat's instructions, I compiled a version of the binaries with the "PSP_LARGE_MEMORY = 1" flag set and 32 MB rom buffer showing. Note that in addition to installing minimalist pspsdk, I also had to copy four files from the ProCFW repo. I had to copy systemctrl_se.h and kubridge.h to pspsdk/psp/sdk/include and the libraries libpspsystemctrl_user.a and libpspkubridge.a to my pspsdk/psp/sdk/include and lib folders to get gpsp to compile.

This version works for me and doesn't exhibit the lock-ups on my PSP. I uploaded the new version binaries, just copy them over the original gpsp files if you want to try it out:
https://mega.nz/#!kYpGWI5Z!3DjmsylVcxKbxhDbX0lUWOlMYJFtySU81sUTHieTED0

I only tested this version on PRO-C fix 3 CFW on a PSP Slim 3001. I am not sure if it will work on other CFW or PSP models.
#405975 by ErikPshat
Tue Jul 05, 2016 10:03 pm
rsn8887, yeah, great job! I did not expect that someone will be interested to do everything myself .

P.S. And yes, I forgot to write, that the files includes and libs from PRO SDK I probably used for a long time to update in the "Minimalist PSPSDK", therefore, I forgot to warn you about this.
#406135 by Casavult
Thu Jul 14, 2016 9:19 pm
Nice! 32mb!

I would have compiled it myself but I'm too lazy to install Minimalist PSPSDK among other things to my PC after doing fresh wipe/install of the entire system 4 weeks ago.

Thanks to everyone involved in making this build!
#406245 by kry
Tue Jul 26, 2016 9:24 am
I think this version need to fix again because this version still have glitches in image. I played Advance war 2 and popup on the top always didn't show up. Popup on the bottom works like normal, only the top have a problem.
See the different:

Image

UO gpSP kai ver 3.4 test 3 Build 92 also have same prob. Im trying using old version of gpsp ver: 3.2 user test 02 no prob at all. Hope you can fix this glitches.
gpSP ver 3.2 user test 02 i got from here: [LINK REMOVED BY MOD]
#408075 by saekhor
Sun Aug 07, 2016 6:53 pm
Hello does anyone have a solution to this?

Every time i start this version of the emulator the screen remains black and the psp turn off, i have place both folders inside PSP/GAME, i have even place "UO gpSP kai" folder without the other one and still no luck, i also have the bios in place so i dont know what i'm missing here

at the moment the one i'm using is this " Unofficial gpSP Kai v3.5 mod" and this works without problem but with a little cracking on the sound

Cheers
PD: I'm using a PSP3000 runing on PRO-C
#410280 by rsn8887
Tue Aug 23, 2016 6:28 am
Thanks for the hint! You are right, I installed TempGBA-mod and it really seems to run better. It is awesome. TempGBA-mod even runs Powder 117 and Qwak. Qwak failed on gpsp, and I think Powder also didn't work on GPSP.

Who is online

Users browsing this forum: No registered users and 2 guests