Running old school games on your PSP? It's definitely possible
#405788 by DanielChief
Fri Jun 24, 2016 9:16 am
Hi, I can do a proper Hungarian translate. :) Where should I start? Get the English msg file and use your instructions, right?
Advertising
#405806 by rsn8887
Sun Jun 26, 2016 5:21 pm
There are two later versions of PSPUAE version 0.82S RC2 and version 0.83 Beta 1. I tested them and 0.83 B1 doesn't have AGA support, but it doesn't have the bug from 0.82 where in some games a large chunk of the right of the screen is missing which is good.

Reference: an old post by the author in the EAB forum

EDIT: I did some testing and I think version 0.80 Beta 20, available here
https://mega.nz/#!YZhRXCTT!qQ_wPLw6mJ75iWU5DUoVojHWBsHmD0aJTV4LRa9TSBQ is still the best in terms of the compatibility and speed. 0.83 beta 1 fails booting a lot of trackloader games. 0.82 has a bug where some of the screen on the right is missing.

EDIT2: In the original post, Picodrive (Genesis emulator) is listed as emulating Sega 32x, but it does not support 32x.
#406166 by Casavult
Wed Jul 20, 2016 12:48 am
@Luck

First of all... I think this thread needs a sticky, congratulations! ;) It's great to see a more up to date emulator index for the PSP as the other one is old and hasn't been updated in a few years if I remember right. Just a friendly request, if possible, please try to keep this updated as the PSP deserves it. <3

Second of all... Your download for Neko Project on PSP is at v0.33, which is old. There is a newer version v0.39.

Link: http://emuhani.seesaa.net/article/195546090.html

Edit: Here a few more emulators that you may have missed from the original dev websites (the only ones I could find that are still up and running :( )

http://psp.akop.org/ - Has a lot of emu's
http://zx81.zx81.free.fr/serendipity/ - This guy ported around 20 different emu's. Look on the right and scroll down until you see PSP emulators such as Atari 2600, ect.
#406974 by JohnDough69
Mon Aug 01, 2016 11:44 am
Hi @luck, your new version of the SNES Emulator is great, however i have one problem with it: when i try to load a save, the game either resets, or i get glitched screen. Also when i close the meualtor and open it back up the regular saves are all gone too.

I have a psp slim with the latest pro firmware 6.61 on it.
#407758 by luck
Fri Aug 05, 2016 11:06 am
ShimaFlareX wrote:You should probably include the snesadvance.dat with the Snes9xTYL emulator (or mention the file).
I think the latest is at https://raw.githubusercontent.com/17321 ... dvance.dat.
It adds speedhacks for several games.
I think it is supposed to be located in the "data" folder of the emulator.

Thanks again for the thread!


thanks

i didn t know about that file.
added in data.

JohnDough69 wrote:Hi @luck, your new version of the SNES Emulator is great, however i have one problem with it: when i try to load a save, the game either resets, or i get glitched screen. Also when i close the meualtor and open it back up the regular saves are all gone too.

I have a psp slim with the latest pro firmware 6.61 on it.

yea, seems the media engine version is a bit unstable.
i added the standard version.
i could be slower but it works.
#408241 by ShimaFlareX
Mon Aug 08, 2016 1:42 pm
I just tested both versions of the SNES9xTYL and both still crash when loading save states unfortunately.

Edit: The revision 27 from the website works fine (I've tested only the ME version): https://github.com/173210/snes9xTYL/releases
I guess we could try to figure out which of the commits is causing the issue. I tried to compile the latest version, but my compiler keep complaining about the flag -flto not being recognized. Removing the flag unfortunately gives me another error:

memmap.cpp:62:22: error: kubridge.h: No such file or directory
memmap.cpp: In member function 'u8 CMemory::Init()':
memmap.cpp:251: error: 'kuKernelGetModel' was not declared in this scope
memmap.cpp: In member function 'void CMemory::Deinit()':
memmap.cpp:353: error: 'kuKernelGetModel' was not declared in this scope
make[1]: *** [memmap.o] Error 1

I'm guessing I'm using an outdated version of the SDK. What did you use to compile your version?

Who is online

Users browsing this forum: No registered users and 4 guests