Advertising (This ad goes away for registered users. You can Login or Register)

PS Plus Heads up! PS Plus 12 Months subscription is $39.99 on Amazon for Prime Day. Get it while supplies last.

Installing the PSPSDK (Linux or Windows)

All the Help you need is here
Post Reply
User avatar
m0skit0
Guru
Posts: 3817
Joined: Mon Sep 27, 2010 6:01 pm

Re: Installing the PSPSDK (Linux or Windows)

Post by m0skit0 » Tue Apr 17, 2012 11:46 pm

Wolfx15T wrote:I have everything installed, I'm just not sure how to get link up-and-running
Then you should learn programming for PC first.
HeroKing wrote:well, what i did for starters was cd into the psplinkusb folder and ran "make release" which compiled all that ready to be used. the other stuff within the sdk i haven't touched yet. but the psplinkusb has a pdf file to teach you how to use it
Huh? An SDK is not meant to have programs, but to allow you to program your own stuff.
Advertising
I wanna lots of mov al,0xb
Image
"just not into this RA stuffz"

S0lll0s
Posts: 6
Joined: Mon May 07, 2012 2:35 pm

Re: Installing the PSPSDK (Linux or Windows)

Post by S0lll0s » Fri May 11, 2012 4:09 pm

Hello, I built this toolchain for the second time now, and I found a bug as well in 007-gdb and 008-insight installation scripts.
Those try to fetch an old version of said pieces of code, which don't exist on the ftp servers anymore. I attached the fixed files, hf coding!

(Woever has an account in forums.ps2dev.org please post this, I can't sign up due to an PHP sendmail error on their forums)

S0lll0s
psptoolchain-step78FIX.zip
Put these into ./scripts/
(1.61 KiB) Downloaded 170 times
Advertising

User avatar
Xian Nox
Retired Mod
Posts: 2749
Joined: Fri Nov 05, 2010 5:27 pm
Location: Over the hills and far away

Re: Installing the PSPSDK (Linux or Windows)

Post by Xian Nox » Tue Jun 05, 2012 7:21 pm

Now this is silly. Getting the following error on the last script of the psptoolchain:

Code: Select all

xian@linux-z2yr:~> cd projects/pspsdk/psptoolchain/scripts/
xian@linux-z2yr:~/projects/pspsdk/psptoolchain/scripts> sudo ./009-psplinkusb.sh 
root's password:
At revision 2494.
make -C pspsh clean
make[1]: Entering directory `/home/xian/projects/pspsdk/psptoolchain/scripts/psplinkusb/pspsh'
rm -f pspsh *.o
make[1]: Leaving directory `/home/xian/projects/pspsdk/psptoolchain/scripts/psplinkusb/pspsh'
make -C usbhostfs_pc clean
make[1]: Entering directory `/home/xian/projects/pspsdk/psptoolchain/scripts/psplinkusb/usbhostfs_pc'
rm -f usbhostfs_pc *.o
make[1]: Leaving directory `/home/xian/projects/pspsdk/psptoolchain/scripts/psplinkusb/usbhostfs_pc'
if ( which sdl-config ); then { make -C tools/remotejoy/pcsdl clean; } else { make -C tools/remotejoy/pc clean; } fi
which: no sdl-config in (/usr/bin:/bin:/usr/sbin:/sbin)
make[1]: Entering directory `/home/xian/projects/pspsdk/psptoolchain/scripts/psplinkusb/tools/remotejoy/pc'
rm -f remotejoy *.o
make[1]: Leaving directory `/home/xian/projects/pspsdk/psptoolchain/scripts/psplinkusb/tools/remotejoy/pc'
make -C pspsh all
make[1]: Entering directory `/home/xian/projects/pspsdk/psptoolchain/scripts/psplinkusb/pspsh'
g++ -Wall -g -D_PCTERM -I../psplink   -c -o pspsh.o pspsh.C
pspsh.C: In function ‘int strlen_cmd(int, char**)’:
pspsh.C:439:50: warning: format ‘%d’ expects argument of type ‘int’, but argument 4 has type ‘size_t {aka long unsigned int}’ [-Wformat]
pspsh.C:439:50: warning: format ‘%d’ expects argument of type ‘int’, but argument 4 has type ‘size_t {aka long unsigned int}’ [-Wformat]
pspsh.C: In function ‘char* command_gen(const char*, int)’:
pspsh.C:693:13: warning: variable ‘locals’ set but not used [-Wunused-but-set-variable]
pspsh.C: In function ‘int init_readline()’:
pspsh.C:974:39: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
g++ -Wall -g -D_PCTERM -I../psplink   -c -o parse_args.o parse_args.C
g++ -Wall -g -D_PCTERM -I../psplink   -c -o pspkerror.o pspkerror.C
g++ -Wall -g -D_PCTERM -I../psplink   -c -o asm.o asm.C
g++ -Wall -g -D_PCTERM -I../psplink   -c -o disasm.o disasm.C
g++ -o pspsh pspsh.o parse_args.o pspkerror.o asm.o disasm.o -lreadline -lcurses
/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: skipping incompatible /usr/lib/libcurses.a when searching for -lcurses
/usr/lib64/gcc/x86_64-suse-linux/4.6/../../../../x86_64-suse-linux/bin/ld: cannot find -lcurses
collect2: ld returned 1 exit status
make[1]: *** [pspsh] Error 1
make[1]: Leaving directory `/home/xian/projects/pspsdk/psptoolchain/scripts/psplinkusb/pspsh'
make: *** [all] Error 2
xian@linux-z2yr:~/projects/pspsdk/psptoolchain/scripts> 
(This is what I did to replicate it without running the entire thing over.)
This is what YaST gives me on packages with 'curses' in their name:

Code: Select all

# Status             Package                        | Summary                                  | Installed (Available)     |       Size

[Keep]               cdk                            | The Runtime for the Curses Developmen... | 4.9.13-152.1.2            |  328.0 KiB
[Keep]               cdk-devel                      | Development Part of Curses Developmen... | 4.9.13-152.1.2            |  263.0 KiB
[Keep]               cmus                           | Curses-based Ogg, MP3, WMA, and WAV P... | 2.4.3-1.6                 |  446.0 KiB
[Keep]               libncurses5                    | The New curses Libraries                 | 5.8-5.1.4                 | 1008.0 KiB
[Keep]               libncurses5-32bit              | The New curses Libraries                 | 5.8-5.1.4                 |  911.0 KiB
[Keep]               libncurses6                    | The New curses Libraries                 | 5.8-5.1.4                 |  961.0 KiB
[Keep]               libncurses6-32bit              | The New curses Libraries                 | 5.8-5.1.4                 |  907.0 KiB
[Keep]               ncurses-devel                  | Include Files and Libraries mandatory... | 5.8-5.1.4                 |   25.6 MiB
[Keep]               ncurses-devel-32bit            | Include Files and Libraries mandatory... | 5.8-5.1.4                 |   15.4 MiB
[Keep]               ncurses-utils                  | Tools using the new curses libraries     | 5.8-5.1.4                 |  119.0 KiB
[Keep]               yast2-ncurses                  | YaST2 - Character Based User Interface   | 2.21.4-3.1.3              |  967.0 KiB
[Keep]               yast2-ncurses-pkg              | YaST2 - Character Based Package Manag... | 2.21.2-1.1.2              |  767.0 KiB
[Do Not Install]     BitTorrent-curses              | Scatter-Gather Network File Transfer ... | (4.4.0-1.3)               |   28.0 KiB
[Do Not Install]     bpython                        | Fancy Curses Interface to the Python ... | (0.10.1-3.1.2)            |  417.0 KiB
[Do Not Install]     cgdb                           | Curses debugger                          | (0.6.6-5.1.2)             |  335.0 KiB
[Do Not Install]     ncmpc                          | Curses Client for the Music Player Da... | (0.20-1.1)                |  174.0 KiB
[Do Not Install]     perl-Curses                    | Terminal screen handling and optimiza... | (1.28-13.1.3)             |  332.0 KiB
[Do Not Install]     perl-CursesWidgets             | CursesWidgets Perl module                | (1.997-154.1.3)           |  202.0 KiB
[Do Not Install]     pms                            | Curses Client for the Music Player Da... | (0.42-2.5)                |  371.0 KiB
[Do Not Install]     python-curses                  | Python Interface to the (N)Curses Lib... | (2.7.2-7.10.1)            |  135.0 KiB
[Do Not Install]     python3-curses                 | Python Interface to the (N)Curses Lib... | (3.2.1-5.3.1)             |  137.0 KiB
[Do Not Install]     tig                            | An ncurses-based text-mode interface ... | (1.0-3.1)                 |  203.0 KiB
[Do Not Install]     wavemon                        | An ncurses monitoring application for... | (0.6.10-8.1.3)            |  113.0 KiB
[Do Not Install]     yast2-ncurses-devel            | YaST2 - Character Based User Interface   | (2.21.4-3.1.3)            |  321.0 KiB
As far as I can tell, I have the required library installed. So, any way to fix this?

User avatar
m0skit0
Guru
Posts: 3817
Joined: Mon Sep 27, 2010 6:01 pm

Re: Installing the PSPSDK (Linux or Windows)

Post by m0skit0 » Tue Jun 05, 2012 9:40 pm

Try with -lncurses.
I wanna lots of mov al,0xb
Image
"just not into this RA stuffz"

User avatar
SAUVAL DANNY
Posts: 27
Joined: Sun May 08, 2011 6:03 pm
Location: France
Contact:

Re: Installing the PSPSDK (Linux or Windows)

Post by SAUVAL DANNY » Sun Jul 15, 2012 1:48 pm

Thank you very much to you for this great tutorial I'll test it on Ubuntu 11.10!

EDIT 1 : The .deb of the minimalist doesn't work for me it says me that "xz: (stdin): File format not recognized" and it gives me some other errors....

So I'm trying ti install the PSP toolchain. It looks be working fine. I'm wating for it to finish to be able to see the result :) . I'll edit this message to give you my answer.
I'm french and my English is not perfect! Sorry.

Ubuntu user and Windows 7 64 bits


PSP 3004 6.20ProB9v3
PSP 1004 6.35ME
PS3 3.55 Kmeaw with Multiman
Wii 4.2 with HBC

framerate
Posts: 3
Joined: Wed Aug 15, 2012 6:45 pm

Re: Installing the PSPSDK (Linux or Windows)

Post by framerate » Wed Aug 15, 2012 6:47 pm

S0lll0s wrote:Hello, I built this toolchain for the second time now, and I found a bug as well in 007-gdb and 008-insight installation scripts.
Those try to fetch an old version of said pieces of code, which don't exist on the ftp servers anymore. I attached the fixed files, hf coding!

(Woever has an account in forums.ps2dev.org please post this, I can't sign up due to an PHP sendmail error on their forums)

S0lll0s
psptoolchain-step78FIX.zip
Thank you for taking the time to do this!

thorwak
Posts: 37
Joined: Tue Feb 21, 2012 2:06 pm
Location: .se

Re: Installing the PSPSDK (Linux or Windows)

Post by thorwak » Mon Sep 03, 2012 9:40 am

Thought I'd rebuild this again :) Starting with gcc 4.3.2 (since that is nicely pre-configured + fixes in this thread, thanks!), but I'm also interested in trying to use a later gcc.
Anyone tested how much breaks, or have a recommendation for a specific gcc version, or perhaps even did this and have updated patches?

JJS
Big Beholder
Posts: 1416
Joined: Mon Sep 27, 2010 2:18 pm
Contact:

Re: Installing the PSPSDK (Linux or Windows)

Post by JJS » Mon Sep 03, 2012 9:47 am

It seems that GCC is already at 4.6.3 on here: https://github.com/pspdev/psptoolchain

thorwak
Posts: 37
Joined: Tue Feb 21, 2012 2:06 pm
Location: .se

Re: Installing the PSPSDK (Linux or Windows)

Post by thorwak » Mon Sep 03, 2012 9:49 am

JJS wrote:It seems that GCC is already at 4.6.3 on here: https://github.com/pspdev/psptoolchain
Thanks a lot! Will use that instead, once I make sure the old one builds!

EDIT: The old toolchain built just fine, but the newer one was quite messy, mostly because plenty of librarys were included as well. Those took a lot of manual fix-ups to build (SDL* in particular was tricky), at least for me, but in the end it all worked actually. I'm not sure it was worth the trouble though :D

I'll try both toolchains and see if I notice anything worth mentioning speedwise when I find some time :)

poed
Posts: 4
Joined: Sun Oct 28, 2012 7:54 am

Re: Installing the PSPSDK (Linux or Windows)

Post by poed » Wed Oct 31, 2012 9:56 am

Very nice

Post Reply

Return to “Tutorials”