Page 11 of 11

Re: Installing the PSPSDK (Linux or Windows)

Posted: Sat Feb 08, 2014 11:27 pm
by SMOKE
Acid_Snake wrote:forget my dumbass, it's -lz, you just gotta install the zlib development files for the PSP SDK
Thanks Acid, that worked.

For future reference:
viewtopic.php?f=5&t=10849

Re: Installing the PSPSDK (Linux or Windows)

Posted: Mon Feb 10, 2014 4:15 am
by SMOKE
I have a question.. What's the reason the Op said not to delete the toolchain folder in your home folder?

Re: Installing the PSPSDK (Linux or Windows)

Posted: Thu May 01, 2014 8:48 pm
by soluslobo
Hello, I am on Ubuntu 14.04 and I have done every step correctly in the tutorial. When I get to

Code: Select all

sudo ./toolchain-sudo.sh
I get this

Code: Select all

ls: cannot access /usr/include/gmp.h: No such file or directory
ERROR: Install gmp before continuing.
../depends/check-gmp.sh: Failed.
ERROR: Could not run the toolchain script.
solus@freedom:~/psptoolchain$ 
Can someone help me with this? I have synaptic manager and it shows I have gmp-doc, php5-gmp installed. I don't know what is left to do. When I run

Code: Select all

sudo apt-get install libgmp3-dev
it says was already installed. Please help, thank you.

Re: Installing the PSPSDK (Linux or Windows)

Posted: Sat Nov 08, 2014 5:15 pm
by sl4kmex
This may be late but check in the /usr/include directory for any header file incuding gmp. On my machine I was able to resolve the issue by going into the psptoolchain file and changing the changing the check-gmp.sh file to have the following

Code: Select all

 ls /usr/include/gmpxx.h 1> /dev/null || { echo "ERROR: Install gmp before continuing."; exit 1; }
I changed /usr/include/gmp.h> to what is above because that was the name of the gmp file in my folder. I hope that it helps!

Re: Installing the PSPSDK (Linux or Windows)

Posted: Wed Jul 15, 2015 10:17 pm
by Railf
Does anyone have any explanation for this?:
viewtopic.php?f=24&t=43561

Re: Installing the PSPSDK (Linux or Windows)

Posted: Tue Sep 15, 2015 2:10 pm
by futurepr0n
Long shot, but figured I would ask..

I recently tried to re-take up PSPDev, been away for a while and looking to get back into it as a hobby.

I ended up going to the github hosted pspsdk and getting the psptoolchain and pspsdk, but when I ran the sudo_toolchain.sh I ended up having the following error after all was said and done (or at least, this was the final few lines)

Code: Select all

Installation Finished
Failed installing: freetype opentri SDL_ttf
Is there any help that someone may be able to offer me in order to resolve this? Or will these not hinder me much through development?

I see that there is this minimilast psp sdk out , but I was not familiar with that when I began programming - I always built using the original. Now that I am halfway through the installation - if I was to run the minimilast sdk install, would it resolve these issues? create new ones? or am I alright to try and get the devpaks from the minimilast that I seem to be unable to install (the freetype, opentri, and sdl_ttf)

http://sourceforge.net/p/minpspw/code/H ... k/devpaks/

Cant install toolchain

Posted: Thu Aug 02, 2018 9:20 pm
by Tau
When i run

Code: Select all

sudo sudo ./toolchain-sudo.sh
After some time I get this:

Code: Select all

/usr/bin/install -c -m 644 bfd.h /usr/local/pspdev/x86_64-unknown-linux-gnu/psp/include/bfd.h
/usr/bin/install -c -m 644 ../../bfd/../include/ansidecl.h /usr/local/pspdev/x86_64-unknown-linux-gnu/psp/include/ansidecl.h
/usr/bin/install -c -m 644 ../../bfd/../include/symcat.h /usr/local/pspdev/x86_64-unknown-linux-gnu/psp/include/symcat.h
/usr/bin/install -c -m 644 ../../bfd/../include/bfdlink.h /usr/local/pspdev/x86_64-unknown-linux-gnu/psp/include/bfdlink.h
make[3]: se sale del directorio '/home/tau/Documentos/psp/pspsdk/psptoolchain/build/binutils-2.16.1/build-psp/bfd'
make[2]: se sale del directorio '/home/tau/Documentos/psp/pspsdk/psptoolchain/build/binutils-2.16.1/build-psp/bfd'
Makefile:1008: recipe for target 'install-recursive' failed
make[1]: *** [install-recursive] Error 1
make[1]: se sale del directorio '/home/tau/Documentos/psp/pspsdk/psptoolchain/build/binutils-2.16.1/build-psp/bfd'
Makefile:2503: recipe for target 'install-bfd' failed
make: *** [install-bfd] Error 2
../scripts/001-binutils-2.16.1.sh: Failed.
ERROR: Could not run the toolchain script.

Re: Installing the PSPSDK (Linux or Windows)

Posted: Mon Aug 06, 2018 7:50 pm
by qwikrazor87
I had no luck either installing the PSP SDK after many changes were made to it. I got it to install after a while but I couldn't compile any plugins with it, only eboots.

Re: Installing the PSPSDK (Linux or Windows)

Posted: Mon Feb 18, 2019 6:04 pm
by Acid_Snake
For those (in Linux) still having trouble here's the precompiled binaries for 64-bit (only tested on Ubuntu):
https://drive.google.com/open?id=0B3hwB ... nl5NTdVUUk

Re: Installing the PSPSDK (Linux or Windows)

Posted: Fri Feb 22, 2019 12:00 am
by rsn8887
Has somebody found a working pspsdk on MacOS? I cannot seem to install it from anywhere without hundreds of bugs. All the scripts I found try to build it (building gcc etc.) instead of downloading binaries. Of course the build fails...