All topics regarding downgrading with TN Hen
#95822 by TiPi
Tue Aug 23, 2011 3:23 pm
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
UPDATE: some1 just released version 4.1. Changelog and new DL link below.
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Developer some1 just released an updated version of his downgrader. This version now supports OFW 6.60.

Changelog:
Added Support for 6.60
Fixed 6.60 problem that didn't allow to downgrade to anything greater than 6.20, thanks to Davee
Allows any updater that is greater than or equal to the factory installed OFW (Has not been fully tested, will most likely work on 500 and up)
Special Sauce added by Proxima


Full announcement by some1 on PSPslimhacks.com:



Important Note: This Kernel Exploit was NOT found by me. It was handed to me by Zecoxao, and it was handed to him by Davee.
Another Important note: You run the application at your OWN risk. I am not held accountable if you screw up your PSP.

After a long wait, here is the port of Davee's 6.35/6.31 downgrader to 6.60/6.39/6.38.

This is a very simple app, just put the desired destination OFW in PSP/GAME/UPDATE, and the app will read the factory installed OFW (aka, the OFW it came with), and allow any updater greater than or equal to this OFW. The range for this has NOT been tested, so I do not know which OFWs it is possible to downgrade to, for which model, but I've tested from 6.60 to 6.20 and 6.35, 6.39 should also work. If you use the wrong updater, the update itself will error out or go back to XMB.

[V4.0] Change Log:
Added Support for 6.60
Fixed 6.60 problem that didn't allow to downgrade to anything greater than 6.20, thanks to Davee
Allows any updater that is greater than or equal to the factory installed OFW (Has not been fully tested, will most likely work on 500 and up)
Special Sauce added by Proxima

[V4.1] Change Log:
Added Source Code
Added Safety net just in case, for some reason, your psp does not have the 0x51 key, the safety net sets minimum version to 6.35 if you were getting an error from v4.
Includes Proxima's prxencrypter with gzip support.

Thanks:
Spoiler
To Davee for making the original 6.35/6.31 downgrader, and for finding this exploit.
To ultimakillz and skyend for being my mentors when I first entered the scene.
To n00b81 for teaching me a lot of things.
To Davee, Freddy, TheLemonMan, Hellcat, and Draan for answering any question's I've had.
To TiPi and Nymphaea for allowing me to work on their VSH sploit, which gained me alot of knowledge and experience.
To Npt for hosting such an awesome competition!
To Arnold, for fixing things here and there.
To All the people who beta tested!
To TiPi for the awsome icon0.
To Zecoxao for handing me the exploit.
To Proxima for adding the special sauce!
And to many others that I'm probably forgetting.


[ [SOURCE] | [DOWNLOAD V4.0] | [DOWNLOAD V4.1] ]
Advertising
#95827 by The_Black_Panther
Tue Aug 23, 2011 3:50 pm
Oops... That was fast. Now people can freely go up to 6.60 and come back. Thanks.
Advertising
#95851 by The Z
Tue Aug 23, 2011 5:33 pm
#95872 by hrfounder
Tue Aug 23, 2011 7:02 pm
this doesn't work on my 02g


"A later version of the system software is already installed.
There is no need to update.
(CAAFFFFFCF7)"


i tried downgrading to 6.20, 6.35 and 6.39... none seem to work...
help please :(

edit: could it be that i'm trying to downgrade it with the wrong ofw? dunno what ofw came with it from the factory, but the readme said something about it... what ofw should i try?
#95879 by some1
Tue Aug 23, 2011 7:19 pm
hrfounder wrote:this doesn't work on my 02g


"A later version of the system software is already installed.
There is no need to update.
(CAAFFFFFCF7)"


i tried downgrading to 6.20, 6.35 and 6.39... none seem to work...
help please :(

edit: could it be that i'm trying to downgrade it with the wrong ofw? dunno what ofw came with it from the factory, but the readme said something about it... what ofw should i try?


weird, what's your mobo? Can you use idstorage manager to dump your keys and send me the 0x51 key?

Who is online

Users browsing this forum: No registered users and 4 guests