Advertising (This ad goes away for registered users. You can Login or Register)

PSP 2000 soft brick power on

Everything that is PSP-related but doesn't go in any other subforum
Post Reply
bitsoul91
Posts: 2
Joined: Thu Nov 10, 2016 9:15 am

PSP 2000 soft brick power on

Post by bitsoul91 » Thu Nov 10, 2016 9:29 am

Hello guys! I'm new here, I have a psp 2001 series and I installed a ME 6.60 after updating it to PRO-C. It was working well and fine but it still can't read .iso format games. When I turned it off completely it powers on but only a black screen. It doesn't power off unless I remove the battery. It still charges and powers on with a plug but still the same.

Here are the things I tried: (all of these are without memory stick)
•Holding HOME+L
•Holding HOME+SELECT+START+SQUARE+TRIANGLE and POWER ON
•Holding HOME+SELCET+START+SQUARE+TRIANGLE while charger is plugged in, turning it on and then plugging the battery
•Holding HOME+L while the charger is plugged in, turning it on and then plugging the battery
•Holding L+R and turning it on (w/ w/o memory stick)
•Holding R and turning it on (w/ w/o memory stick)
•Plugging it to the pc via USB cable doesn't work either

I didn't get any luck at all. but the thing is that the Power doesn't turn of at all and there's no sound, no boot or anything. The memory stick still works though.

Thank you!
Advertising

User avatar
fate6
Big Beholder
Posts: 7599
Joined: Fri Mar 09, 2012 1:18 am
Location: [fate6@Canterlot ~]$

Re: PSP 2000 soft brick power on

Post by fate6 » Thu Nov 10, 2016 4:55 pm

So you had ME then installed PRO? Then the system just sorta killed itself one day? oh boy.... I actually had this happen! your NAND is corrupt!....
If you have a good NAND dump from your system then restore that but if not then try pandora battery, if like in my case even that fails then the only way to use the system is with Time Machine to run the firmware from the memory card.

viewtopic.php?f=2&t=11309

Not sure what causes this and not even sure it was having both CFW but it really sucks cause it killed my first PSP :/
Advertising
Image
anon wrote:If you can't trust a 600 year old vampire in a prepubescent girl's body, who can you trust?

bitsoul91
Posts: 2
Joined: Thu Nov 10, 2016 9:15 am

Re: PSP 2000 soft brick power on

Post by bitsoul91 » Fri Nov 11, 2016 7:22 am

Thank you for the reply fate6! but I installed PRO then ME because it's what the youtube said from wololo.net as well. the only issue I've encountered was that the game can't be read (no matter what game) before I even tried going to ME. and also my friend updated it to 6.61 before he gave it to me so I had no idea what firmware it was :( thank you again I'll post the result!

User avatar
fate6
Big Beholder
Posts: 7599
Joined: Fri Mar 09, 2012 1:18 am
Location: [fate6@Canterlot ~]$

Re: PSP 2000 soft brick power on

Post by fate6 » Fri Nov 11, 2016 5:14 pm

Sounds like you might have had the wrong ISO driver? odd that both CFW couldn't run games.
In my case everything worked fine then one day while playing some Mario 64 the system locked up then never turned back on ;_;

Later found out it had a ton of bad blocks which is probably what did it in.
Image
anon wrote:If you can't trust a 600 year old vampire in a prepubescent girl's body, who can you trust?

Post Reply

Return to “General”