Advertising (This ad goes away for registered users. You can Login or Register)

[Help Request] L Trigger Stuck

Everything that is PSP-related but doesn't go in any other subforum
Post Reply
User avatar
Darth Agnon
Posts: 153
Joined: Wed May 07, 2014 2:41 pm
Location: United Kingdom
Contact:

[Help Request] L Trigger Stuck

Post by Darth Agnon » Sun Jun 12, 2016 11:25 am

Greetings, fellow citizens of Wololo.net!

Please, could anyone help me? A little while back, I replaced my little brother's busted PSP 3003 analog stick. It went well, except for....

Cause of the problem
... The L trigger. To replace the analogue, I (obviously to those who've opened their PSPs) had to remove that module that includes the Memory Stick slot and the L trigger receptor. Fool that I am, I had no spudger, so I used the next best thing to hand: small metal tweezers from a Swiss Army Knife, that also happened to be magnetised. So I put it back together.

The problem
The L trigger now registers as permanently pressed. I'm thinking it may have something to do with either:
a) magnetisation?
b) a small indentation on the base of the receptor sticker, probably resulting from forcing the tweezers under it for removal?

Help request
Does anyone know of any hardware or software solutions? e.g. would Macrofire fix it? or is there some way to fix the L trigger receptor, e.g. magnets or dissection? or is getting new parts/PSP the way to go (I'd rather avoid this if possible)?

What I've tried
I've tried rubbing a magnet over the receptor in a randomish manner, to (hopefully) demagnetise it?
I've ordered a replacement L trigger module, but when it arrived, it was a PSP 3001 module, with surprisingly more hardware differences than I'd thought there would be. If anyone has any suggestions, or knows the pinouts or how to mod a 3001 L trigger/Memory Stick module so that it'll fit into a 3003 PSP, I'm all ears :)


Any help would be appreciated!
Many thanks,

Darth Agnon
Planeswalker, Monster Hunter, Sith and Maker
Advertising
Image
Like Wagic? Check out my custom themes, etc. at viewtopic.php?f=2&t=44148
Wololo's article: http://wololo.net/2016/07/14/new-wagic- ... rth-agnon/

User avatar
Darth Agnon
Posts: 153
Joined: Wed May 07, 2014 2:41 pm
Location: United Kingdom
Contact:

Re: [Help Request] L Trigger Stuck

Post by Darth Agnon » Wed Jun 15, 2016 8:24 pm

Has anyone experienced similar problems or have any suggestions? Any help would be greatly appreciated!

Darth
Advertising
Image
Like Wagic? Check out my custom themes, etc. at viewtopic.php?f=2&t=44148
Wololo's article: http://wololo.net/2016/07/14/new-wagic- ... rth-agnon/

User avatar
HarmfulMushroom
Posts: 752
Joined: Wed Dec 25, 2013 10:02 pm

Re: [Help Request] L Trigger Stuck

Post by HarmfulMushroom » Wed Jun 15, 2016 8:47 pm

I can't say I'm very familiar with the PSP hardware but I have taken apart my Vita many times and I would think some things to be somewhat similar between the two. For the thumb stick module I'm assuming it sends its data via ribbon cable to the PSP? I'm wondering if it could possibly be an issue with this cable itself, I know those things are just ridiculously fragile and very easy to mess up (done it many times myself, hate those things). If that's what it uses that could be worth checking out, see if any of the pins are lifted/touching one another. I held off giving this suggestion earlier because I am not familiar with the hardware, but since no one else is pitching ideas could be worth a shot.

User avatar
Darth Agnon
Posts: 153
Joined: Wed May 07, 2014 2:41 pm
Location: United Kingdom
Contact:

Re: [Help Request] L Trigger Stuck

Post by Darth Agnon » Sun Jun 26, 2016 9:06 pm

Thank you very much for your suggestion, HarmfulMushroom! The stick's fine and fixed now; it, and the broken L trigger both use (separate) ribbon cables to send data to the motherboard. Do you know if magnetism can mess up ribbon cables and/or connected buttons? I'll take a look at the pins, but have a feeling it might be the pressure-sensitive button pad that's messed up.

Or has anyone ever rebuilt a PSP L trigger?

Many thanks,

Darth
Image
Like Wagic? Check out my custom themes, etc. at viewtopic.php?f=2&t=44148
Wololo's article: http://wololo.net/2016/07/14/new-wagic- ... rth-agnon/

lusid
Posts: 10
Joined: Tue Feb 08, 2011 6:15 am

Re: [Help Request] L Trigger Stuck

Post by lusid » Tue Jun 28, 2016 5:54 am

Magnetism is not a likely cause.

Remove the L trigger and see if the button underneath actuates with the trigger removed. Make sure it is still correctly aligned below the round depression on the underside of the trigger, and that the adhesive is still holding it in place.

Also disconnect the ribbon cable and inspect the motherboard connector under a magnifying glass for debris or damage. Check the ribbon cable as well. But a damaged cable is more likely to cause "L-trigger doesn't work" than "L-trigger is stuck". When you reconnect it, make sure the cable is fully inserted and properly aligned before flipping down the retaining tab. Misalignment or failure of the button or an improperly seated ribbon cable are both likely causes.

Post Reply

Return to “General”