Unleash the full power of your PSP with a Custom Firmware.
Download and installation tutorial at http://wololo.net/wagic/cfw4dummies
#96446 by Augusta
Fri Aug 26, 2011 2:07 pm
Just want to clarify

Is there a difference between the official v3 on pops google page and pops' vd unofficial?
Great work btw pops :]
Advertising
#96468 by jvhellraiser
Fri Aug 26, 2011 3:24 pm
I download every OFW need it to build popsloader V3
add them to ms0:/ and use popsdeco to build it
popsloader V3 Official,with Psp 1001 01g i had Problems
with pops 302,303,310 all others work great.

-------------------------------------------------------------

as i was confuse i downloaded popsloader V4D
and did the same to build it OFW to ms0:/
and use popsdeco to build it as for my surprise
popslaoder V3D was build with all pops working
on Psp 1001 01g.

As i had problems before,i check every single file
MD5 sum and they are the same files
from V4D and V3 the all have same checksum but
deference is V3 wont boot some 310 under pops
and V4D boots every single one. guess i will stay
with my trusty popsdeco V4D. and i did not miss
checking popcorn.prx this time!!!
Advertising
#96807 by Kazuhira7
Sun Aug 28, 2011 1:55 am
Thanks popsdeco.

Someone correct me if I'm wrong:

Popsdeco's v4d and is exclusively for 6.39 PRO/ME and fixes the 3.72 issue. The official v3 release by VF uses popsdeco's fix and works with 6.39 and 6.60 firmwares? Also is the new v4e compatible with both 6.39 and 6.60 cfws?
#96836 by Kazuhira7
Sun Aug 28, 2011 4:11 am
popsdeco wrote:
Kazuhira7 wrote:Popsdeco's v4d and is exclusively for 6.39 PRO/ME and fixes the 3.72 issue.

Really? then v4e is useless thing bah...

anyway Popsloader PRO/ME mod v4d+ support 6.60 fully.


no idk, sorry.. should have added a question mark after that. I've read through the last pages of this thread, but I still need someone to briefly explain to me what major fix/change was made from v3c to 4d, that's all.

also, is Neur0n's popsbridge v3 integrated to 4d and 4e?
#96843 by popsdeco
Sun Aug 28, 2011 5:48 am
history.txt
Spoiler
Popsloader PRO/ME mod.

v3 (110721)
Derived from official v2.
Workaround for neur0n's sceKernelGetGameInfo()+0x44.
Using open(sceKernelGetGameInfo()+0x74,O_RDONLY,0777);

v3a (110721)
Fixed save_config().

v3b (110722)
Fixed "Original from flash" feature.

v3c (110722)
Fixed a bug in popsloader_patch_chain().
Removed debug line.

v4 (110723)
Integrated pops_bridge into popsloader.prx.
6.x pops are supported on ME.

v4a beta (110724)
All pops are supported on ME.
Instead, popcorn.prx now works in release/debug hybrid mode.

v4b alpha1 (110808)
1. Removed sceLoaderCore patch.
2. Changed remove timing of ms0:/__popcorn.txt. Now you should be able to see it.
(You need to paste it if you want to report bugs)
3. sctrlSetStartModuleExtra() (ME's original function) is now resolved via sctrlHENFindFunction(), rather than systemctrl.S.

v4b alpha2 (110817)
Integrated http://code.google.com/p/popsloader/source 2d9f6175ddde to support 6.60 pops.

v4b alpha2+1 (110817)
1. 5.00+ pops are working on 6.60ME. Unfortunately impose.prx (used in 4.01- pops) patch is incomplete.
2. Now that popscore.prx is compiled using DEBUG=1, you need to paste ms0:/core.txt to report bugs.

v4b alpha2+2 (110817)
1. Changed debug text name to ms0:/__popscore.txt. Also it is removed in every launching.
2. Fixed sceKernelGetModel NID for 6.60.
3. Fixed fatal bug that PSP-3000+ on 6.20PRO couldn't use 4.01- pops at all.

v4b alpha2+3 (110818)
Added impose.prx patch. Still 3 NIDs are missing though.
Anyway 4.01 pops seems to be working fully.

v4b alpha3 (110819)
Now that impose.prx patch is complete, popsloader supports all pops fully on 6.60ME.

v4b alpha4 (110821)
PSPgo will use pops_04g.prx on 6.00 (I don't know if this is correct)
Integrated http://code.google.com/p/procfw/source df2af4ebe25c. Popsloader should support 6.60PRO PSP-E1000 (when released).

v4c (110822)
Attached popsloader.md5sum (and popsloader_updater.md5sum).
Make sure your pops md5 is correct before reporting bugs.
Now popscore.prx / popcorn.prx is compiled in release mode (no longer emits debug log)
*** I don't know why this time popcorn.prx is working in release mode. Tested only on 6.60ME. Be careful. ***

v4d (110824)
Forgot to close EBOOT file handle when get_disc_id() failed.
Integrated http://code.google.com/p/popsloader/source 54abc82880ed. Now more stable.
(Actually some of NID wasn't resolved for 6.60.)

v4e (110827)
Recompiled all modules using -O2.
Suspend recover bug fixed for 3.7x if you use PRO (?)
94235f09107f wasn't merged because:
1. official v3 cannot get DISC ID yet, at least on PSP-2000[C].
2. changing load_config() timing will crash ME mode.
#96852 by jvhellraiser
Sun Aug 28, 2011 9:16 am
thanks!! popsdeco popsloader_v4e fix cracking sound
on mortal kombat triology in 3.71 pops awesome.
Usually i play it 3.71 but since V4D i was playing it on
pops 3.72 cause of the cracking sound,nice work!
#96968 by Lyan53
Sun Aug 28, 2011 9:26 pm
Hello all,

I would have 2 questions you:


1- In the earlier DarkAlex's popsloader (or HellDashX too), there was an automatic function which consisted to downgrade PS1 savegame when we went of 3.40 pops or more, towards 3.30 pops or less

This function (for upgrade save) is included in pops since the version 3.40, because the savegame format changed
Image
Convert savegame 3.30 or - >> 3.40 or +

Image
savegame 3.30 or -

Image
savegame 3.40 or +

The official pops upgrade savegame format and the earlier popsloader was made savegame downgarde ;)

Would it be possible to find this function in a future update?

---------------------------------------------------------------------------------

2- In the Read-Me, for 6.20 pops, the modules necessary to install in the popsloader are:

¦   +-- 620
¦   ¦   +-- common_util.prx
¦   ¦   +-- libpspvmc.prx
¦   ¦   +-- pafmini.prx
¦   ¦   +-- popcorn.prx
¦   ¦   +-- pops_01g.prx
¦   ¦   +-- pops_02g.prx
¦   ¦   +-- pops_03g.prx
¦   ¦   +-- pops_04g.prx
¦   ¦   +-- pops_05g.prx
¦   ¦   +-- pops_07g.prx
¦   ¦   +-- pops_09g.prx
¦   ¦   +-- popsman.prx
¦   ¦   +-- pops.prx

I did not manage to obtain modules in red in spite of the use from different psardumper (or other software based on psardumper) oO

Can you indicate me a software to extract these files, or explain me how to obtain them?
#96970 by jvhellraiser
Sun Aug 28, 2011 10:04 pm
2- In the Read-Me, for 6.20 pops, the modules necessary to install in the popsloader are:

¦ +-- 620
¦ ¦ +-- common_util.prx
¦ ¦ +-- libpspvmc.prx
¦ ¦ +-- pafmini.prx
¦ ¦ +-- popcorn.prx
¦ ¦ +-- pops_01g.prx
¦ ¦ +-- pops_02g.prx
¦ ¦ +-- pops_03g.prx
¦ ¦ +-- pops_04g.prx
¦ ¦ +-- pops_05g.prx
¦ ¦ +-- pops_07g.prx
¦ ¦ +-- pops_09g.prx
¦ ¦ +-- popsman.prx
¦ ¦ +-- pops.prx

I did not manage to obtain modules in red in spite of the use from different psardumper (or other software based on psardumper) oO

Can you indicate me a software to extract these files, or explain me how to obtain them?
Sorry for my bad english :/
Image

User avatar
Lyan53

Posts: 1
Joined: Sun Aug 28, 2011 5:59 pm
Location: France



Ok 0X.g.prx are found in 6.35 OFW,6.39 OFW,6.60 OFW
Is simple use popdeco V2 to dump the files,

step 1:
add OFW to ms0:/ rename OFW eboot.PBP to Example =635.PBP

step 2:
launch popsdeco V2 and dump the files from 635.PBP directly into 635 pops folder

Ps, popsloader folder must be in seplugins and the module should be where it supose too.
cause popsdeco V2 will look for ms0:/seplugins/popsloader/module/folder 635.

once you download:
635
639
660

you will see the files you need for in 620
inside those other folders.make sure you have
620-GO
635-GO
660-GO
OFW's too.

Who is online

Users browsing this forum: No registered users and 8 guests