Advertising (This ad goes away for registered users. You can Login or Register)

[GBA, SNES EMULATION] Question

Discuss emulation on HBL. No discussion about how to download illegal content is allowed!
wachu
Posts: 47
Joined: Sat Dec 18, 2010 4:30 pm

[GBA, SNES EMULATION] Question

Post by wachu » Sat Dec 18, 2010 4:42 pm

First of all - Hi every1! I visited wololo.net many times, but without account. Just wanted to say that You guys are doing great things, keep it up.
Secondly - Sorry for my bad english, im from Poland (Europe).

So, the thing I wanted to ask is about emulation on psp 3004 6.20 by using HalfByteLoader-loaded homebrew emulators

First problem is that when Im using homebrew emulator called "Gpsp Kai" (downloaded from Your's site links) I have some problems with FPS in some games, like Golden Sun and Golden Sun: Lost Age - mainly when Im roaming the world map I have like ~10FPS, which obviously is crappy.

Second problem is that when Im using homebrew emulator called "Snes9xTYL" (downloaded from Your's site links) I have some problems with FPS in some games, like Chrono Trigger - when im on map i have ~55fps, when I fight ~40 FPS and in the invectory ~20FPS (FPS rate is shown by emulator). When I'm changing PSP clock frequency on 333mhz the problem is still there.

So, if somebody can help me I will be more than happy ;)

Cheers,
wachu
Advertising

HomebrewEnabler
Banned
Posts: 658
Joined: Thu Sep 30, 2010 12:45 pm

Re: [GBA, SNES EMULATION] Question

Post by HomebrewEnabler » Sat Dec 18, 2010 4:54 pm

this isnt the right topic to post questions and issues for hbl compatibility
Advertising

wachu
Posts: 47
Joined: Sat Dec 18, 2010 4:30 pm

Re: [GBA, SNES EMULATION] Question

Post by wachu » Sat Dec 18, 2010 4:58 pm

HomebrewEnabler wrote:this isnt the right topic to post questions and issues for hbl compatibility
Really? The topic name is: "[GBA, SNES EMULATION] Question" so why cant I post Q's ? :D
Well, if it is wrong FORUM, please move it to correct one, sorry (its sooo important, isnt it? :) )

TiPi
Retired Mod
Posts: 740
Joined: Tue Sep 28, 2010 5:32 am
Contact:

Re: [GBA, SNES EMULATION] Question

Post by TiPi » Sat Dec 18, 2010 5:09 pm

--> Moved to Half Byte Loader --> Emulation

I'm afraid I can't help you. :(
I've never had problems with those homebrew before. The only thing I can guess is that it's because of the fact that 6.20 HBL on a PSP 3000 doesn't have a full syscall estimation, but I'm not too sure about that either.
Problems or questions? Feel free to contact me.
-My Blog-

Nitori
Posts: 28
Joined: Tue Dec 14, 2010 3:18 am

Re: [GBA, SNES EMULATION] Question

Post by Nitori » Sun Dec 19, 2010 2:10 am

It's mostly just because those two systems are very hard to emulate at 100% speed.

For SNES, you can try disabling transparencies and using frameskips, but that's about as far as you'll get. HBL does play a very small part in slowing it down, but not by too much nowadays.

AssasinRam
Posts: 284
Joined: Thu Sep 30, 2010 9:45 am
Location: HFIL

Re: [GBA, SNES EMULATION] Question

Post by AssasinRam » Sun Dec 19, 2010 4:30 am

It's either a problem with hbl or the emulators or it's the config(try messing with it)
I have a -
PSP 3000

And I love-
HBL!
Why are you reading my signature? =)
Blog- http://ultimate-psp-hacks.blogspot.com/

wachu
Posts: 47
Joined: Sat Dec 18, 2010 4:30 pm

Re: [GBA, SNES EMULATION] Question

Post by wachu » Sun Dec 19, 2010 9:07 am

Nitori wrote:For SNES, you can try disabling transparencies and using frameskips, but that's about as far as you'll get. HBL does play a very small part in slowing it down, but not by too much nowadays.
Thanks ! Setting frameskip to AUTO and framelimit to 40 (it was 2fast) did the trick. Great !

JAKE320
Posts: 14
Joined: Tue Jan 25, 2011 2:35 pm

Re: [GBA, SNES EMULATION] Question

Post by JAKE320 » Wed Jan 26, 2011 12:42 pm

Ummm.... do you have gpSP-kai signed?
PSP 3000 6.37
~JAKE320

Aconcit
Posts: 43
Joined: Sun Nov 14, 2010 8:29 pm

Re: [GBA, SNES EMULATION] Question

Post by Aconcit » Wed Jan 26, 2011 1:28 pm

This post is over a month old..

JJS
Big Beholder
Posts: 1416
Joined: Mon Sep 27, 2010 2:18 pm
Contact:

Re: [GBA, SNES EMULATION] Question

Post by JJS » Wed Jan 26, 2011 1:37 pm

JAKE320 wrote:Ummm.... do you have gpSP-kai signed?
Do not post the same thing in multiple threads. Also that question is offtopic in the HBL forum.

Post Reply

Return to “Emulation”