HENkaku is a native Homebrew Enabler for the PS Vita and PS TV. It lets you run homebrews on the PS Vita
#417830 by Joel16
Sat Apr 15, 2017 6:16 pm
robin5968 wrote:
sauske_firekid wrote:Wait does this work on other homebrews though? Have you tried it on Vitashell?
Cause then I think this seems to only be affecting ePSP stuff.


I could say "Yes", but may just work with all games and some of homebrews.
As PoliteTimesplitter and Yugi say in wololo post.
Just change the *RAND0666 line to *ALL
Then the plugin can be use with all other apps or homebrews, though some will unable to run like ARK and Adrenaline.

But note that when using the VITABattery button set to display info,
some homebrew (like VitaShell) and games will temporary cause lots of button unable to use,
except touch screen, power button, PS button and both analog,
until you use the VITABattery button set to close or push PS button.

Another thing, would any chance it could work in LiveArea? XD


Yeah I know of the *ALL method, I only decided to use RAND0666 as an example since *ALL may crash some homebrews (EPSP stuff). About the live area, it's definitely something I want to do, but haven't had the time to look into it as yet.

igito wrote:don't work in adrenaline...
i delete this plugin because that..
can you repair that?


Yeah, this and a few other plugins are facing the same problem. We'll consider looking into it.
Advertising
#418048 by Rinnegatamante
Thu Apr 27, 2017 9:14 am
sauske_firekid wrote:
XandridFire wrote:When I put this in my "Tai" folder, when ever I try to play a game or anything, it just freezes. Is it because I have Freescreenshot and Framecounter too?


I don't think it's Freescreenshot, but it's Framecounter for sure. I was trying out Framecounter earlier, but sadly it freezes if I have both Framecounter and VITABattery enabled.
I'll try looking into this in the weekend. I think I have a good idea what the problem is. It's most likely because it's using 'libk' for blitting text onto the screen, whereas VITABattery is using Sceclib functions.

EDIT: Nah, nvm I don't think that's it.


That's cause you use sceLibC to get access to POSIX stdio/string/stdlib etc.
Replace sceLibC with libk.

That's also a possible motivation why VITAbattery is not compatible with Adrenaline at all.
#418053 by Joel16
Thu Apr 27, 2017 4:21 pm
Rinnegatamante wrote:
sauske_firekid wrote:
XandridFire wrote:When I put this in my "Tai" folder, when ever I try to play a game or anything, it just freezes. Is it because I have Freescreenshot and Framecounter too?


I don't think it's Freescreenshot, but it's Framecounter for sure. I was trying out Framecounter earlier, but sadly it freezes if I have both Framecounter and VITABattery enabled.
I'll try looking into this in the weekend. I think I have a good idea what the problem is. It's most likely because it's using 'libk' for blitting text onto the screen, whereas VITABattery is using Sceclib functions.

EDIT: Nah, nvm I don't think that's it.


That's cause you use sceLibC to get access to POSIX stdio/string/stdlib etc.
Replace sceLibC with libk.

That's also a possible motivation why VITAbattery is not compatible with Adrenaline at all.


Haha believe it or not I tried using libk once, but for some reason it wouldn't work with oclockvita if I had both VITAbattery + oclockvita enabled, so I decided against using it. Now that you told me it fixes Adrenaline, I decided to give it another shot and it actually fixed Adrenaline and still works with oclockvita. Thanks for the tip rin!

Anyways release time!

VITABattery v1.3


Change-log:

- Fixed compatibility issues with Adrenaline.


Download:

https://github.com/joel16/VITABattery/releases
#418107 by Chris_Highwind
Mon May 01, 2017 3:50 pm
Hopefully this will tell me how much battery I actually have left, as this morning, my Vita kept claiming the battery was low, but as soon as I exited Borderlands, the battery level jumped back up to almost full.
#418112 by robin5968
Mon May 01, 2017 6:23 pm
Another thing found.
When full charge of 100%, the percent symbol "%" will display at top left corner,
separate from "100" at top right corner.
As the picture shown below.
It does not need to be fixed immediately beause it's just a little bug XD
Image
#418118 by Joel16
Mon May 01, 2017 11:40 pm
robin5968 wrote:Another thing found.
When full charge of 100%, the percent symbol "%" will display at top left corner,
separate from "100" at top right corner.
As the picture shown below.
It does not need to be fixed immediately beause it's just a little bug XD
Image


Thanks for reporting, I'll fix it in the next release.
#418274 by Joel16
Thu May 11, 2017 5:14 am
Sorry I took a while to clear up some rather simple issues.

Anyways release 1.4 is up. https://github.com/joel16/VITABattery/releases

    - Fixed misalignment issues when percentage is a 3 digit number (100%).
    - Fixed button conflicts with other plugins (oclockvita for example).
    - Added battery temperature in degrees C. (Degrees F kept showing up in weird units, sorry)

Due to a few users reporting on button conflicts with other plugins, I've made the following changes:

The new button configurations are as follows:

Code: Select allStart + Up -> Current battery percentage.
Star +  Left -> Current battery temperature in degrees C.
Start + Right -> Battery life time.

Start + Down -> Close each of the above.
#418400 by Joel16
Mon May 22, 2017 3:21 am
given001 wrote:Hi ,I followed your instruction but when i press the button it show nothing :(, please help. My vita's fw is 3.60 hacked with taiHen .


What exactly do you have in your config? I hope you're not using RAND666, because that was an example.

You can just use

Code: Select all# titleid for your application
*ALL
ux0:tai/batteryPercent.suprx


Then use either of the following combinations:
Code: Select allStart + Up -> Current battery percentage.
Star +  Left -> Current battery temperature in degrees C.
Start + Right -> Battery life time.

Start + Down -> Close each of the above.

Who is online

Users browsing this forum: No registered users and 3 guests