Carriage returns not present in later _cards.dat files

Do not post feature requests here, please.
Before posting bugs report check the Image Bug reporting help & guidelines
Forum rules
Do not post Features/Improvments request here (i.e : AI being stupid is not a bug, not being able to do a mulligan is not a bug, etc..etc..)
Before posting, please read the Bugs reporting guideline
Post Reply
GPBurdell
Posts: 8
Joined: Sat Aug 06, 2016 11:14 am

Carriage returns not present in later _cards.dat files

Post by GPBurdell » Sat Aug 13, 2016 12:14 pm

I'm running 0.20.1 right now. It seems like the _cards.dat for the latest-to-be-added sets do not have carriage returns in them. This causes Wagic to crash whenever you add a card from these sets (like Bloodbraid Elf or JTMS from the EMA set) to a deck and attempt to play the deck, or when you add the card from collection view, then switch to deck view.

The easy but tedious fix is to add carriage returns by hand. I think I have confirmed this because I added proper carriage returns with Bloodbraid Elf, added it to a deck, and played a match with that deck (casting BBE once). Everything worked.

kevlahnota
Posts: 618
Joined: Tue Feb 08, 2011 3:00 pm
Location: Philippines
Contact:

Re: Carriage returns not present in later _cards.dat files

Post by kevlahnota » Sat Aug 13, 2016 2:54 pm

GPBurdell wrote:I'm running 0.20.1 right now. It seems like the _cards.dat for the latest-to-be-added sets do not have carriage returns in them. This causes Wagic to crash whenever you add a card from these sets (like Bloodbraid Elf or JTMS from the EMA set) to a deck and attempt to play the deck, or when you add the card from collection view, then switch to deck view.

The easy but tedious fix is to add carriage returns by hand. I think I have confirmed this because I added proper carriage returns with Bloodbraid Elf, added it to a deck, and played a match with that deck (casting BBE once). Everything worked.
Which sets? I can do it programmatically. Just give me the set names :)

GPBurdell
Posts: 8
Joined: Sat Aug 06, 2016 11:14 am

Re: Carriage returns not present in later _cards.dat files

Post by GPBurdell » Sat Aug 13, 2016 7:05 pm

It looks like every set that was added to Wagic starting from Theros onward. The .dat for Dragon's Maze is fine, and then Theros begins the lack of carriage returns.

kevlahnota
Posts: 618
Joined: Tue Feb 08, 2011 3:00 pm
Location: Philippines
Contact:

Re: Carriage returns not present in later _cards.dat files

Post by kevlahnota » Sat Aug 13, 2016 11:39 pm

GPBurdell wrote:It looks like every set that was added to Wagic starting from Theros onward. The .dat for Dragon's Maze is fine, and then Theros begins the lack of carriage returns.
Thanks, I just recheck them and it turns out that BFZ, OGW & SOI needs carriage returns. It's fixed on latest-git.
Theros set is fine:
Image

GPBurdell
Posts: 8
Joined: Sat Aug 06, 2016 11:14 am

Re: Carriage returns not present in later _cards.dat files

Post by GPBurdell » Sun Aug 14, 2016 12:45 am

I must be getting the files from the wrong place on git-hub. I go to git, then I click on Code, then Releases. Is that the wrong path to take? When I download from the "latest-master", none of the latest sets have carriage returns. Can you link the latest? (Sorry, I have no idea how git-hub releases work)


kevlahnota
Posts: 618
Joined: Tue Feb 08, 2011 3:00 pm
Location: Philippines
Contact:

Re: Carriage returns not present in later _cards.dat files

Post by kevlahnota » Sun Aug 14, 2016 1:06 am

GPBurdell wrote:I must be getting the files from the wrong place on git-hub. I go to git, then I click on Code, then Releases. Is that the wrong path to take? When I download from the "latest-master", none of the latest sets have carriage returns. Can you link the latest? (Sorry, I have no idea how git-hub releases work)
you're correct, the changes I made is not considered by github. i'll delete the files and upload the correct .dat

Post Reply