Bugs SVN

Do not post feature requests here, please.
Before posting bugs report check the Image Bug reporting help & guidelines
Forum rules
Do not post Features/Improvments request here (i.e : AI being stupid is not a bug, not being able to do a mulligan is not a bug, etc..etc..)
Before posting, please read the Bugs reporting guideline
goojamin
Posts: 115
Joined: Wed Jul 28, 2010 2:54 pm

Re: Bugs SVN

Post by goojamin » Wed Oct 05, 2011 11:11 pm

r3998 - psp compilation issue

Code: Select all

./JGE/src/zipFS -I../../JGE/include/psp -I../../JGE/include/psp/freetype2 -I../.
./JGE/src -I../../projects/mtg/include -I../../Boost -I. -IC:/pspsdk/psp/sdk/inc
lude -Wall -W -Werror -Wno-unused -O2 -G0 -DPSPFW3XX -DDEVHOOK -DUSE_PRECOMPILED
_HEADERS=1 -DPSP -D_PSP_FW_VERSION=371 src/GuiPhaseBar.cpp -o objs/GuiPhaseBar.o

cc1plus.exe: warnings being treated as errors
src/GuiPhaseBar.cpp: In constructor 'GuiPhaseBar::GuiPhaseBar(GameObserver*)':
src/GuiPhaseBar.cpp:46: error: base 'PlayGuiObject' will be initialized after
src/GuiPhaseBar.cpp:46: error:   base 'GuiLayer'
src/GuiPhaseBar.cpp:44: error:   when initialized here
make: *** [objs/GuiPhaseBar.o] Error 1

C:\wagthesource\projects\mtg>

goojamin
Posts: 115
Joined: Wed Jul 28, 2010 2:54 pm

Re: Bugs SVN

Post by goojamin » Sat Oct 08, 2011 2:20 pm

Psp1000 svn r4000

I was using the blue/red ISD starter deck KF1 posted. I played a curse of the bloody tome and targeted my opponent. The aura cast and worked as expected but the card disappeared from the battlefield and could not be seen anywhere? I played another card from my hand and then it reappeared directly above the second card from the top in my hand and I could no longer select that card to play (I could only play card 1 or 3). This happened with the hand set to always display.

sandman423
Posts: 739
Joined: Thu Sep 10, 2009 8:59 pm

Re: Bugs SVN

Post by sandman423 » Sat Oct 08, 2011 6:04 pm

PSP 3000

Similar problem happened to me...I play Curse of the Bloody Tome and when I try and select my GY it just jumps to the battlefield to select Curse of the Bloody Tome...The card is Placed off to the FAR Right..It prevents me from selecting my GY...

Please fix this.

User avatar
ph34rbot
Posts: 259
Joined: Thu Jan 07, 2010 6:33 am

Re: Bugs SVN

Post by ph34rbot » Sat Nov 26, 2011 5:40 pm

Doesn't anyone buy boosters anymore?

I'm having some trouble trying to purchase boosters from the store, it happens in the last revision (4075), in happens in psp 1000 and in windows 7 professional 64 bits, after clicking a booster the game just crashes, can't tell if this bug is being for a while but it seems so...

Also the compilation in psp is wrong, the reference to te test suite it's not correct, check GameObserver.cpp line 437 the error it's that testSuiteAI it's not declared in this scope or something like that.

KF1
Posts: 1952
Joined: Tue Apr 06, 2010 7:04 pm

Re: Bugs SVN

Post by KF1 » Sat Nov 26, 2011 6:35 pm

ph34rbot wrote: Also the compilation in psp is wrong, the reference to te test suite it's not correct, check GameObserver.cpp line 437 the error it's that testSuiteAI it's not declared in this scope or something like that.
I reported this in the compilation section yesterday with the Error message here: viewtopic.php?f=16&p=24581#p24581

I'm hoping that the compiler gurus can look at it and tell us what needs to be done to fix it.

wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

Re: Bugs SVN

Post by wololo » Sun Nov 27, 2011 8:07 am

I fixed the compilation issue, I'll have a look at the boosters issue sometime this week

goojamin
Posts: 115
Joined: Wed Jul 28, 2010 2:54 pm

Re: Bugs SVN

Post by goojamin » Wed Feb 01, 2012 2:01 am

psp - r4243 - compilation error

Code: Select all

psp-g++ -c -I../../JGE/include -I../../JGE/src/zipFS -I../../JGE/include/psp -I.
./../JGE/include/psp/freetype2 -I../../JGE/src -I../../projects/mtg/include -I..
/../Boost -I. -IC:/pspsdk/psp/sdk/include -Wall -W -Werror -Wno-unused -O2 -G0 -
DPSPFW3XX -DDEVHOOK -DUSE_PRECOMPILED_HEADERS=1 -DPSP -I../../JGE/include -I../.
./JGE/src/zipFS -I../../JGE/include/psp -I../../JGE/include/psp/freetype2 -I../.
./JGE/src -I../../projects/mtg/include -I../../Boost -I. -IC:/pspsdk/psp/sdk/inc
lude -Wall -W -Werror -Wno-unused -O2 -G0 -DPSPFW3XX -DDEVHOOK -DUSE_PRECOMPILED
_HEADERS=1 -DPSP -D_PSP_FW_VERSION=371 src/AIHints.cpp -o objs/AIHints.o
In file included from ../../projects/mtg/include/AIHints.h:9,
                 from src/AIHints.cpp:3:
../../projects/mtg/include/AIPlayerBaka.h:84: error: expected ',' or '...' befor
e '>' token
../../projects/mtg/include/AIPlayerBaka.h:84: error: wrong number of template ar
guments (1, should be 4)
c:/pspsdk/lib/gcc/../../psp/include/c++/4.3.5/bits/stl_map.h:91: error: provided
 for 'template<class _Key, class _Tp, class _Compare, class _Alloc> class std::m
ap'
../../projects/mtg/include/AIPlayerBaka.h:84: error: default argument missing fo
r parameter 4 of 'virtual std::vector<MTGAbility*, std::allocator<MTGAbility*> >
 AIPlayerBaka::canPayMana(MTGCardInstance*, ManaCost*, std::map<MTGCardInstance*
, bool, std::less<MTGCardInstance*>, std::allocator<std::pair<MTGCardInstance* c
onst, bool> > >, bool)'
make: *** [objs/AIHints.o] Error 1

C:\wagthesource\projects\mtg>

mnguyen
Posts: 229
Joined: Thu Apr 29, 2010 4:13 pm

Re: Bugs SVN

Post by mnguyen » Wed Feb 01, 2012 2:17 am

This will be fixed. I believe it has to do with the map being passed around with the invalid initializer.
goojamin wrote:psp - r4243 - compilation error

Code: Select all

psp-g++ -c -I../../JGE/include -I../../JGE/src/zipFS -I../../JGE/include/psp -I.
./../JGE/include/psp/freetype2 -I../../JGE/src -I../../projects/mtg/include -I..
/../Boost -I. -IC:/pspsdk/psp/sdk/include -Wall -W -Werror -Wno-unused -O2 -G0 -
DPSPFW3XX -DDEVHOOK -DUSE_PRECOMPILED_HEADERS=1 -DPSP -I../../JGE/include -I../.
./JGE/src/zipFS -I../../JGE/include/psp -I../../JGE/include/psp/freetype2 -I../.
./JGE/src -I../../projects/mtg/include -I../../Boost -I. -IC:/pspsdk/psp/sdk/inc
lude -Wall -W -Werror -Wno-unused -O2 -G0 -DPSPFW3XX -DDEVHOOK -DUSE_PRECOMPILED
_HEADERS=1 -DPSP -D_PSP_FW_VERSION=371 src/AIHints.cpp -o objs/AIHints.o
In file included from ../../projects/mtg/include/AIHints.h:9,
                 from src/AIHints.cpp:3:
../../projects/mtg/include/AIPlayerBaka.h:84: error: expected ',' or '...' befor
e '>' token
../../projects/mtg/include/AIPlayerBaka.h:84: error: wrong number of template ar
guments (1, should be 4)
c:/pspsdk/lib/gcc/../../psp/include/c++/4.3.5/bits/stl_map.h:91: error: provided
 for 'template<class _Key, class _Tp, class _Compare, class _Alloc> class std::m
ap'
../../projects/mtg/include/AIPlayerBaka.h:84: error: default argument missing fo
r parameter 4 of 'virtual std::vector<MTGAbility*, std::allocator<MTGAbility*> >
 AIPlayerBaka::canPayMana(MTGCardInstance*, ManaCost*, std::map<MTGCardInstance*
, bool, std::less<MTGCardInstance*>, std::allocator<std::pair<MTGCardInstance* c
onst, bool> > >, bool)'
make: *** [objs/AIHints.o] Error 1

C:\wagthesource\projects\mtg>

KF1
Posts: 1952
Joined: Tue Apr 06, 2010 7:04 pm

Re: Bugs SVN

Post by KF1 » Wed Feb 01, 2012 12:06 pm

PSP r4245 still getting a compilation error.

Foreroes
Posts: 85
Joined: Sun Jul 25, 2010 7:40 am

Re: Bugs SVN

Post by Foreroes » Fri Feb 03, 2012 1:32 pm

Wagic rev 4253 on windows xp

I'm getting some ramdom crashes when playing Classic mode.
It happens after having selected my deck, just when the match starts. Sometimes I only can see the back of cards (I can see also P/T if it's a creature) and if I try to go to main menu screen it just gets black (although music keeps playing) and I have to quit wagic using ctrl + alt + supr.
In other cases it simply crashes (I get a black screen and I keep listening to music). The problem is that when I have a crash all decks are labelled as new again so I can't unblock new decks. However, it seems to be ramdom since other times the game works perfectly, so any clue about what's happening? I didn't touch anything in res folder since I'm using my user folder and in this folder is my profile, my card pictures and some themes.
It seems to be an important bug isn't it?

Post Reply