Bugs SVN

Do not post feature requests here, please.
Before posting bugs report check the Image Bug reporting help & guidelines
Forum rules
Do not post Features/Improvments request here (i.e : AI being stupid is not a bug, not being able to do a mulligan is not a bug, etc..etc..)
Before posting, please read the Bugs reporting guideline
pake1
Posts: 129
Joined: Tue Mar 30, 2010 12:47 am

Re: Bugs SVN

Post by pake1 » Sun Jun 06, 2010 7:32 am

Foxfire does not work

Image

Code: Select all

[card]
name=Foxfire
target=creature[attacking]
auto=untap
auto=preventAllCombatDamage to(mytgt) ueot
auto=preventAllCombatDamage from(mytgt) ueot
auto=@next upkeep:draw:1 controller
text=Untap target attacking creature. Prevent all combat damage that would be dealt to and dealt by that creature this turn. -- Draw a card at the beginning of the next turn's upkeep.
mana={2}{G}
type=Instant
[/card]
So a creature attacks me, I use this instant, it untaps the card but i still get damaged from the creature.

tactonrae
Posts: 18
Joined: Sat Jun 20, 2009 3:14 am

R2079 - Rules are broken (Closed)

Post by tactonrae » Tue Jun 08, 2010 3:24 am

So I compiled Wagic for the first time today. It was very easy, but as I tr to play what i compiled I see odd things. Not sure if this is the right board.

1. we can put in play as many lands as we wish. I discovered it when the opponent put in play 5 lands then psychic drained me with them i was like Holy crepes.
2. instants and sorceries are put on the battlefield
3. Although I can put 4 lands in 1st turn I can only cast 1 spell. I didn't try future turns.
4. creatures are not put in play... I am not sure where they went. I cast a wall of wood on turn one and a raging goblin turn 2 and neither went in to play. this was before i found out about 1.

[EDIT ABRA - edited the title added the Revision number and slightly summarized the issue + this should be reported in the bug SVN thread]

wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

Re: oddities in the latsest SVN

Post by wololo » Tue Jun 08, 2010 8:18 am

I'm going to assume you did something wrong, but I don't have access to my machine so I can't test before sunday.
If possible, try an earlier revision of the SVN (in tortoise, there's an item in the menu called "upgrade to revision" or something similar).

baldersmashed
Posts: 156
Joined: Sat Apr 25, 2009 12:00 am

Re: oddities in the latsest SVN

Post by baldersmashed » Tue Jun 08, 2010 9:09 am

I can confirm this on pc with build 2079. Tried to play an green creature first turn and it disappeared. Did not appear in any zone that can be accessed ingame.
Dr.Solomat wrote:"Vegeta! What does the scouter say about Wagics power level?"

"It's over ten thooooouuuuuusaaaaaaaaand!"

"What 10.000? There's no way that can be right!"

kucing
Posts: 17
Joined: Thu Jun 03, 2010 1:13 am

Re: oddities in the latsest SVN

Post by kucing » Tue Jun 08, 2010 10:34 am

I can confirm that this problem exists in PSP version of revision 2079. Both the AI and I can put as many lands as we want. The creatures that we cast went to nowhere (not displayed on the board).

Another problem is when I selected the story mode, it crashed. I guess this is probably known because the story mode is not implemented yet.


Edit: I reverted back to revision 2078 by hand (there's only one line change) and it works again. So the revision 2079 change broke it.

kucing
Posts: 17
Joined: Thu Jun 03, 2010 1:13 am

Re: Bugs SVN

Post by kucing » Tue Jun 08, 2010 1:53 pm

Revision 2078

When AI has 1 Deathbringer Liege in play and then cast another Deathbringer Liege, the game will freeze. The screen when it froze showed a menu with options "Tap", "Tap" and "Cancel".

This has happened twice.

abrasax
Posts: 976
Joined: Wed Oct 15, 2008 7:46 am
Location: Switzerland

Re: R2079 - Rules are broken.

Post by abrasax » Tue Jun 08, 2010 4:55 pm

Hi,

Jean is gonna correct this one, in the meantime just revert to R2078.
Another problem is when I selected the story mode, it crashed. I guess this is probably known because the story mode is not implemented yet.
Well it's not supposed to crash... in the last daily built (and since then there was no need to recompile since the code didn't changed) this function is working fine.

Grü

L.
We need your Help !!!
New to wagic ? Be sure to check the following :

Bug report: Bug reporting
Help us: Add cards & Compiling.
Customize: Themes FAQ, All images thread, Abra's Mediafire folder

sandman423
Posts: 739
Joined: Thu Sep 10, 2009 8:59 pm

Issues with SVN?? Noob here

Post by sandman423 » Tue Jun 08, 2010 5:43 pm

I compiled the game and am able to load it but when I try to play creatures I can tap the mana but when I play creatures they disappear.

Is anyone else having this issue?

Jean
Posts: 32
Joined: Tue Nov 18, 2008 5:12 am

Re: R2079 - Rules are broken.

Post by Jean » Tue Jun 08, 2010 5:47 pm

Um, ok, my fault.
R2080 fixes it, sorry for the noise.

abrasax
Posts: 976
Joined: Wed Oct 15, 2008 7:46 am
Location: Switzerland

Re: Issues with SVN?? Noob here

Post by abrasax » Tue Jun 08, 2010 8:08 pm

Hi,

I let you read the following : viewtopic.php?f=4&t=1547

will merge both later.
We need your Help !!!
New to wagic ? Be sure to check the following :

Bug report: Bug reporting
Help us: Add cards & Compiling.
Customize: Themes FAQ, All images thread, Abra's Mediafire folder

Post Reply