Bugs 0.6.0

Do not post feature requests here, please.
Before posting bugs report check the Image Bug reporting help & guidelines
Forum rules
Do not post Features/Improvments request here (i.e : AI being stupid is not a bug, not being able to do a mulligan is not a bug, etc..etc..)
Before posting, please read the Bugs reporting guideline
Post Reply
wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

Bugs 0.6.0

Post by wololo » Wed Apr 22, 2009 12:06 am

Beta testers, please post your bugs here, thanks :)

mark_simplicidad
Posts: 8
Joined: Tue Mar 31, 2009 6:09 am

Re: Bugs 0.6.0

Post by mark_simplicidad » Wed Apr 22, 2009 1:45 am

i would just like to share that i haven't found any bug yet, especially on those items you mentioned to me wololo. im playing with 2135 cards in my database all of them having pictures except those on the Mercadian Expansion.
i have a question here wololo, i have observed that i am experiencing more crash when playing with Cache set to 60, when i changed it to 30 i almost got no crash occurrences. i am using PSP Slim with CFW 4.0.
i love the change in the shop!hehehe
i would like to suggest a change on the first booster box given, can we use other core set like 10ED?instead of the RV ED?
for some of the dual land cards specially on the 10ED expansion, when you use it you have options, add 1 mana, ability, ability, can we improve this?instead of ability can we put like add 1 red mana, like that.hehehe
ALL HAIL WTH!!!

NyghtcrawleR
Posts: 328
Joined: Thu Dec 11, 2008 4:07 am
Location: Planeswalking

Re: Bugs 0.6.0

Post by NyghtcrawleR » Wed Apr 22, 2009 3:02 am

So far on the default value of 20 on a fat psp I havent seen any crashes really even with all but 3 sets having images.

I did have one random crash so far when I clicked to return from the main menu from within a game. Other than that, no crashes.
"Real Magic" Graphic Mod & Image sets: viewtopic.php?f=3&t=318

Dr.Solomat
Posts: 975
Joined: Mon Dec 15, 2008 5:12 pm
Location: Germany

Re: Bugs 0.6.0

Post by Dr.Solomat » Wed Apr 22, 2009 6:36 am

Game is pretty stabile now!

Its pretty cool, but I have to test Momir (not activated yet)!


Great work wololo!
Sets Coded/Released: Legends, Visions, Weatherlight, Tempest, Stronghold, Portal I & III, Urza's Saga BLOCK, Mercadian Masques, Invasion BLOCK, Mirrodin, Ravnica, Guildpact, Conflux, Alara Reborn

superhiro
Posts: 151
Joined: Thu Nov 13, 2008 1:28 pm

Re: Bugs 0.6.0

Post by superhiro » Wed Apr 22, 2009 4:08 pm

Yeah, I agree, it's pretty stable. I played for the whole day and only encountered one crash, which was in Momir Basic mode, but I don't really know what caused it... just happened.

I also have images enabled for most sets and it seems to work just fine.

Counterspells are still buggy as heck, and it would be great to have them fixed.

Other than that, I would REALLY like a different shop background. It just does not fit at all, some sort of brownish, woodish background would be way better.

NyghtcrawleR
Posts: 328
Joined: Thu Dec 11, 2008 4:07 am
Location: Planeswalking

Re: Bugs 0.6.0

Post by NyghtcrawleR » Wed Apr 22, 2009 10:35 pm

superhiro wrote:Yeah, I agree, it's pretty stable. I played for the whole day and only encountered one crash, which was in Momir Basic mode, but I don't really know what caused it... just happened.

I also have images enabled for most sets and it seems to work just fine.

Counterspells are still buggy as heck, and it would be great to have them fixed.

Other than that, I would REALLY like a different shop background. It just does not fit at all, some sort of brownish, woodish background would be way better.
You could always change the bg yourself, but the default should be better I would agree. The new layout is cool for it but the triangles are really jagged looking and would look much neater if they were smooth lines.

Counterspells dont ever work for me. Not even once. I know they are broken, but I cant even get them to ever work. Really wish this could be fixed soon :(
"Real Magic" Graphic Mod & Image sets: viewtopic.php?f=3&t=318

Pyros_70
Posts: 66
Joined: Wed Mar 25, 2009 4:42 pm

Re: Bugs 0.6.0

Post by Pyros_70 » Wed Apr 22, 2009 10:47 pm

PSP-2001 Slim (Daxter)
CFW 5.00 M33-6
Memory Card 4 gig with 1116 megs free

Clean install of Wagic 0.6.0
- Added card graphics and replaced card backs only.
- Menu graphics and avatars remain as released versions.
- Added the players folder from 0.5.1 so that I could have a "clean" collection and starter deck.

1) Multiple crashes entering the shop. Selecting the shop freezes the PSP 3 out 4 times. Oddly on an identical PSP but with far more sets enabled, it functions correctly.
2) Music still stutters when leaving the shop.
3) The shop background picture needs changing. Makes it difficult to read. I am trying different pics in the GIMP washing them out so that they don't distract, and also just using gradients.
4) Momir mode gives an automatic win giving 913 credits. Oddly on an identical PSP but with far more sets enabled, it functions correctly.

I suspect the problem may be coming frm the players folder I used from 0.5.1 but I can't be positive.

NyghtcrawleR
Posts: 328
Joined: Thu Dec 11, 2008 4:07 am
Location: Planeswalking

Re: Bugs 0.6.0

Post by NyghtcrawleR » Wed Apr 22, 2009 11:36 pm

Then test that to check, otherwise it would be hard to know what is really happening.

On my fat psp I did copy over my decks and earned cards from v.4.1 and havent had any problems in that regard.
"Real Magic" Graphic Mod & Image sets: viewtopic.php?f=3&t=318

Pyros_70
Posts: 66
Joined: Wed Mar 25, 2009 4:42 pm

Re: Bugs 0.6.0

Post by Pyros_70 » Thu Apr 23, 2009 12:22 am

The problem is that I don't have another Players folder to use besides the one that has a collection.dat with cards from sets not included in the release. Such as The Dark, Onslaught, etc... when I use my 0.5.1 folder with retro (copyrighted) avatars and backgrounds and symbols updated with just the items that changed it seems to work ok. Is there an official Players folder to use with 0.6.0 so I don't have to guess?
Many users may be downloading Wagic for the first time, so I thought I'd test it that way.

wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

Re: Bugs 0.6.0

Post by wololo » Thu Apr 23, 2009 12:27 am

@Pyros_70
1) Multiple crashes entering the shop. Selecting the shop freezes the PSP 3 out 4 times. Oddly on an identical PSP but with far more sets enabled, it functions correctly.
4) Momir mode gives an automatic win giving 913 credits. Oddly on an identical PSP but with far more sets enabled, it functions correctly.
could you send me your "settings" and "player" directories (the ones from the PSP that fails). Just zip them and send them to me by PM, or email at wagic dot the dot homebrew at gmail dot com
2) Music still stutters when leaving the shop.
Yeah, this can't be avoided with my current knowledge of the system. A save is performed on the memory stick when you leave the shop, and concurrent accesses don't work very well :(
3) The shop background picture needs changing. Makes it difficult to read. I am trying different pics in the GIMP washing them out so that they don't distract, and also just using gradients.
Agreed.


@everyone:
Agreed with the triangles being very "8 bit" right now too.
I've received enough feedback to be confident that version 0.6.0 is not less stable than 0.5.1, so I'll probably release it very soon with no change.

Depending on the release of the HEN, I might focus on design changes (shop, ingame...) or network features after that.
I'd still be happy to find developers to help me fixing bugs such as the counterspells' one :D

Post Reply