[hbl r100, fw 6.31, golf exploit] General stability issues

This forum is locked, but kept for archiving purpose. If you want to discuss Half-Byte Loader or PSP homebrews, we now recommend our sister forum http://wololo.net/talk
Forum rules
Do not post requests/bug reports regarding versions of the HBL that you didn't download from wololo.net, I do not offer support for other people's versions, thanks!
Locked
erp
Posts: 7
Joined: Sun Sep 12, 2010 10:34 pm

[hbl r100, fw 6.31, golf exploit] General stability issues

Post by erp » Tue Sep 14, 2010 9:27 pm

Hi all,

I'm new to hbl, but very impressed so far. However, I am running into a few general stability issues.

I'm running hbl r100 using the Golf exploit on a PSP1003 (fat & white).

The issues I'm experiencing are as follows:

1. Menu hangs if loaded for more than about 30 secs, regardless of whether I'm scrolling it or just leaving at alone. This happens 100% of the time

2. Menu sometimes menu doesn't appear. This happens about 3/5 times. The white-text "Starting HBL" screen appears, but once it disappears the menu never actually appears -- it just hangs on a black screen

3. I've very rarely been able to quit from an app back to the menu (I honestly think I've only managed this once). It usually just hangs on black

4. Hung once (out of many times) on the "Starting HBL" screen, with the last message being "Freeing memory"

The only configuration change I've made is to change which directory is pointed at at startup.

I've read other posts that suggest that some of these problems (1, 2, maybe 3) could be caused by WMenu rather than hbl itself. However, I've not been able to find information on how to change the menu, or indeed what alternative menus are available. Any advice on this would also be much appreciated.

I'm thrilled there's now a homebrew solution that doesn't require firmware hacks -- keep up the fantastic work!

Cheers,

erp.

wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

Re: [hbl r100, fw 6.31, golf exploit] General stability issues

Post by wololo » Wed Sep 15, 2010 4:52 am

general instability is unfortunately a price to pay as long as we don't have a perfect syscall estimation (such as what we have on 6.20) but I know JJS is working on it.
I'll have a look at the "wMenu freezing after 30 seconds" thing. Never happened to me on the 6.20 go.
I've been also planning to make a post about alternate menu for a while on my blog. Stay tuned for that :)

erp
Posts: 7
Joined: Sun Sep 12, 2010 10:34 pm

Re: [hbl r100, fw 6.31, golf exploit] General stability issues

Post by erp » Wed Sep 15, 2010 6:37 am

Fantastic, I look forward to any further progress on this!

Thanks for the speedy and helpful reply.

erp.

Locked