Problems compiling

Problems compiling the game? Ask Here
Post Reply
wieczorek1990
Posts: 2
Joined: Wed Apr 02, 2014 11:44 am

Problems compiling

Post by wieczorek1990 » Wed Apr 02, 2014 11:49 am

I had to add:
QT += opengl
to wagic-qt.pro because of #include <QtOpenGL> failing.
I also had to add
#include <stdint.h>
to ObjectAnalytics.h because of undefined int types.
Somebody please fix this on master.
I'm on Ubuntu 14.04, Qt 5.2.1.

Yeah and after compilation I get a segmentation fault:

Code: Select all

Uruchamianie /home/luke/Dokumenty/wagic/projects/build-wagic-qt-Desktop_Qt_5_2_1_GCC_64bit-Debug/wagic...
QEventLoop: Cannot be used without QApplication
QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.
User path /home/luke/.Wagic
System path /home/luke/Dokumenty/wagic/projects/build-wagic-qt-Desktop_Qt_5_2_1_GCC_64bit-Debug/Res
Current path /home/luke/Dokumenty/wagic/projects/build-wagic-qt-Desktop_Qt_5_2_1_GCC_64bit-Debug
FATAL: cannot find modrules.xml
Init ResourceManagerImpl : 0x2824000
21hgeParticleSystemInfo cache resized to 500000 bytes
7JSample cache resized to 1500000 bytes
8JTexture cache resized to 2000000 bytes
Threaded Version
8JTexture cache resized to 20000000 bytes
AttemptNew failed to load. Deleting cache item 0x281eb50
Destroying WCachedResource: menuicons.png
Can't locate 
menuicons.png
AttemptNew failed to load. Deleting cache item 0x2824870
Destroying WCachedResource: back.jpg
Can't locate 
back.jpg
AttemptNew failed to load. Deleting cache item 0x2824870
Destroying WCachedResource: back_thumb.jpg
Can't locate 
back_thumb.jpg
AttemptNew failed to load. Deleting cache item 0x2824870
Destroying WCachedResource: particles.png
Can't locate 
particles.png
AttemptNew failed to load. Deleting cache item 0x2825340
Destroying WCachedResource: phasebar.png
Can't locate 
phasebar.png
AttemptNew failed to load. Deleting cache item 0x2825340
Destroying WCachedResource: wood.png
Can't locate 
wood.png
AttemptNew failed to load. Deleting cache item 0x2824870
Destroying WCachedResource: gold.png
Can't locate 
gold.png
AttemptNew failed to load. Deleting cache item 0x2824870
Destroying WCachedResource: goldglow.png
Can't locate 
goldglow.png
AttemptNew failed to load. Deleting cache item 0x2824870
Destroying WCachedResource: backdrop.jpg
Can't locate 
backdrop.jpg
AttemptNew failed to load. Deleting cache item 0x2824870
Destroying WCachedResource: handback.png
Can't locate 
handback.png
AttemptNew failed to load. Deleting cache item 0x2824870
Destroying WCachedResource: shadows.png
Can't locate 
shadows.png
size of MTGCardInstance: 1336
size of MTGCard: 32
size of CardPrimitive: 344
size of ExtraCost: 48
size of ManaCost: 144
entergamestate:menuAttemptNew failed to load. Deleting cache item 0x28069d0
Destroying WCachedResource: menutitle.png
inserted item ptr 00000000 at index 2000000011
Can't locate 
menutitle.png
AttemptNew failed to load. Deleting cache item 0x2815790
Destroying WCachedResource: spade_ul.png
Can't locate 
spade_ul.png
AttemptNew failed to load. Deleting cache item 0x2815790
Destroying WCachedResource: spade_ur.png
Can't locate 
spade_ur.png
AttemptNew failed to load. Deleting cache item 0x21da350
Destroying WCachedResource: menuside.png
Can't locate 
menuside.png
Program nieoczekiwanie przerwał pracę.
/home/luke/Dokumenty/wagic/projects/build-wagic-qt-Desktop_Qt_5_2_1_GCC_64bit-Debug/wagic zakończył pracę błędem
Debugger stopped on this line:

Code: Select all

memcpy(&info, psi, sizeof(hgeParticleSystemInfo));

apollov
Posts: 6
Joined: Mon Oct 13, 2014 9:11 pm

Re: Problems compiling

Post by apollov » Tue Oct 14, 2014 12:37 am

Yes, I know it's necro, but I've got the answer :)
The reason why app is segfaulting is it has no idea where its resources are.
> User path /home/luke/.Wagic
> System path /home/luke/Dokumenty/wagic/projects/build-wagic-qt-Desktop_Qt_5_2_1_GCC_64bit-Debug/Res
> Current path /home/luke/Dokumenty/wagic/projects/build-wagic-qt-Desktop_Qt_5_2_1_GCC_64bit-Debug

These are paths app is trying to locate its resources.
I did
> cp projects/mtg/bin/Res/* ~/.Wagic/
Then run app — and it works.
Guess it uses cwd and home path for search. Also guess that it is configurable :)

Zethfox
Posts: 3022
Joined: Thu Jun 10, 2010 11:28 pm

Re: Problems compiling

Post by Zethfox » Tue May 24, 2016 2:43 pm

necro, the issue here is someone changed locate system resources from "bin/res" into just "/res" and added a linker file that clearly doesnt work on all IDEs VStudios being one of them.

Kellyshork
Posts: 3
Joined: Mon Dec 03, 2018 1:59 pm

Problems compiling

Post by Kellyshork » Mon Dec 10, 2018 5:06 am

You are having problems compiling wx? How did you configure it, and what was its output?

I make money like that:
I registered on this site, now every day I buy BTC and ETH when the price drops, then I sell when the price rises.
I spent only $ 10 at the very beginning, now I always have more than $ 1000 on my account, I withdraw money 1-2 times a week. I withdraw $ 500 at a time
It’s easy to trade here and now you don’t need to work :)
Image

Post Reply