Slow on PSP sometimes?

If you have a question about the git repository and the code, or if you have code to propose then please post in this forum.
Do not post request here.
wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

Re: Slow on PSP sometimes?

Post by wololo » Tue Jul 12, 2011 9:06 am

sandman423, I did a series of improvements recently to the SVN. Can you update (including your Res/graphics folder!!! ) and see if you still have the issues? I fixed most of the problems I was experiencing on my end, so I have good hopes this solved the major problems.

goojamin
Posts: 115
Joined: Wed Jul 28, 2010 2:54 pm

Re: Slow on PSP sometimes?

Post by goojamin » Tue Jul 12, 2011 11:50 am

I played a bit on r3788 last night and the slow down was definitely improved. I played 6 regular games, edited my deck and did some shopping at the card shop and checked out the trophy room a few times after unlocking new sets. At the end of the 6th game when the deck unlock screen came up it finally slowed to a crawl and I had to quit and reload (I assume the memory fragmentation finally caught up with me).

One question, on the deck unlock screen when the screen dims and the unlock message and money earned text comes up it seems to load a different play-field in the background than the one I had just been using (there seems to also be a decent delay after the end of the match and before this screen comes up and the cha-ching sound effect plays). I am using a profile named Mike (not the default one) and I have set it to use the gemstones theme. When the unlock message comes up it looks like it is loading the default wagic play-field in the background rather than just overlaying the play-field image I had just been playing on? Is this the intended behavoiour?

wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

Re: Slow on PSP sometimes?

Post by wololo » Tue Jul 12, 2011 12:28 pm

goojamin wrote:I played a bit on r3788 last night and the slow down was definitely improved. I played 6 regular games, edited my deck and did some shopping at the card shop and checked out the trophy room a few times after unlocking new sets. At the end of the 6th game when the deck unlock screen came up it finally slowed to a crawl and I had to quit and reload (I assume the memory fragmentation finally caught up with me).
This is still extremely disappointing. There used to be a time where you could play Wagic for 3h in a row without encountering a single problem...
One question, on the deck unlock screen when the screen dims and the unlock message and money earned text comes up it seems to load a different play-field in the background than the one I had just been using (there seems to also be a decent delay after the end of the match and before this screen comes up and the cha-ching sound effect plays). I am using a profile named Mike (not the default one) and I have set it to use the gemstones theme. When the unlock message comes up it looks like it is loading the default wagic play-field in the background rather than just overlaying the play-field image I had just been playing on? Is this the intended behavoiour?
I don't think this is the intended behavior.
By the way, can you try to play with the default theme? I also need to see if the gemstone theme could be causing your issues, or at least contributing to it.

goojamin
Posts: 115
Joined: Wed Jul 28, 2010 2:54 pm

Re: Slow on PSP sometimes?

Post by goojamin » Tue Jul 12, 2011 4:02 pm

I will try tonight with the default theme and let you know how it goes.

goojamin
Posts: 115
Joined: Wed Jul 28, 2010 2:54 pm

Re: Slow on PSP sometimes?

Post by goojamin » Sun Jul 17, 2011 1:01 am

Hi Wololo,

Sorry for the delay getting back to you. Real life has gotten in the way of my wagic addiction :)

Today I did find a find a few hours to test SVN r3800 and can confirm I am still seeing the unusual behavior with the unlock screen when using the gemstones theme (which I really like btw). When using this theme when the screen dims and the unlock screen appears it reloads the battlefield graphics with the default theme images. By doing this there is a decent delay from when the game ends and the unlock screen and sound effect play. I have also tried playing with the default theme and it does not appear to reload anything and the delay from game end to display of the unlock screen seems notably quicker. If I have some time in the coming days I will try out some other themes and see if the same issue is present. Also as always this is on my trusty ram challenged psp1000.

Thanks again to all devs for the great program!

wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

Re: Slow on PSP sometimes?

Post by wololo » Sun Jul 17, 2011 1:32 am

Thanks a lot for the feedback. I'll investigate. We won't have a fix for Wagic 0.16, but hopefully I'll have time to fix this before next release :)

goojamin
Posts: 115
Joined: Wed Jul 28, 2010 2:54 pm

Re: Slow on PSP sometimes?

Post by goojamin » Tue Jul 19, 2011 12:15 am

Hi Wololo,

I was just playing a few games using the white shrine theme that comes with Wagic (on the same SVN revision as before) and I unlocked a new set but do not see the background changing image issue or slowdown when using this theme. Perhaps the issue is gemstone theme specific? I think the next time I have some time I will try the gemstone theme but will turn off the dynamic theme part (sorry I forget the actual term for this, it is the part that changes the colour based on the cards in the deck) and see if that makes any difference.

Thanks again, 0.16.1 is looking like it will be a really good release!

Darth Agnon
Posts: 124
Joined: Mon Sep 22, 2014 8:00 pm
Location: United Kingdom
Contact:

Re: Slow on PSP sometimes?

Post by Darth Agnon » Fri Oct 17, 2014 1:21 pm

You mentioned something about the background changing at the end of a duel when using the Gemstone theme - Gemstone theme has a "Dynamic" mode, which changes the battlefield colour, depending on the deck colour you are using (or something like that). This may be part of the problem.
Image
Like Wagic? Check out my custom themes, etc. at viewtopic.php?f=9&t=66181
Wololo's article: http://wololo.net/2016/07/14/new-wagic- ... rth-agnon/

Post Reply