[FAQ] PSP Performance tips

Need help installing/playing Wagic? Post here
Post Reply
wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

[FAQ] PSP Performance tips

Post by wololo » Tue Aug 02, 2011 4:00 am

We're getting (too) many reports of performance issues from people playing on the PSP.
The PSP is a fairly old device, with about 200 times less ram than your average computer. This means that when you play Wagic on the PSP, you have to be careful about the performance.

Wagic by default doesn't ship with any card image, and that's the version we support. IF you play with cards image on your PSP (we know lots of you do) and are running into performance issues, then you have to try fixing the issue yourself before reporting any problem to the dev team:

Before reporting any "slowness" issues on the PSP, please try the following:
- confirm that the problem is really related to images: in the game options, set "disable card images" to yes, and see if it improves the performance dramatically. If so, your problem comes from card pictures and you can follow the steps below to improve performance.

- if you have a psp2000/3000 or go, install a CFW on it. It will double your amount of ram. Also make sure you are using the unsigned version of Wagic (the signed one will not use the additional ram)
- Make sure you are using "low res" images, and not high res images that are made for computers or tablets. Anything above 255x512 pixels will kill the performance on your psp.
- use tiny crop images instead of "full" images
- have all your lands be exactly the same card. If you have for example 12 swamps in your deck, make sure they are all the same card from the same edition, instead of various swamps from various editions. The same goes for all card in your deck: if you have several cards of the same name, it's better to have 4 times the same card from the same edition, than the same card from different editions. This will get the engine to load only one picture instead of several.
- use the default Wagic theme
- (if your problem is not related to images) avoid having too many "lord" cards in your deck (cards that say "all your XXX get YYY" such as goblin king, etc...)

Zethfox
Posts: 3029
Joined: Thu Jun 10, 2010 11:28 pm

Re: [FAQ] PSP Performance tips

Post by Zethfox » Tue Aug 02, 2011 12:16 pm

another thing to check is that you are using low res images on the psp.
using the hi-res images on psp will bring the game to a crawl.

Brenten
Posts: 2
Joined: Mon Dec 26, 2011 5:14 pm

Re: [FAQ] PSP Performance tips

Post by Brenten » Mon Dec 26, 2011 5:42 pm

hey dudes and ladies i have a psp 3000 ofw 6.60 and am playing a singed version from this page- http://endlessparadigm.com/forum/showth ... ?tid=25707
the issue is the cursor speed is so fast it skips from play to to exit in one button push. it skips over cards during play and i have to hold down the button and time it right to land on the right card or option ive tried reloading it and i posted on their site they refered me to woolo so yeah id really like to play it and fix this issue plz help! ps you guys rock! magic is awsome and where i live no one plays! and the closest shop is in waseca which is like an hour away! so this would be awsome. bye

Zethfox
Posts: 3029
Joined: Thu Jun 10, 2010 11:28 pm

Re: [FAQ] PSP Performance tips

Post by Zethfox » Tue Dec 27, 2011 11:39 am

v0.15.1?
thats old man, we're about to release version 17, the difference is close to 1500 new *unique* cards...I might be wrong but I'm pretty sure we now sign our psp releases so you don't need to download it from other sites, unfortunately because it was not one that we re-leased we would have to chalk it up to error made by the person who compiled that one.
maybe wololo will read this and be able to confirm if our releases are now signed, pretty sure they are but he can confirm it.

wololo
Site Admin
Posts: 3727
Joined: Wed Oct 15, 2008 12:42 am
Location: Japan

Re: [FAQ] PSP Performance tips

Post by wololo » Tue Dec 27, 2011 11:59 am

Brenten, this is a known bug that we fixed recently. Delete your entire wagic installation (both the PSP/GAME/WTH folder and the PSP/wagic_res folder), and redownload it from the download page: http://wololo.net/wagic/download/

This should fix your issue.

Brenten
Posts: 2
Joined: Mon Dec 26, 2011 5:14 pm

Re: [FAQ] PSP Performance tips

Post by Brenten » Wed Dec 28, 2011 11:02 pm

awsome! thank you so very much, now if there was just a way to make me not suck so bad at wagic! i havent played in forever. thanks :lol:

User avatar
Bas
Posts: 411
Joined: Sat Dec 26, 2015 10:55 pm
Location: Germany

Re: [FAQ] PSP Performance tips

Post by Bas » Tue Jan 26, 2016 6:16 pm

Guess LME counts as a custom FW?
https://en.wikibooks.org/wiki/PSP/ME_CFW

Do i need to adjust any settings in order to get a performance boost?
(Such as CPU Clock Game/XMB speed...)

sandman423
Posts: 739
Joined: Thu Sep 10, 2009 8:59 pm

Re: [FAQ] PSP Performance tips

Post by sandman423 » Wed Jan 27, 2016 8:03 pm

I have a PSP 3000 and I keep getting a Blue Screen of Death when using CFW 6.60 and if I play a BW Deck using life gain...It crashes at different times so can't figure out what it is...

I usually make 100 Singleton card decks kind of like an EDH Deck and so far Mono Green has been fine/Kozilek Mono Artifacts/Titania EDH and they are all fine...

does it have to do with How many decks I am saving? I notice if I make 6 decks in game then I start getting the blue screen crash.

User avatar
Bas
Posts: 411
Joined: Sat Dec 26, 2015 10:55 pm
Location: Germany

Re: [FAQ] PSP Performance tips

Post by Bas » Sun Feb 07, 2016 1:58 am

DDid you try with disabled images?

I also encounter a lot of BSODs vs certain Ai enemy(s).

Post Reply