Firmware Reinstaller for PSVita released – Life Insurance if you’re messing around

Aurora

I'm a girl that's liked technology from day 1. Mostly interested in the PSVita/PSP scene but I've always modded my stuff when it's possible, that is :)Contact me via DM at @KawaiiAuroraA on Twitter if you have any questions/concerns about my articles or if you have any article requests.

31 Responses

  1. solidsnake says:

    Great Work!

  2. JamesJamason says:

    I suppose this doesn’t protect against upgrading the firmware

  3. JK0cr says:

    Lets say that you installed one of those evil bricker VPKs games. Does this help in that situation?

  4. Razorbacktrack says:

    Perfect! Now we can fix the mess of Silica’s Apps

  5. Anonymous says:

    Guy who makes controversial vpk makes software to revert it

    We’ve gone full circle

  6. Tonbo says:

    Thank you for the article, Wololo. Looking forward to further developments, I love surprises.
    I also love dried lime powder, such astringent taste, try sprinkling it over spaghetti.

  7. anonanon says:

    “yes, he’s the controversial VPK guy; give him a break, he’s done some cool stuff and he’s another human afterall”

    Mate. I’m not touching anything that guy makes with a barge pole. Can’t believe anyone is.

  8. DSpider says:

    Here’s a crazy idea… maybe, I don’t know… NOT mess with the system files?

    Pretty crazy, right?

  9. Moondemon says:

    My FW is still 2.02 ….I guess I missed the time when the advice “Stay on the lowest firmware possible” got obsolete 🙂

  10. Huehuehuehuehue says:

    But will this work or will it just brick it?

  11. Not Tonbo says:

    All Asian hackers I implore you to go help on the hacking scene instead of rubbing your vita to ecchi games. Lend me your brains don’t be selfish.

  12. Asbel_Lhant says:

    Darn, I really thought the day has come for those in 3.61+ Firmware to enjoy a nice Downgrade. Still thanks this shows many possibilities, who knows maybe a downgrade app will soon arrive.

  13. mlc says:

    Why would you trust anything released by a guy who previously tricked people into running malicious code? Merely writing malware should surely be legal, but tricking people into using it and destroying data crosses a moral and legal line.

  14. xaliax says:

    Error: this system software cannot be used with this system. (C1-6562-9)

    • adover says:

      Why Would You Do That?….After Reading ALL Of The Articles??…XALIAX…..WOW, Hooked On Phonix Worked For Me!…

  15. SKGleba says:

    This Software cannot be used with this system!! Help

  16. Matthew says:

    If you’re getting an error that says “This software cannot be used with this system.”, it’s because you have to enable spoofing in Henkaku settings and spoof a firmware lower than 3.60. The PS Vita can’t update to 3.60 if it’s already on it lol.

  17. hurricane says:

    Answer me one thing, is it possible with this vpk that I can downgrade from version 3.65 to version 3.60?

Leave a Reply

Your email address will not be published. Required fields are marked *

Most comments are automatically approved, but in some cases, it might take up to 24h for your comments to show up on the site, if they need manual moderation. Thanks for your understanding